aboutsummaryrefslogtreecommitdiff
path: root/audio/gmsynth-lv2
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-06-09 18:38:00 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-06-09 18:38:00 +0000
commit8f9c91399253b5f129045ec586936ba5f4079588 (patch)
tree5757afb17dbad5857bbb7eac1ca577c7e7830577 /audio/gmsynth-lv2
parent21c11575c4ecbd96b00c779ca83c9f1d95ba3bb4 (diff)
downloadports-8f9c91399253b5f129045ec586936ba5f4079588.tar.gz
ports-8f9c91399253b5f129045ec586936ba5f4079588.zip
audio/gmsynth-lv2: Unbreak on non-Intel/AMD architectures
Notes
Notes: svn path=/head/; revision=472079
Diffstat (limited to 'audio/gmsynth-lv2')
-rw-r--r--audio/gmsynth-lv2/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/audio/gmsynth-lv2/Makefile b/audio/gmsynth-lv2/Makefile
index b5bf1ab8a7db..e1567690792f 100644
--- a/audio/gmsynth-lv2/Makefile
+++ b/audio/gmsynth-lv2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gmsynth
DISTVERSIONPREFIX= v
DISTVERSION= 0.3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
PKGNAMESUFFIX= -lv2
@@ -13,9 +13,6 @@ COMMENT= General MIDI LV2 Synth
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_armv6= fails to compile: unknown FP unit 'sse'
-BROKEN_armv7= fails to compile: unknown FP unit 'sse'
-
BUILD_DEPENDS= lv2>0:audio/lv2
LIB_DEPENDS= libfluidsynth.so:audio/fluidsynth
@@ -30,4 +27,12 @@ PLIST_FILES= lib/lv2/${PORTNAME}.lv2/GeneralUser_LV2.sf2 \
lib/lv2/${PORTNAME}.lv2/${PORTNAME}.ttl \
lib/lv2/${PORTNAME}.lv2/manifest.ttl
+OPTIONS_DEFINE_amd64= SSE
+OPTIONS_DEFINE_i386= SSE
+OPTIONS_DEFAULT_amd64= SSE
+OPTIONS_DEFAULT_i386= SSE
+
+SSE_MAKE_ENV= OPTIMIZATIONS="-msse -msse2 -mfpmath=sse -DNDEBUG"
+SSE_MAKE_ENV_OFF= OPTIMIZATIONS="-DNDEBUG"
+
.include <bsd.port.mk>