aboutsummaryrefslogtreecommitdiff
path: root/audio/gmsynth-lv2
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-11-08 01:18:56 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-11-08 01:44:19 +0000
commit9604cdac30a773934f465bb570dc21d02b869ff7 (patch)
tree2083d01a998421674474fa12ef4a13f7164432a0 /audio/gmsynth-lv2
parentdceaf660a726b36ac871827a7bbb70b89930f049 (diff)
downloadports-9604cdac30a773934f465bb570dc21d02b869ff7.tar.gz
ports-9604cdac30a773934f465bb570dc21d02b869ff7.zip
Diffstat (limited to 'audio/gmsynth-lv2')
-rw-r--r--audio/gmsynth-lv2/Makefile7
-rw-r--r--audio/gmsynth-lv2/distinfo6
-rw-r--r--audio/gmsynth-lv2/files/patch-Makefile18
3 files changed, 17 insertions, 14 deletions
diff --git a/audio/gmsynth-lv2/Makefile b/audio/gmsynth-lv2/Makefile
index 6ea7d4be8dfd..c32d6dc144df 100644
--- a/audio/gmsynth-lv2/Makefile
+++ b/audio/gmsynth-lv2/Makefile
@@ -1,6 +1,6 @@
PORTNAME= gmsynth
DISTVERSIONPREFIX= v
-DISTVERSION= 0.5.0
+DISTVERSION= 0.5.1
CATEGORIES= audio
PKGNAMESUFFIX= -lv2
@@ -15,10 +15,13 @@ BUILD_DEPENDS= lv2>0:audio/lv2
# FluidSynth is left bundled based on the project owner's request: https://github.com/x42/gmsynth.lv2/issues/2#issuecomment-441458303
USES= gmake gnome pkgconfig
+USE_GNOME= glib20
+
USE_GITHUB= yes
GH_ACCOUNT= x42
GH_PROJECT= ${PORTNAME}.lv2
-USE_GNOME= glib20
+
+BINARY_ALIAS= git=false
PLIST_FILES= lib/lv2/${PORTNAME}.lv2/GeneralUser_LV2.sf2 \
lib/lv2/${PORTNAME}.lv2/${PORTNAME}.so \
diff --git a/audio/gmsynth-lv2/distinfo b/audio/gmsynth-lv2/distinfo
index 1d02142bca6b..65db179a76fa 100644
--- a/audio/gmsynth-lv2/distinfo
+++ b/audio/gmsynth-lv2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1594787654
-SHA256 (x42-gmsynth.lv2-v0.5.0_GH0.tar.gz) = 25e6afd63bea140a41d259cecb0907fabb172a0d71cc2a86d3bd0d0c0277ae56
-SIZE (x42-gmsynth.lv2-v0.5.0_GH0.tar.gz) = 28776440
+TIMESTAMP = 1667864090
+SHA256 (x42-gmsynth.lv2-v0.5.1_GH0.tar.gz) = e8382b2263f1bd2c9791ba34a33b7a2ca94ba19d45957f075898416f56ccfa4d
+SIZE (x42-gmsynth.lv2-v0.5.1_GH0.tar.gz) = 28951324
diff --git a/audio/gmsynth-lv2/files/patch-Makefile b/audio/gmsynth-lv2/files/patch-Makefile
index b83236b423d9..5dcc6adcb94c 100644
--- a/audio/gmsynth-lv2/files/patch-Makefile
+++ b/audio/gmsynth-lv2/files/patch-Makefile
@@ -1,11 +1,11 @@
---- Makefile.orig 2019-02-24 17:24:37 UTC
+--- Makefile.orig 2022-10-31 15:07:16 UTC
+++ Makefile
-@@ -9,7 +9,7 @@ MANDIR ?= $(PREFIX)/share/man/man1
- # see http://lv2plug.in/pages/filesystem-hierarchy-standard.html, don't use libdir
- LV2DIR ?= $(PREFIX)/lib/lv2
-
--OPTIMIZATIONS ?= -msse -msse2 -mfpmath=sse -ffast-math -fomit-frame-pointer -O3 -fno-finite-math-only -DNDEBUG
-+OPTIMIZATIONS ?= $(PORT_SIMD_FLAGS) -ffast-math -fomit-frame-pointer -fno-finite-math-only -DNDEBUG
- CFLAGS ?= -Wall -g -Wno-unused-function
- STRIP ?= strip
+@@ -26,7 +26,7 @@ ifneq (,$(findstring 86,$(MACHINE)))
+ endif
+ ifeq ($(HAVE_SSE),yes)
+- OPTIMIZATIONS ?= -msse -msse2 -mfpmath=sse --fast-math -fomit-frame-pointer -O3 -fno-finite-math-only -DNDEBUG
++ OPTIMIZATIONS ?= $(PORT_SIMD_FLAGS) -ffast-math -fomit-frame-pointer -O3 -fno-finite-math-only -DNDEBUG
+ else
+ OPTIMIZATIONS ?= -fomit-frame-pointer -O3 -fno-finite-math-only -DNDEBUG
+ endif