aboutsummaryrefslogtreecommitdiff
path: root/audio/gmusicbrowser
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-17 14:27:39 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-17 14:27:39 +0000
commit1670d9180bfe9d08b30fde91234b3516602ef861 (patch)
tree7cd038bf43398ef067ab3884e85870f625729242 /audio/gmusicbrowser
parent90acd49d3df53bbeb800d48dbe8465911a327408 (diff)
downloadports-1670d9180bfe9d08b30fde91234b3516602ef861.tar.gz
ports-1670d9180bfe9d08b30fde91234b3516602ef861.zip
Support stage
Fix shebang
Notes
Notes: svn path=/head/; revision=340045
Diffstat (limited to 'audio/gmusicbrowser')
-rw-r--r--audio/gmusicbrowser/Makefile61
-rw-r--r--audio/gmusicbrowser/pkg-plist19
2 files changed, 39 insertions, 41 deletions
diff --git a/audio/gmusicbrowser/Makefile b/audio/gmusicbrowser/Makefile
index a855d2bf1b12..2afb71d3c61a 100644
--- a/audio/gmusicbrowser/Makefile
+++ b/audio/gmusicbrowser/Makefile
@@ -12,63 +12,42 @@ COMMENT= Jukebox for large collections of mp3/ogg/flac/mpc files
RUN_DEPENDS= p5-Gtk2>=1.0:${PORTSDIR}/x11-toolkits/p5-Gtk2
NO_BUILD= yes
-NO_STAGE= yes
-MAN1= gmusicbrowser.1
PORTDOCS= AUTHORS COPYING README NEWS INSTALL layout_doc.html
PORTDATA= *
+USES= shebangfix
+SHEBANG_FILES= *.pl
+
OPTIONS_DEFINE= GSTREAMER MPLAYER DBUS WEBKIT NLS LIBNOTIFY
OPTIONS_DEFAULT=MPLAYER
-LIBNOTIFY_DESC= Desktop notification
+LIBNOTIFY_DESC= Desktop notification
WEBKIT_DESC= Enable embedded web browser
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MGSTREAMER}
-RUN_DEPENDS+= p5-GStreamer>=0:${PORTSDIR}/multimedia/p5-GStreamer
-.endif
-
-.if ${PORT_OPTIONS:MMPLAYER}
-RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
-.endif
-
-.if ${PORT_OPTIONS:MDBUS}
-RUN_DEPENDS+= p5-Net-DBus>=1.0:${PORTSDIR}/devel/p5-Net-DBus
-.endif
-
-.if ${PORT_OPTIONS:MWEBKIT}
-RUN_DEPENDS+= p5-Gtk2-WebKit>=0:${PORTSDIR}/www/p5-Gtk2-WebKit
-.endif
-
-.if ${PORT_OPTIONS:MLIBNOTIFY}
-RUN_DEPENDS+= pt-Gtk2-Notify>=0.05:${PORTSDIR}/devel/p5-Gtk2-Notify
-.endif
+GSTREAMER_RUN_DEPENDS= p5-GStreamer>=0:${PORTSDIR}/multimedia/p5-GStreamer
+MPLAYER_RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
+DBUS_RUN_DEPENDS= p5-Net-DBus>=1.0:${PORTSDIR}/devel/p5-Net-DBus
+WEBKIT_RUN_DEPENDS= p5-Gtk2-WebKit>=0:${PORTSDIR}/www/p5-Gtk2-WebKit
+LIBNOTIFY_RUN_DEPENDS= pt-Gtk2-Notify>=0.05:${PORTSDIR}/devel/p5-Gtk2-Notify
+OPTIONS_SUB= yes
.if defined(NOPORTDATA)
IGNORE= port data contain code, undefine NOPORTDATA
.endif
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.man ${MANPREFIX}/man/man1/${MAN1}
- @${MKDIR} ${DESKTOPDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${DESKTOPDIR}
- @${MKDIR} ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.man ${STAGEDIR}${MANPREFIX}/man/man1/${MAN1}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${STAGEDIR}${DESKTOPDIR}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
(cd ${WRKSRC} && (for d in layouts pix plugins; do \
- ${COPYTREE_SHARE} $$d ${DATADIR}; done) && \
- ${INSTALL_DATA} *.pm ${DATADIR} && \
- ${INSTALL_SCRIPT} iceserver.pl ${DATADIR})
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
-.endif
-.if ${PORT_OPTIONS:MNLS}
+ ${COPYTREE_SHARE} $$d ${STAGEDIR}${DATADIR}; done) && \
+ ${INSTALL_DATA} *.pm ${STAGEDIR}${DATADIR} && \
+ ${INSTALL_SCRIPT} iceserver.pl ${STAGEDIR}${DATADIR})
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
(cd ${WRKSRC}/locale && \
- ${COPYTREE_SHARE} \* ${PREFIX}/share/locale)
- (cd ${WRKSRC} && \
- ${FIND} locale -type f | ${SED} "s|^|share/|g" >> ${TMPPLIST})
-.endif
+ ${COPYTREE_SHARE} \* ${STAGEDIR}${PREFIX}/share/locale)
.include <bsd.port.mk>
diff --git a/audio/gmusicbrowser/pkg-plist b/audio/gmusicbrowser/pkg-plist
index 47bc8d9bc894..cd824423d751 100644
--- a/audio/gmusicbrowser/pkg-plist
+++ b/audio/gmusicbrowser/pkg-plist
@@ -1,2 +1,21 @@
bin/gmusicbrowser
share/applications/gmusicbrowser.desktop
+man/man1/gmusicbrowser.man.gz
+share/locale/cs/LC_MESSAGES/gmusicbrowser.mo
+share/locale/de/LC_MESSAGES/gmusicbrowser.mo
+share/locale/es/LC_MESSAGES/gmusicbrowser.mo
+share/locale/fi/LC_MESSAGES/gmusicbrowser.mo
+share/locale/fr/LC_MESSAGES/gmusicbrowser.mo
+share/locale/hu/LC_MESSAGES/gmusicbrowser.mo
+share/locale/it/LC_MESSAGES/gmusicbrowser.mo
+share/locale/ja/LC_MESSAGES/gmusicbrowser.mo
+share/locale/ko/LC_MESSAGES/gmusicbrowser.mo
+share/locale/nl/LC_MESSAGES/gmusicbrowser.mo
+share/locale/pl/LC_MESSAGES/gmusicbrowser.mo
+share/locale/pt/LC_MESSAGES/gmusicbrowser.mo
+share/locale/pt_BR/LC_MESSAGES/gmusicbrowser.mo
+share/locale/ru/LC_MESSAGES/gmusicbrowser.mo
+share/locale/sr/LC_MESSAGES/gmusicbrowser.mo
+share/locale/sv/LC_MESSAGES/gmusicbrowser.mo
+share/locale/zh_CN/LC_MESSAGES/gmusicbrowser.mo
+share/locale/zh_TW/LC_MESSAGES/gmusicbrowser.mo