aboutsummaryrefslogtreecommitdiff
path: root/audio/gnome-media/Makefile
diff options
context:
space:
mode:
authorJacques Vidrine <nectar@FreeBSD.org>1999-03-09 01:22:43 +0000
committerJacques Vidrine <nectar@FreeBSD.org>1999-03-09 01:22:43 +0000
commit775f0a9a8c0b1b65a6a8c863ea7d080a5c273a8b (patch)
tree2d81e0d4e1025f464234c567ca40479aee8cf4d8 /audio/gnome-media/Makefile
parentf4442a7aa7d134c8de8574845b26edddcac65935 (diff)
Multimedia applications for the GNOME desktop. Includes gtcd, a CDDB
aware CD player; GMix, for controlling the sound card's mixer; and VU-Meter, to slow down your desktop... Submitted by: Jeremy Lea <reg@shale.csir.co.za>
Notes
Notes: svn path=/head/; revision=17092
Diffstat (limited to 'audio/gnome-media/Makefile')
-rw-r--r--audio/gnome-media/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/audio/gnome-media/Makefile b/audio/gnome-media/Makefile
new file mode 100644
index 000000000000..8a17ad7c6c90
--- /dev/null
+++ b/audio/gnome-media/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: gnome-media
+# Version required: 1.0.1
+# Date created: 20 January 1999
+# Whom: Jeremy Lea <reg@shale.csir.co.za>
+#
+# $Id: $
+#
+
+DISTNAME= gnome-media-1.0.1
+PKGNAME= gnomemedia-1.0.1
+CATEGORIES= audio gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= gnome-1.0/sources
+
+MAINTAINER= reg@shale.csir.co.za
+
+BUILD_DEPENDS= panel:${PORTSDIR}/x11/gnomecore
+RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore
+
+# implicit dependencies:
+# gettext, esound, gnomelibs
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-ncurses \
+ --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome \
+ --with-gnome=${X11BASE}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+post-install:
+ @${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+
+.include <bsd.port.mk>