aboutsummaryrefslogtreecommitdiff
path: root/audio/gnormalize/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-06 18:00:10 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-06 18:00:10 +0000
commit89a9fdc5964c46351ee89934c5a0d7b563c0954a (patch)
tree455428e7f32697d5bf0e6e26216831056b0b6a27 /audio/gnormalize/Makefile
parent912ec3b830b163927fd8fc68a16afae7ed91b25d (diff)
downloadports-89a9fdc5964c46351ee89934c5a0d7b563c0954a.tar.gz
ports-89a9fdc5964c46351ee89934c5a0d7b563c0954a.zip
Notes
Diffstat (limited to 'audio/gnormalize/Makefile')
-rw-r--r--audio/gnormalize/Makefile50
1 files changed, 12 insertions, 38 deletions
diff --git a/audio/gnormalize/Makefile b/audio/gnormalize/Makefile
index 23cd35e5616d..0a682cab3c66 100644
--- a/audio/gnormalize/Makefile
+++ b/audio/gnormalize/Makefile
@@ -14,37 +14,31 @@ RUN_DEPENDS+= p5-Gtk2>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
wavegain:${PORTSDIR}/audio/wavegain
USES= perl5 shebangfix
-NO_STAGE= yes
USE_PERL5= run
INSTALLS_ICONS= yes
-SHEBANGFILES= ${PORTNAME}
+SHEBANG_FILES= ${PORTNAME}
NO_BUILD= yes
-MAN1= gnormalize.1
-
OPTIONS_DEFINE= MP3 OGG MP4 CDPARANOIA CDDB CDPLAY PLAC MAC MUSEPACK
OPTIONS_DEFAULT= MP3 OGG MP4
MAC_DESC= Monkey's Audio Encoding and Playback
CDPLAY_DESC= CD Playback
-.include <bsd.port.options.mk>
+MP3_RUN_DEPENDS= lame:${PORTSDIR}/audio/lame \
+ p5-MP3-Info>=0:${PORTSDIR}/audio/p5-MP3-Info
+OGG_RUN_DEPENDS= oggenc:${PORTSDIR}/audio/vorbis-tools
+MP4_RUN_DEPENDS= faac:${PORTSDIR}/audio/faac \
+ faad:${PORTSDIR}/audio/faad
+CDDB_RUN_DEPENDS= cddb.pl:${PORTSDIR}/audio/p5-CDDB_get
+CDPLAY_RUN_DEPENDS= p5-Audio-CD>=0:${PORTSDIR}/audio/p5-Audio-CD
+FLAC_RUN_DEPENDS= flac:${PORTSDIR}/audio/flac
+MAC_RUN_DEPENDS= mac:${PORTSDIR}/audio/mac
+MUSEPACK_RUN_DEPENDS= mppenc:${PORTSDIR}/audio/musepack
-.if ${PORT_OPTIONS:MMP3}
-RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame \
- p5-MP3-Info>=0:${PORTSDIR}/audio/p5-MP3-Info
-.endif
-
-.if ${PORT_OPTIONS:MOGG}
-RUN_DEPENDS+= oggenc:${PORTSDIR}/audio/vorbis-tools
-.endif
-
-.if ${PORT_OPTIONS:MMP4}
-RUN_DEPENDS+= faac:${PORTSDIR}/audio/faac \
- faad:${PORTSDIR}/audio/faad
-.endif
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCDPARANOIA} || ${PORT_OPTIONS:MCDDA2WAV}
RUN_DEPENDS+= cdda2wav:${PORTSDIR}/sysutils/cdrtools
@@ -52,26 +46,6 @@ RUN_DEPENDS+= cdda2wav:${PORTSDIR}/sysutils/cdrtools
RUN_DEPENDS+= cdparanoia:${PORTSDIR}/audio/cdparanoia
.endif
-.if ${PORT_OPTIONS:MCDDB}
-RUN_DEPENDS+= cddb.pl:${PORTSDIR}/audio/p5-CDDB_get
-.endif
-
-.if ${PORT_OPTIONS:MCDPLAY}
-RUN_DEPENDS+= p5-Audio-CD>=0:${PORTSDIR}/audio/p5-Audio-CD
-.endif
-
-.if ${PORT_OPTIONS:MFLAC}
-RUN_DEPENDS+= flac:${PORTSDIR}/audio/flac
-.endif
-
-.if ${PORT_OPTIONS:MMAC}
-RUN_DEPENDS+= mac:${PORTSDIR}/audio/mac
-.endif
-
-.if ${PORT_OPTIONS:MMUSEPACK}
-RUN_DEPENDS+= mppenc:${PORTSDIR}/audio/musepack
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's,^PREFIX=.*,PREFIX=${PREFIX},; \
s,^MANDIR=.*,MANDIR=${MANPREFIX}/man,; \