aboutsummaryrefslogtreecommitdiff
path: root/audio/gnump3d/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-27 13:25:00 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-27 13:25:00 +0000
commite9bf4e61f0765f02aedb9a70f885a97877e31fb9 (patch)
tree7ef12789c3acbcd4f67e0cedc10ad3c5beb447bf /audio/gnump3d/Makefile
parent01ee33ab8f33d57b9cc3ad78c74dcaacb80d8e2e (diff)
downloadports-e9bf4e61f0765f02aedb9a70f885a97877e31fb9.tar.gz
ports-e9bf4e61f0765f02aedb9a70f885a97877e31fb9.zip
Notes
Diffstat (limited to 'audio/gnump3d/Makefile')
-rw-r--r--audio/gnump3d/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/audio/gnump3d/Makefile b/audio/gnump3d/Makefile
new file mode 100644
index 000000000000..7b05e864ebb8
--- /dev/null
+++ b/audio/gnump3d/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# Ports collection makefile for: gnump3d
+# Date created: May 27, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnump3d
+PORTVERSION= 0.9.9.7
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+ALL_TARGET= freebsd
+
+MAN1= mp3d.1 mp3d.conf.1 mp3d-top.1
+
+post-patch:
+ @${PERL} -pi -e "s,^PREFIX,#PREFIX,g ; \
+ s,/usr/local,${PREFIX},g ; \
+ s,-pthread,${PTHREAD_LIBS},g" ${WRKSRC}/mkfiles/freebsd
+
+.include <bsd.port.mk>