aboutsummaryrefslogtreecommitdiff
path: root/audio/gnupod
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-12-08 14:44:03 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-12-08 14:44:03 +0000
commitfd7e1ea935614d8e02ecd42294fb8606086de8fc (patch)
treee5e3d39eff3588b5a28ae6ff4e3e064a11e936af /audio/gnupod
parentf3a4c3361f6f70d4f95f4b190909210d3b29d78b (diff)
downloadports-fd7e1ea935614d8e02ecd42294fb8606086de8fc.tar.gz
ports-fd7e1ea935614d8e02ecd42294fb8606086de8fc.zip
- Add LICENSE
- Add NO_ARCH - Add missing run-depends - Switch to options helpers
Notes
Notes: svn path=/head/; revision=403274
Diffstat (limited to 'audio/gnupod')
-rw-r--r--audio/gnupod/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/audio/gnupod/Makefile b/audio/gnupod/Makefile
index 56b4bfeef55e..9df0f49db31a 100644
--- a/audio/gnupod/Makefile
+++ b/audio/gnupod/Makefile
@@ -11,6 +11,9 @@ MASTER_SITES= SAVANNAH \
MAINTAINER= ports@FreeBSD.org
COMMENT= Set of Perl scripts for using an Apple iPod
+LICENSE= GPLv3 # or later
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= p5-MP3-Info>=0:${PORTSDIR}/audio/p5-MP3-Info \
p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate \
@@ -24,6 +27,7 @@ INFO= gnupod
USES= makeinfo perl5 tar:tgz
GNU_CONFIGURE= yes
NO_BUILD= yes
+NO_ARCH= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
CONFIGURE_ENV= ac_cv_path_PERL=${PERL}
@@ -31,20 +35,25 @@ CONFIGURE_ENV= ac_cv_path_PERL=${PERL}
OPTIONS_DEFINE= FLAC VORBIS DOCS
FLAC_BUILD_DEPENDS= p5-Audio-FLAC-Header>=0:${PORTSDIR}/audio/p5-Audio-FLAC-Header
+FLAC_RUN_DEPENDS= p5-Audio-FLAC-Header>=0:${PORTSDIR}/audio/p5-Audio-FLAC-Header
VORBIS_BUILD_DEPENDS= p5-Ogg-Vorbis-Header-PurePerl>=0:${PORTSDIR}/audio/p5-Ogg-Vorbis-Header-PurePerl \
oggdec:${PORTSDIR}/audio/vorbis-tools
+VORBIS_RUN_DEPENDS= p5-Ogg-Vorbis-Header-PurePerl>=0:${PORTSDIR}/audio/p5-Ogg-Vorbis-Header-PurePerl \
+ oggdec:${PORTSDIR}/audio/vorbis-tools
post-install:
+ # It tries to guess where it should install it's Perl modules, gets it
+ # wrong, and put them in BSDPAN, so move stuff at the right place.
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}
+ ${MV} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/GNUpod ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}
+ @${RMDIR} -p ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL} 2>/dev/null || :
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/CHANGES ${STAGEDIR}${DOCSDIR}
.for file in gnupodrc.example gnutunesdb.example gnupod.html mkspl.html \
gnupod.texi fdl.texi version.texi ipod.svg
${INSTALL_DATA} ${WRKSRC}/doc/${file} ${STAGEDIR}${DOCSDIR}
.endfor
- # It tries to guess where it should install it's Perl modules, gets it
- # wrong, and put them in BSDPAN, so move stuff at the right place.
- @${MKDIR} ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}
- ${MV} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/GNUpod ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}
- @${RMDIR} -p ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL} 2>/dev/null || :
.include <bsd.port.mk>