aboutsummaryrefslogtreecommitdiff
path: root/audio/gnuspeechsa
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-12-07 16:38:43 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-12-07 16:38:43 +0000
commit4386c6e7b06f3f56f779af30cd86f76f9b734ee2 (patch)
treec9685bc76a64ea814009c9e5d5be83580e529aef /audio/gnuspeechsa
parent662065c63c4eadedd02352e78099a0180e212dc1 (diff)
downloadports-4386c6e7b06f3f56f779af30cd86f76f9b734ee2.tar.gz
ports-4386c6e7b06f3f56f779af30cd86f76f9b734ee2.zip
- Remove -march=native; should unbreak aarch64/powerpc64
Notes
Notes: svn path=/head/; revision=455737
Diffstat (limited to 'audio/gnuspeechsa')
-rw-r--r--audio/gnuspeechsa/Makefile7
-rw-r--r--audio/gnuspeechsa/files/patch-CMakeLists.txt9
2 files changed, 11 insertions, 5 deletions
diff --git a/audio/gnuspeechsa/Makefile b/audio/gnuspeechsa/Makefile
index 89f5c2952c3f..4f84cd833cc2 100644
--- a/audio/gnuspeechsa/Makefile
+++ b/audio/gnuspeechsa/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnuspeechsa
PORTVERSION= 0.1.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= GNU/gnuspeech
@@ -13,9 +13,6 @@ COMMENT= Command line, or application-based speech output module of gnuspeech
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_aarch64= Does not build: the clang compiler does not support -march=native
-BROKEN_powerpc64= Does not build: the clang compiler does not support -march=native
-
USES= cmake compiler:c++11-lib
PORTDOCS= README
@@ -23,7 +20,7 @@ PORTDOCS= README
OPTIONS_DEFINE= DOCS
post-install-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/
.include <bsd.port.mk>
diff --git a/audio/gnuspeechsa/files/patch-CMakeLists.txt b/audio/gnuspeechsa/files/patch-CMakeLists.txt
index bc2ab43d6fb7..af8cb9ca2dfa 100644
--- a/audio/gnuspeechsa/files/patch-CMakeLists.txt
+++ b/audio/gnuspeechsa/files/patch-CMakeLists.txt
@@ -1,5 +1,14 @@
--- CMakeLists.txt.orig 2015-08-23 17:14:40 UTC
+++ CMakeLists.txt
+@@ -5,7 +5,7 @@ if(UNIX)
+ if(APPLE)
+ set(CMAKE_CXX_FLAGS "-std=c++11 -stdlib=libc++")
+ else()
+- set(CMAKE_CXX_FLAGS "-std=c++11 -Wall -Wextra -march=native")
++ set(CMAKE_CXX_FLAGS "-std=c++11 -Wall -Wextra")
+ endif()
+ endif()
+
@@ -137,7 +137,7 @@ if(UNIX AND NOT APPLE)
install(DIRECTORY src/ DESTINATION include/gnuspeechsa FILES_MATCHING PATTERN "*.h")
install(DIRECTORY data DESTINATION share/gnuspeech/gnuspeechsa)