aboutsummaryrefslogtreecommitdiff
path: root/audio/gnuspeechsa
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-10-20 23:19:21 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-10-20 23:19:21 +0000
commit81ab189f394ea39e2e32c598cbf5ce0f872b484a (patch)
tree33821de1a7450d9f17f6f3fa8f412a82e5b858bc /audio/gnuspeechsa
parent7c83376a4bcc25b0760ff535cdd4b6172ea0205a (diff)
downloadports-81ab189f394ea39e2e32c598cbf5ce0f872b484a.tar.gz
ports-81ab189f394ea39e2e32c598cbf5ce0f872b484a.zip
gnuspeech makes it easy to produce high quality computer speech
output, design new language databases, and create controlled speech stimuli for psychophysical experiments. gnuspeechsa is a cross-platform module of gnuspeech that allows command line, or application-based speech output WWW: https://www.gnu.org/software/gnuspeech/
Notes
Notes: svn path=/head/; revision=399883
Diffstat (limited to 'audio/gnuspeechsa')
-rw-r--r--audio/gnuspeechsa/Makefile27
-rw-r--r--audio/gnuspeechsa/distinfo2
-rw-r--r--audio/gnuspeechsa/files/patch-CMakeLists.txt11
-rw-r--r--audio/gnuspeechsa/pkg-descr8
-rw-r--r--audio/gnuspeechsa/pkg-plist87
5 files changed, 135 insertions, 0 deletions
diff --git a/audio/gnuspeechsa/Makefile b/audio/gnuspeechsa/Makefile
new file mode 100644
index 000000000000..a03f1a843c69
--- /dev/null
+++ b/audio/gnuspeechsa/Makefile
@@ -0,0 +1,27 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= gnuspeechsa
+PORTVERSION= 0.1.5
+CATEGORIES= audio
+MASTER_SITES= GNU/gnuspeech
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Command line, or application-based speech output module of gnuspeech
+
+LICENSE= GPLv3 # or later
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BROKEN_FreeBSD_9= does not build
+
+USES= cmake compiler:c++11-lib
+
+PORTDOCS= README
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/
+
+.include <bsd.port.mk>
diff --git a/audio/gnuspeechsa/distinfo b/audio/gnuspeechsa/distinfo
new file mode 100644
index 000000000000..463130daeacf
--- /dev/null
+++ b/audio/gnuspeechsa/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gnuspeechsa-0.1.5.tar.gz) = 5691ad47214e055062b9c3b04c19cea3ff3b5eb261cd5b16aa946e70bce8d088
+SIZE (gnuspeechsa-0.1.5.tar.gz) = 816802
diff --git a/audio/gnuspeechsa/files/patch-CMakeLists.txt b/audio/gnuspeechsa/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..bc2ab43d6fb7
--- /dev/null
+++ b/audio/gnuspeechsa/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2015-08-23 17:14:40 UTC
++++ CMakeLists.txt
+@@ -137,7 +137,7 @@ if(UNIX AND NOT APPLE)
+ install(DIRECTORY src/ DESTINATION include/gnuspeechsa FILES_MATCHING PATTERN "*.h")
+ install(DIRECTORY data DESTINATION share/gnuspeech/gnuspeechsa)
+ configure_file(gnuspeechsa.pc.pre gnuspeechsa.pc @ONLY)
+- install(FILES ${CMAKE_BINARY_DIR}/gnuspeechsa.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig/)
++ install(FILES ${CMAKE_BINARY_DIR}/gnuspeechsa.pc DESTINATION libdata/pkgconfig/)
+ endif()
+
+ #add_dependencies(gnuspeech_sa gnuspeechsa)
diff --git a/audio/gnuspeechsa/pkg-descr b/audio/gnuspeechsa/pkg-descr
new file mode 100644
index 000000000000..e5f66aecb1da
--- /dev/null
+++ b/audio/gnuspeechsa/pkg-descr
@@ -0,0 +1,8 @@
+gnuspeech makes it easy to produce high quality computer speech
+output, design new language databases, and create controlled speech
+stimuli for psychophysical experiments.
+
+gnuspeechsa is a cross-platform module of gnuspeech that allows
+command line, or application-based speech output
+
+WWW: https://www.gnu.org/software/gnuspeech/
diff --git a/audio/gnuspeechsa/pkg-plist b/audio/gnuspeechsa/pkg-plist
new file mode 100644
index 000000000000..e986e7a2b037
--- /dev/null
+++ b/audio/gnuspeechsa/pkg-plist
@@ -0,0 +1,87 @@
+bin/gnuspeech_sa
+bin/gnuspeech_sa_trm
+include/gnuspeechsa/Dictionary.h
+include/gnuspeechsa/Exception.h
+include/gnuspeechsa/KeyValueFileReader.h
+include/gnuspeechsa/Log.h
+include/gnuspeechsa/Text.h
+include/gnuspeechsa/VocalTractModelParameterValue.h
+include/gnuspeechsa/WAVEFileWriter.h
+include/gnuspeechsa/en/dictionary/DictionarySearch.h
+include/gnuspeechsa/en/dictionary/suffix_list.h
+include/gnuspeechsa/en/letter_to_sound/apply_stress.h
+include/gnuspeechsa/en/letter_to_sound/check_word_list.h
+include/gnuspeechsa/en/letter_to_sound/clusters.h
+include/gnuspeechsa/en/letter_to_sound/ends_with.h
+include/gnuspeechsa/en/letter_to_sound/final_s.h
+include/gnuspeechsa/en/letter_to_sound/ie_to_y.h
+include/gnuspeechsa/en/letter_to_sound/insert_mark.h
+include/gnuspeechsa/en/letter_to_sound/isp_trans.h
+include/gnuspeechsa/en/letter_to_sound/letter_to_sound.h
+include/gnuspeechsa/en/letter_to_sound/long_medial_vowels.h
+include/gnuspeechsa/en/letter_to_sound/mark_final_e.h
+include/gnuspeechsa/en/letter_to_sound/medial_s.h
+include/gnuspeechsa/en/letter_to_sound/medial_silent_e.h
+include/gnuspeechsa/en/letter_to_sound/member.h
+include/gnuspeechsa/en/letter_to_sound/stresstables.h
+include/gnuspeechsa/en/letter_to_sound/suffix.h
+include/gnuspeechsa/en/letter_to_sound/syllabify.h
+include/gnuspeechsa/en/letter_to_sound/tail.h
+include/gnuspeechsa/en/letter_to_sound/vowel_before.h
+include/gnuspeechsa/en/letter_to_sound/word_to_patphone.h
+include/gnuspeechsa/en/number_pronunciations.h
+include/gnuspeechsa/en/phonetic_string_parser/PhoneticStringParser.h
+include/gnuspeechsa/en/text_parser/NumberParser.h
+include/gnuspeechsa/en/text_parser/TextParser.h
+include/gnuspeechsa/en/text_parser/abbreviations.h
+include/gnuspeechsa/en/text_parser/special_acronyms.h
+include/gnuspeechsa/global.h
+include/gnuspeechsa/trm/BandpassFilter.h
+include/gnuspeechsa/trm/FIRFilter.h
+include/gnuspeechsa/trm/MovingAverageFilter.h
+include/gnuspeechsa/trm/NoiseFilter.h
+include/gnuspeechsa/trm/NoiseSource.h
+include/gnuspeechsa/trm/RadiationFilter.h
+include/gnuspeechsa/trm/ReflectionFilter.h
+include/gnuspeechsa/trm/SampleRateConverter.h
+include/gnuspeechsa/trm/TRMConfiguration.h
+include/gnuspeechsa/trm/Throat.h
+include/gnuspeechsa/trm/Tube.h
+include/gnuspeechsa/trm/WavetableGlottalSource.h
+include/gnuspeechsa/trm_control_model/Category.h
+include/gnuspeechsa/trm_control_model/Controller.h
+include/gnuspeechsa/trm_control_model/DriftGenerator.h
+include/gnuspeechsa/trm_control_model/Equation.h
+include/gnuspeechsa/trm_control_model/EventList.h
+include/gnuspeechsa/trm_control_model/FormulaSymbol.h
+include/gnuspeechsa/trm_control_model/IntonationPoint.h
+include/gnuspeechsa/trm_control_model/Model.h
+include/gnuspeechsa/trm_control_model/Parameter.h
+include/gnuspeechsa/trm_control_model/Posture.h
+include/gnuspeechsa/trm_control_model/PostureList.h
+include/gnuspeechsa/trm_control_model/Rule.h
+include/gnuspeechsa/trm_control_model/Symbol.h
+include/gnuspeechsa/trm_control_model/TRMControlModelConfiguration.h
+include/gnuspeechsa/trm_control_model/Transition.h
+include/gnuspeechsa/trm_control_model/XMLConfigFileReader.h
+include/gnuspeechsa/trm_control_model/XMLConfigFileWriter.h
+include/gnuspeechsa/xml/RapidXmlUtil.h
+include/gnuspeechsa/xml/StreamXMLWriter.h
+lib/libgnuspeechsa.so
+lib/libgnuspeechsa.so.0
+lib/libgnuspeechsa.so.0.1.5
+libdata/pkgconfig/gnuspeechsa.pc
+share/gnuspeech/gnuspeechsa/data/en/MainDictionary
+share/gnuspeech/gnuspeechsa/data/en/README
+share/gnuspeech/gnuspeechsa/data/en/intonation
+share/gnuspeech/gnuspeechsa/data/en/monet.xml
+share/gnuspeech/gnuspeechsa/data/en/trm.config
+share/gnuspeech/gnuspeechsa/data/en/trm_control_model.config
+share/gnuspeech/gnuspeechsa/data/en/voice_baby.config
+share/gnuspeech/gnuspeechsa/data/en/voice_female.config
+share/gnuspeech/gnuspeechsa/data/en/voice_large_child.config
+share/gnuspeech/gnuspeechsa/data/en/voice_male.config
+share/gnuspeech/gnuspeechsa/data/en/voice_small_child.config
+share/gnuspeech/gnuspeechsa/data/en/vowelTransitions
+share/gnuspeech/gnuspeechsa/data/en/vowelTransitions_2
+@comment @dir include/gnuspeechsa/rapidxml