aboutsummaryrefslogtreecommitdiff
path: root/audio/gogglesmm
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-06-05 18:10:29 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-06-05 18:10:29 +0000
commit6541f22285e6e09ecacb379b728d0becc6f134f0 (patch)
tree0e6c2e240bfd5ac91318ce1ba8723c312e5e6b63 /audio/gogglesmm
parent32abacc861f65a7359bc75c6acde0836224bca52 (diff)
downloadports-6541f22285e6e09ecacb379b728d0becc6f134f0.tar.gz
ports-6541f22285e6e09ecacb379b728d0becc6f134f0.zip
Fix build with SQLite 3.19.2
Approved by: portmgr (blanket)
Notes
Notes: svn path=/head/; revision=442678
Diffstat (limited to 'audio/gogglesmm')
-rw-r--r--audio/gogglesmm/Makefile1
-rw-r--r--audio/gogglesmm/files/patch-src-GMDatabase.h11
2 files changed, 11 insertions, 1 deletions
diff --git a/audio/gogglesmm/Makefile b/audio/gogglesmm/Makefile
index dc0a37b380fe..47a75d5af570 100644
--- a/audio/gogglesmm/Makefile
+++ b/audio/gogglesmm/Makefile
@@ -16,7 +16,6 @@ LIB_DEPENDS= libtag.so:audio/taglib \
libexpat.so:textproc/expat2 \
libFOX-1.7.so:x11-toolkits/fox17
-BROKEN= fails to compile: sqlite3.h:3712:16: elaborated type refers to a typedef
BROKEN_powerpc64= fails to compile: ap_mad.cpp:358:2: \#error fixme
USE_GITHUB= yes
diff --git a/audio/gogglesmm/files/patch-src-GMDatabase.h b/audio/gogglesmm/files/patch-src-GMDatabase.h
new file mode 100644
index 000000000000..d8bc9ce850ef
--- /dev/null
+++ b/audio/gogglesmm/files/patch-src-GMDatabase.h
@@ -0,0 +1,11 @@
+--- src/GMDatabase.h.orig 2017-03-29 02:18:22 UTC
++++ src/GMDatabase.h
+@@ -21,7 +21,7 @@
+
+ struct sqlite3_stmt;
+ struct sqlite3;
+-typedef struct Mem sqlite3_value;
++typedef struct sqlite3_value sqlite3_value;
+ struct sqlite3_context;
+
+