aboutsummaryrefslogtreecommitdiff
path: root/audio/goobox/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-24 23:37:25 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-24 23:37:25 +0000
commit4acc6fb2a411b291c9c210d82bafe7c62e71c77d (patch)
treebc16420eb52d65511ceb520c00171d219210a473 /audio/goobox/Makefile
parent97dfcc1b41c5b4581b1d73128a866beec069c5bf (diff)
downloadports-4acc6fb2a411b291c9c210d82bafe7c62e71c77d.tar.gz
ports-4acc6fb2a411b291c9c210d82bafe7c62e71c77d.zip
Notes
Diffstat (limited to 'audio/goobox/Makefile')
-rw-r--r--audio/goobox/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/audio/goobox/Makefile b/audio/goobox/Makefile
new file mode 100644
index 000000000000..0cafa575afe2
--- /dev/null
+++ b/audio/goobox/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: guikachu
+# Date created: 11 Nov 2004
+# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/audio/goobox/Makefile,v 1.25 2007/08/15 03:03:09 mezz Exp $
+#
+
+PORTNAME= goobox
+PORTVERSION= 1.9.2
+CATEGORIES= audio gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= CD player and ripper for GNOME Desktop environment
+
+LIB_DEPENDS= musicbrainz.4:${PORTSDIR}/audio/libmusicbrainz
+
+USE_XLIB= yes
+USE_GETTEXT= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui libglade2 libbonobo \
+ gnomedocutils nautiluscdburner
+USE_GSTREAMER= cdparanoia gconf core
+GNU_CONFIGURE= yes
+INSTALLS_OMF= yes
+INSTALLS_ICONS= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+GCONF_SCHEMAS= goobox.schemas
+
+OPTIONS= NOTIFY "Enable libnotify support" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_NOTIFY)
+LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+CONFIGURE_ARGS+= --enable-notification
+.else
+CONFIGURE_ARGS+= --disable-notification
+.endif
+
+.include <bsd.port.post.mk>