aboutsummaryrefslogtreecommitdiff
path: root/audio/goobox
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2007-06-01 20:43:43 +0000
committerMichael Johnson <ahze@FreeBSD.org>2007-06-01 20:43:43 +0000
commitf2ae9f3e0b9b1c92d2369bbc774cbb65829ee61c (patch)
treeb9dd381e57a7c820f31901234c6d3535f92e2fd6 /audio/goobox
parent52f174f280a98481c8ae9c24c7c085e4b6245a58 (diff)
downloadports-f2ae9f3e0b9b1c92d2369bbc774cbb65829ee61c.tar.gz
ports-f2ae9f3e0b9b1c92d2369bbc774cbb65829ee61c.zip
- Retire gstreamer 0.8.0
Notes
Notes: svn path=/head/; revision=192557
Diffstat (limited to 'audio/goobox')
-rw-r--r--audio/goobox/Makefile47
-rw-r--r--audio/goobox/distinfo3
-rw-r--r--audio/goobox/files/patch-src_cd-drive.c12
-rw-r--r--audio/goobox/files/patch-src_main.c51
-rw-r--r--audio/goobox/pkg-descr4
-rw-r--r--audio/goobox/pkg-plist48
6 files changed, 0 insertions, 165 deletions
diff --git a/audio/goobox/Makefile b/audio/goobox/Makefile
deleted file mode 100644
index 06e8c1fb8d99..000000000000
--- a/audio/goobox/Makefile
+++ /dev/null
@@ -1,47 +0,0 @@
-# New ports collection makefile for: guikachu
-# Date created: 11 Nov 2004
-# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
-#
-# $FreeBSD$
-# $MCom: ports/audio/goobox/Makefile,v 1.17 2006/07/25 06:20:43 mezz Exp $
-#
-
-PORTNAME= goobox
-PORTVERSION= 0.9.93
-PORTREVISION= 6
-CATEGORIES= audio gnome
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
-DIST_SUBDIR= gnome2
-
-MAINTAINER= gnome@FreeBSD.org
-COMMENT= CD player and ripper for GNOME Desktop environment
-
-RUN_DEPENDS= cddb-slave2-properties:${PORTSDIR}/audio/gnome-media
-
-USE_XLIB= yes
-USE_GETTEXT= yes
-USE_BZIP2= yes
-USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui libglade2 libbonobo \
- gnomedocutils
-USE_GSTREAMER80= cdparanoia gconf
-GNU_CONFIGURE= yes
-INSTALLS_OMF= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-
-GCONF_SCHEMAS= goobox.schemas
-
-OPTIONS= NOTIFY "Enable libnotify support" on
-
-.include <bsd.port.pre.mk>
-
-.if !defined(WITHOUT_NOTIFY)
-LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
-CONFIGURE_ARGS+= --enable-notification
-.else
-CONFIGURE_ARGS+= --disable-notification
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/audio/goobox/distinfo b/audio/goobox/distinfo
deleted file mode 100644
index 858faf3f6411..000000000000
--- a/audio/goobox/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (gnome2/goobox-0.9.93.tar.bz2) = d12dcf26907935ee4803107c572a5392
-SHA256 (gnome2/goobox-0.9.93.tar.bz2) = fffecbdccf6f1dfbd53d02a2daff882ce62970a563b48e8612957015f4d2939d
-SIZE (gnome2/goobox-0.9.93.tar.bz2) = 539913
diff --git a/audio/goobox/files/patch-src_cd-drive.c b/audio/goobox/files/patch-src_cd-drive.c
deleted file mode 100644
index 44f796b1aa44..000000000000
--- a/audio/goobox/files/patch-src_cd-drive.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/cd-drive.c.orig Sun Dec 24 22:45:32 2006
-+++ src/cd-drive.c Sun Dec 24 22:45:12 2006
-@@ -82,6 +82,9 @@ struct CDDrivePriv {
- char *udi;
- };
-
-+static int get_device_max_read_speed (char *device);
-+static int get_device_max_write_speed (char *device);
-+
- static CDDrive *cd_drive_new (void);
-
- /* Utility functions, be careful to have a match with what's use in the
diff --git a/audio/goobox/files/patch-src_main.c b/audio/goobox/files/patch-src_main.c
deleted file mode 100644
index eaf098579f63..000000000000
--- a/audio/goobox/files/patch-src_main.c
+++ /dev/null
@@ -1,51 +0,0 @@
---- src/main.c.orig Fri Nov 18 21:20:08 2005
-+++ src/main.c Mon Feb 20 22:41:55 2006
-@@ -47,7 +47,6 @@
-
- #ifdef HAVE_LIBNOTIFY
- #include <libnotify/notify.h>
--static NotifyHandle *notify_h = NULL;
- #endif /* HAVE_LIBNOTIFY */
-
- GtkWindow *main_window = NULL;
-@@ -193,7 +192,7 @@
-
- #ifdef HAVE_LIBNOTIFY
- if (! notify_init ("goobox"))
-- g_error ("Cannot initialize notification system.");
-+ g_warning ("Cannot initialize notification system.");
- #endif /* HAVE_LIBNOTIFY */
-
- goo_stock_init ();
-@@ -557,27 +556,10 @@
- int y)
- {
- #ifdef HAVE_LIBNOTIFY
-- NotifyIcon *icon = notify_icon_new_from_uri("goobox");
-- NotifyHints *hints = NULL;
--
-- if ((x >= 0) && (y >= 0)) {
-- hints = notify_hints_new ();
-- notify_hints_set_int (hints, "x", x);
-- notify_hints_set_int (hints, "y", y);
-- }
-+ if(!notify_is_initted())
-+ return;
-+ NotifyNotification *n = notify_notification_new (title,msg,"goobox",GTK_WIDGET (main_window));
-+ notify_notification_show(n, NULL);
-
-- notify_h = notify_send_notification (notify_h,
-- "device",
-- NOTIFY_URGENCY_NORMAL,
-- title,
-- msg,
-- icon,
-- TRUE, 0,
-- hints, // no hints
-- NULL, // no user data
-- 0);
--
-- if (icon != NULL)
-- notify_icon_destroy (icon);
- #endif /* HAVE_LIBNOTIFY */
- }
diff --git a/audio/goobox/pkg-descr b/audio/goobox/pkg-descr
deleted file mode 100644
index c263704fda75..000000000000
--- a/audio/goobox/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-Goobox is a CD player and ripper for the GNOME Desktop environment,
-it uses gstreamer to play and rip CDs and cddb-slave2 (distributed
-with gnome-media) to get and edit CD metadata such as track titles
-and album name.
diff --git a/audio/goobox/pkg-plist b/audio/goobox/pkg-plist
deleted file mode 100644
index 5cf5511492fb..000000000000
--- a/audio/goobox/pkg-plist
+++ /dev/null
@@ -1,48 +0,0 @@
-bin/goobox
-libdata/bonobo/servers/GNOME_Goobox.server
-share/gnome/application-registry/goobox.applications
-share/gnome/applications/goobox.desktop
-share/gnome/goobox/glade/goo_cover_chooser.glade
-share/gnome/goobox/glade/goobox.glade
-share/gnome/help/goobox/C/goobox.xml
-share/gnome/help/goobox/C/legal.xml
-share/gnome/omf/goobox/goobox-C.omf
-share/gnome/pixmaps/goobox.png
-share/locale/ar/LC_MESSAGES/goobox.mo
-share/locale/bg/LC_MESSAGES/goobox.mo
-share/locale/cs/LC_MESSAGES/goobox.mo
-share/locale/da/LC_MESSAGES/goobox.mo
-share/locale/de/LC_MESSAGES/goobox.mo
-share/locale/el/LC_MESSAGES/goobox.mo
-share/locale/en_CA/LC_MESSAGES/goobox.mo
-share/locale/en_GB/LC_MESSAGES/goobox.mo
-share/locale/es/LC_MESSAGES/goobox.mo
-share/locale/eu/LC_MESSAGES/goobox.mo
-share/locale/fi/LC_MESSAGES/goobox.mo
-share/locale/fr/LC_MESSAGES/goobox.mo
-share/locale/hu/LC_MESSAGES/goobox.mo
-share/locale/it/LC_MESSAGES/goobox.mo
-share/locale/ja/LC_MESSAGES/goobox.mo
-share/locale/ko/LC_MESSAGES/goobox.mo
-share/locale/lt/LC_MESSAGES/goobox.mo
-share/locale/nb/LC_MESSAGES/goobox.mo
-share/locale/ne/LC_MESSAGES/goobox.mo
-share/locale/nl/LC_MESSAGES/goobox.mo
-share/locale/no/LC_MESSAGES/goobox.mo
-share/locale/pa/LC_MESSAGES/goobox.mo
-share/locale/pl/LC_MESSAGES/goobox.mo
-share/locale/pt/LC_MESSAGES/goobox.mo
-share/locale/pt_BR/LC_MESSAGES/goobox.mo
-share/locale/ru/LC_MESSAGES/goobox.mo
-share/locale/rw/LC_MESSAGES/goobox.mo
-share/locale/sq/LC_MESSAGES/goobox.mo
-share/locale/sv/LC_MESSAGES/goobox.mo
-share/locale/zh_CN/LC_MESSAGES/goobox.mo
-share/locale/zh_TW/LC_MESSAGES/goobox.mo
-@dirrm share/gnome/omf/goobox
-@dirrm share/gnome/help/goobox/C
-@dirrm share/gnome/help/goobox
-@dirrm share/gnome/goobox/glade
-@dirrm share/gnome/goobox
-@dirrmtry share/locale/rw/LC_MESSAGES
-@dirrmtry share/locale/rw