aboutsummaryrefslogtreecommitdiff
path: root/audio/gqmpeg/Makefile
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2002-07-18 13:52:33 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2002-07-18 13:52:33 +0000
commit4f592a46db847491f2e46b8fd9a87f327c690266 (patch)
treef7afa986e668a259dc9f96a2bb0fba3c11019b61 /audio/gqmpeg/Makefile
parent17381da35bcb106ec908682bd07f6b09e993a954 (diff)
Notes
Diffstat (limited to 'audio/gqmpeg/Makefile')
-rw-r--r--audio/gqmpeg/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/audio/gqmpeg/Makefile b/audio/gqmpeg/Makefile
index 99e1aabe3417..e5b01ee67ce9 100644
--- a/audio/gqmpeg/Makefile
+++ b/audio/gqmpeg/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gqmpeg
-PORTVERSION= 0.16.0
+PORTVERSION= 0.17.0
CATEGORIES+= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,6 +20,7 @@ RUN_DEPENDS= mpg321:${PORTSDIR}/audio/mpg321
RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
.endif
+USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_GTK= yes
USE_LIBTOOL= yes
@@ -47,11 +48,12 @@ pre-everything::
.endif
post-patch:
- @find ${WRKSRC} -name 'Makefile.in*' | xargs ${PERL} -pi.orig -e \
- 's|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+ @${FIND} ${WRKSRC} -name 'Makefile.in*' | ${XARGS} ${REINPLACE_CMD} \
+ -E -e 's|(SUBDIRS[[:space:]]+=.*)intl|\1| ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ;'
.if defined(WITH_MPG321)
- @${PERL} -pi.orig -e \
- 's/^(#define MPG123_BINARY "mpg)123"/$${1}321"/' \
+ @${REINPLACE_CMD} -E -e \
+ 's/^(#define MPG123_BINARY "mpg)123"/\1321"/' \
${WRKSRC}/src/io_mpg123.c
.endif