aboutsummaryrefslogtreecommitdiff
path: root/audio/gramofile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-05-07 09:21:05 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-05-07 09:21:05 +0000
commita282063d3fc0226a9f8ce17fff36c0f24be99596 (patch)
tree2c0a8f67fb0f5c8dbf4efdbb1246dcacb66c0ecf /audio/gramofile
parent9da1deab80c3b82ca946c353ed1420a5c513c76d (diff)
downloadports-a282063d3fc0226a9f8ce17fff36c0f24be99596.tar.gz
ports-a282063d3fc0226a9f8ce17fff36c0f24be99596.zip
Notes
Diffstat (limited to 'audio/gramofile')
-rw-r--r--audio/gramofile/Makefile27
-rw-r--r--audio/gramofile/files/patch-swig35
-rw-r--r--audio/gramofile/files/post-patch-cmf3-swig93
-rw-r--r--audio/gramofile/pkg-plist5
4 files changed, 2 insertions, 158 deletions
diff --git a/audio/gramofile/Makefile b/audio/gramofile/Makefile
index 1099c9423b6b..b48ee0a93c00 100644
--- a/audio/gramofile/Makefile
+++ b/audio/gramofile/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gramofile
PORTVERSION= 1.6P
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= audio
MASTER_SITES= http://www.opensourcepartners.nl/~costar/gramofile/
@@ -19,30 +19,15 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= nox@FreeBSD.org
COMMENT= Audio recording and tick/scratch reduction for e.g. vinyl records
-BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig11
LIB_DEPENDS= fftw.2:${PORTSDIR}/math/fftw
-.if defined(WITH_SWIGDEPS)
-RUN_DEPENDS+= ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple
-RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame
-RUN_DEPENDS+= sox:${PORTSDIR}/audio/sox
-.endif
-
-ALL_TARGET= gramofile perl-swig
+ALL_TARGET= gramofile
USE_GMAKE= yes
USE_PERL5= yes
PERLCOREDIR= ${LOCALBASE}/lib/perl5/${PERL_VERSION}/mach/CORE
MAKE_ARGS+= PERLCOREDIR=${PERLCOREDIR}
-pre-everything::
-.if !defined(WITH_SWIGDEPS)
- @${ECHO_MSG} "If you want to use the perl-swig example,"
- @${ECHO_MSG} "${EXAMPLESDIR}/wav2mp3.pl,"
- @${ECHO_MSG} "you need additional depenencies. You can have this port install them by"
- @${ECHO_MSG} "defining WITH_SWIGDEPS."
-.endif
-
post-patch:
${RM} ${WRKSRC}/debian/20-warning-fixes.dpatch
for i in ${WRKSRC}/debian/*.dpatch; do \
@@ -51,9 +36,6 @@ post-patch:
for i in `${LS} ${FILESDIR}/post-patch-* |${SED} /.orig$$/d`; do \
${PATCH} -d ${WRKSRC} --forward --quiet <$$i ;\
done
- ${LN} -s ../signpr_cmf3.h ${WRKSRC}/perl-swig
- ${LN} -s ../signpr_cmf3.c ${WRKSRC}/perl-swig
- ${SED} -e 's,/usr/bin/perl,${PERL},' ${WRKSRC}/perl-swig/examples/wav2mp3.pl >${WRKDIR}/wav2mp3.pl
.for file in bplay.c sndfunc.c
@${SED} -e 's,machine/soundcard.h,sys/soundcard.h,' < \
${WRKSRC}/bplaysrc/${file} > ${WRKSRC}/bplaysrc/${file}.new
@@ -62,13 +44,8 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gramofile ${WRKSRC}/bplay_gramo ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/perl-swig/Gramofile.pm ${SITE_PERL}/${PERL_ARCH}
- ${INSTALL_DATA} ${WRKSRC}/perl-swig/Gramofile.so ${SITE_PERL}/${PERL_ARCH}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/perl-swig/README ${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${WRKDIR}/wav2mp3.pl ${EXAMPLESDIR}
${LN} -s bplay_gramo ${PREFIX}/bin/brec_gramo
.include <bsd.port.mk>
diff --git a/audio/gramofile/files/patch-swig b/audio/gramofile/files/patch-swig
deleted file mode 100644
index 396834ea156b..000000000000
--- a/audio/gramofile/files/patch-swig
+++ /dev/null
@@ -1,35 +0,0 @@
-Index: perl-swig/Makefile
-@@ -6,14 +6,14 @@
- OBJS := $(patsubst %.c,%.o,$(wildcard *.c))
- SWIGWRAP := $(patsubst %.c,%_wrap.c,$(wildcard *.c))
- SWIGOBJS := $(patsubst %.c,%_wrap.o,$(wildcard *.c))
--PERLCORE = -I/usr/lib/perl5/5.005/i386-linux/CORE
-+PERLCORE = -I${PERLCOREDIR}
- SHELL = /bin/sh
- SWIG = swig
- CC = gcc
--CFLAGS = -c -Wall -O2 -fpic -DSWIG -DTURBO_MEDIAN -DTURBO_BUFFER -Dbool=char
-+CFLAGS = -c -Wall -O2 -fpic -DSWIG -DTURBO_MEDIAN -DTURBO_BUFFER -Dbool=char -DPERL_POLLUTE -I${LOCALBASE}/include
- LD = ld
- LDFLAGS = -shared
--LIBS = -lm -ldl
-+LIBS = -lm
-
- swig:: $(LIB)
-
-Index: perl-swig/Gramofile.i
-@@ -6,6 +6,7 @@
- %import signpr_general.i
- %import signpr_wav.i
- %import signpr_cmf2.i
-+%import signpr_cmf3.i
- %import signpr_cmf.i
- %import signpr_copy.i
- %import signpr_doubmed.i
-Index: perl-swig/signpr_cmf3.i
-@@ -0,0 +1,5 @@
-+%module signpr_cmf3
-+%{
-+#include "signpr_cmf3.h"
-+%}
-+%include "signpr_cmf3.h"
diff --git a/audio/gramofile/files/post-patch-cmf3-swig b/audio/gramofile/files/post-patch-cmf3-swig
deleted file mode 100644
index bee99f2c0697..000000000000
--- a/audio/gramofile/files/post-patch-cmf3-swig
+++ /dev/null
@@ -1,93 +0,0 @@
-Index: signpr_cmf3.c
-@@ -24,6 +24,7 @@
- #include "signpr_cmf3.h"
- #include "signpr_general.h"
- #include "signpr_l1fit.h"
-+#ifndef SWIG
- #include "errorwindow.h"
- #include "stringinput.h"
- #include "buttons.h"
-@@ -31,14 +32,17 @@
- #include "boxes.h"
- #include "helpline.h"
- #include "yesnowindow.h"
-+#endif
- #include <stdlib.h>
- #include <stdio.h>
- #include <math.h>
-+#ifndef SWIG
- #ifndef OLD_CURSES
- #include <ncurses.h>
- #else
- #include <curses.h>
- #endif
-+#endif
-
- #ifdef DEBUGFILE
- static FILE *debugf=NULL;
-@@ -88,6 +92,7 @@
- #define SIGNPR_CMF3_PARAMSCR_HEADERTEXT "CMF IIF [SIXTH ORDER] - Parameters"
- #endif
-
-+#ifndef SWIG
- void
- cond_median3_param_screen (parampointer_t parampointer)
- {
-@@ -579,6 +584,7 @@
- free (threshold1str.string);
- free (threshold2str.string);
- }
-+#endif /* SWIG */
-
- void
- init_cond_median3_filter (int filterno, parampointer_t parampointer)
-@@ -886,7 +886,11 @@
- fillfuncpointer_t cond_median3_gate_pointer = cond_median3_gate;
-
- sample_t
-+#ifndef SWIG
- cond_median3_filter (parampointer_t parampointer)
-+#else
-+cond_median3_filter (parampointer_t parampointer, int *filter_type)
-+#endif
- {
- sample_t sample, gate, returnval;
- /* Length of the fft we'll do to get the smoothed interpolate */
-@@ -901,7 +901,11 @@
- int toleft, toright, nfreq;
- signed short maxval;
-
-+#ifndef SWIG
- advance_current_pos (&parampointer->buffer, parampointer->filterno);
-+#else
-+ advance_current_pos (&parampointer->buffer, parampointer->filterno, filter_type);
-+#endif
-
- advance_current_pos_custom (&parampointer->buffer4,
- cond_median3_gate_pointer,
-Index: signpr_cmf3.h
-@@ -23,7 +23,11 @@
-
- void delete_cond_median3_filter (parampointer_t parampointer);
-
-+#ifndef SWIG
- sample_t cond_median3_filter (parampointer_t parampointer);
-+#else
-+sample_t cond_median3_filter (parampointer_t parampointer, int *filter_type);
-+#endif
-
-
- #endif /* HAVE_SIGNPR_CMF3_H */
-Index: signpr_general.c
-@@ -627,7 +627,11 @@
- break;
-
- case COND_MEDIAN3_FILTER:
-+#ifndef SWIG
- return cond_median3_filter (parampointerarray[filterno]);
-+#else
-+ return cond_median3_filter (parampointerarray[filterno], filter_type);
-+#endif
- break;
-
- case EXPERIMENT_FILTER:
diff --git a/audio/gramofile/pkg-plist b/audio/gramofile/pkg-plist
index b221b9f00c78..d9428bdc731c 100644
--- a/audio/gramofile/pkg-plist
+++ b/audio/gramofile/pkg-plist
@@ -1,10 +1,5 @@
bin/gramofile
bin/bplay_gramo
bin/brec_gramo
-%%SITE_PERL%%/%%PERL_ARCH%%/Gramofile.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Gramofile.so
%%DOCSDIR%%/README
@dirrm %%DOCSDIR%%
-%%EXAMPLESDIR%%/README
-%%EXAMPLESDIR%%/wav2mp3.pl
-@dirrm %%EXAMPLESDIR%%