aboutsummaryrefslogtreecommitdiff
path: root/audio/gramofile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-11-02 05:25:44 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-11-02 05:25:44 +0000
commitb479ca8fa8e630e926fec71e1c2db01c134d6c74 (patch)
treeda39acb9a46766fa20ae1e4687b2e6ad41a8b5d8 /audio/gramofile
parent853795d1fcd0f59657eeb5169fc9eba709e06075 (diff)
downloadports-b479ca8fa8e630e926fec71e1c2db01c134d6c74.tar.gz
ports-b479ca8fa8e630e926fec71e1c2db01c134d6c74.zip
update audio/gramofile to 1.6P+debian patches
update to 1.6P (with perl interface), add debian patches, MASTER_SITE moved PR: ports/88199 Submitted by: Juergen Lock <nox@jelal.kn-bremen.de>
Notes
Notes: svn path=/head/; revision=146995
Diffstat (limited to 'audio/gramofile')
-rw-r--r--audio/gramofile/Makefile62
-rw-r--r--audio/gramofile/distinfo6
-rw-r--r--audio/gramofile/files/patch-20-warning-fixes171
-rw-r--r--audio/gramofile/files/patch-aa26
-rw-r--r--audio/gramofile/files/patch-ab19
-rw-r--r--audio/gramofile/files/patch-swig35
-rw-r--r--audio/gramofile/files/post-patch-Makefile26
-rw-r--r--audio/gramofile/files/post-patch-bplay.c19
-rw-r--r--audio/gramofile/files/post-patch-cmf3-swig93
-rw-r--r--audio/gramofile/files/post-patch-playwav.c10
-rw-r--r--audio/gramofile/files/post-patch-reclp_main.c10
-rw-r--r--audio/gramofile/pkg-descr8
-rw-r--r--audio/gramofile/pkg-plist5
13 files changed, 430 insertions, 60 deletions
diff --git a/audio/gramofile/Makefile b/audio/gramofile/Makefile
index c64ed011efdf..63580ad9de2a 100644
--- a/audio/gramofile/Makefile
+++ b/audio/gramofile/Makefile
@@ -6,21 +6,60 @@
#
PORTNAME= gramofile
-PORTVERSION= 1.6
-PORTREVISION= 1
+PORTVERSION= 1.6P
+PORTREVISION= 7
CATEGORIES= audio
-MASTER_SITES= http://panic.et.tudelft.nl/~costar/gramofile/
+MASTER_SITES= http://www.opensourcepartners.nl/~costar/gramofile/
+
+PATCH_SITES= ${MASTER_SITE_DEBIAN}
+PATCH_SITE_SUBDIR= pool/main/g/${PORTNAME}
+PATCHFILES= ${PORTNAME}_1.6-7.diff.gz
+PATCH_DIST_STRIP= -p1
MAINTAINER= nox@jelal.kn-bremen.de
COMMENT= Audio recording and tick/scratch reduction for e.g. vinyl records
-DEPRECATED= "mastersite disappeared, no longer maintained by author"
-EXPIRATION_DATE= 2005-12-31
+BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig11
+LIB_DEPENDS= fftw.2:${PORTSDIR}/math/fftw
+
+.if defined(WITH_SWIGDEPS)
+RUN_DEPENDS+= ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple
+RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame
+RUN_DEPENDS+= sox:${PORTSDIR}/audio/sox
+.endif
-ALL_TARGET= gramofile
+ALL_TARGET= gramofile perl-swig
USE_GMAKE= yes
+USE_PERL5= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+PERLCOREDIR= /usr/libdata/perl/${PERL_VERSION}/mach/CORE
+.else
+PERLCOREDIR= ${LOCALBASE}/lib/perl5/${PERL_VERSION}/mach/CORE
+.endif
+MAKE_ARGS+= PERLCOREDIR=${PERLCOREDIR}
+
+pre-everything::
+.if !defined(WITH_SWIGDEPS)
+ @${ECHO_MSG} "If you want to use the perl-swig example,"
+ @${ECHO_MSG} "${EXAMPLESDIR}/wav2mp3.pl,"
+ @${ECHO_MSG} "you need additional depenencies. You can have this port install them by"
+ @${ECHO_MSG} "defining WITH_SWIGDEPS."
+.endif
post-patch:
+ ${RM} ${WRKSRC}/debian/20-warning-fixes.dpatch
+ for i in ${WRKSRC}/debian/*.dpatch; do \
+ ${PATCH} -d ${WRKSRC} `${SED} -n '/^#PATCHOPTIONS:/{s///;p;q;}' $$i` --forward --quiet <$$i ;\
+ done
+ for i in `${LS} ${FILESDIR}/post-patch-* |${SED} /.orig$$/d`; do \
+ ${PATCH} -d ${WRKSRC} --forward --quiet <$$i ;\
+ done
+ ${LN} -s ../signpr_cmf3.h ${WRKSRC}/perl-swig
+ ${LN} -s ../signpr_cmf3.c ${WRKSRC}/perl-swig
+ ${SED} -e 's,/usr/bin/perl,${PERL},' ${WRKSRC}/perl-swig/examples/wav2mp3.pl >${WRKDIR}/wav2mp3.pl
.for file in bplay.c sndfunc.c
@${SED} -e 's,machine/soundcard.h,sys/soundcard.h,' < \
${WRKSRC}/bplaysrc/${file} > ${WRKSRC}/bplaysrc/${file}.new
@@ -29,8 +68,13 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gramofile ${WRKSRC}/bplay_gramo ${PREFIX}/bin
- ${MKDIR} ${PREFIX}/share/doc/gramofile
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/gramofile
+ ${INSTALL_DATA} ${WRKSRC}/perl-swig/Gramofile.pm ${SITE_PERL}/${PERL_ARCH}
+ ${INSTALL_DATA} ${WRKSRC}/perl-swig/Gramofile.so ${SITE_PERL}/${PERL_ARCH}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/perl-swig/README ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/wav2mp3.pl ${EXAMPLESDIR}
${LN} -s bplay_gramo ${PREFIX}/bin/brec_gramo
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/gramofile/distinfo b/audio/gramofile/distinfo
index 848f053e04cb..12cc0b35a5ec 100644
--- a/audio/gramofile/distinfo
+++ b/audio/gramofile/distinfo
@@ -1,2 +1,4 @@
-MD5 (gramofile-1.6.tar.gz) = 986c86c6fa17c064bc17c2936cc833e0
-SIZE (gramofile-1.6.tar.gz) = 108596
+MD5 (gramofile-1.6P.tar.gz) = 3b04a9c278626a269ae7b8656a4edd09
+SIZE (gramofile-1.6P.tar.gz) = 117822
+MD5 (gramofile_1.6-7.diff.gz) = 634297336cae62a7c8f6f8c0f99dfdb4
+SIZE (gramofile_1.6-7.diff.gz) = 25428
diff --git a/audio/gramofile/files/patch-20-warning-fixes b/audio/gramofile/files/patch-20-warning-fixes
new file mode 100644
index 000000000000..b8925ad43e0c
--- /dev/null
+++ b/audio/gramofile/files/patch-20-warning-fixes
@@ -0,0 +1,171 @@
+# Patch by Tom Harvey <TomHarvey@IndustryFigure.com>
+# Rediffed. [dk]
+# Also changed return type of bplay.c. [dk]
+#PATCHOPTIONS: -p1
+Index: bplaysrc/bplay.c
+@@ -91,7 +91,7 @@
+ extern void cleanupsems(void);
+
+
+-void main(int argc, char *argv[])
++int main(int argc, char *argv[])
+ {
+
+ int recorder = 0; /* 1 if recording, 0 else */
+@@ -398,6 +398,7 @@
+ }
+
+ finish_curses(0);
++ exit(0); /* Not reached, but keeps compiler happy. */
+ }
+
+ void Usage(void)
+Index: clrscr.c
+@@ -8,6 +8,7 @@
+ */
+
+ #include "clrscr.h"
++#include <string.h>
+ #ifndef OLD_CURSES
+ #include <ncurses.h>
+ #else
+Index: errorwindow.c
+@@ -11,6 +11,8 @@
+ #include "buttons.h"
+ #include "boxes.h"
+ #include "textwindow.h"
++
++#include <string.h>
+ #ifndef OLD_CURSES
+ #include <ncurses.h>
+ #else
+Index: gramofile.c
+@@ -42,7 +42,7 @@
+ exit (0);
+ }
+
+-void
++int
+ main (void)
+ {
+ char startdir[250];
+@@ -63,4 +63,5 @@
+ mainmenu (startdir);
+
+ finishmenu (0);
++ return 0;
+ }
+Index: mainmenu.c
+@@ -21,6 +21,7 @@
+ #include "tracksplit.h"
+ #include <stdlib.h>
+ #include <unistd.h>
++#include <string.h>
+ #ifndef OLD_CURSES
+ #include <ncurses.h>
+ #else
+Index: signpr_cmf.c
+@@ -30,6 +30,7 @@
+ #include "yesnowindow.h"
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <string.h>
+ #include <math.h>
+ #ifndef OLD_CURSES
+ #include <ncurses.h>
+@@ -88,8 +89,8 @@
+ {
+ " ^: no neat interpolation. v: broad ticks not filtered out. ",
+ " ^: less ticks detected. v: not all of tick interpolated. ",
+- " ^: bad following of dynamics. v: less ticks detected. ",
+- " ^: bad following of dynamics. v: less ticks detected. ",
++ " ^: bad following of dynamics. v: fewer ticks detected. ",
++ " ^: bad following of dynamics. v: fewer ticks detected. ",
+ " ^: only strong ticks detected. v: music-ticks also filtered out. ",
+ " Discard changes. ",
+ " Reset default values. ",
+Index: signpr_cmf2.c
+@@ -32,6 +32,7 @@
+ #include "yesnowindow.h"
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <string.h>
+ #include <math.h>
+ #ifndef OLD_CURSES
+ #include <ncurses.h>
+@@ -90,9 +91,9 @@
+
+ char *helplines[8] =
+ {
+- " ^: less ticks detected. v: not all of tick interpolated. ",
+- " ^: bad following of dynamics. v: less ticks detected. ",
+- " ^: bad following of dynamics. v: less ticks detected. ",
++ " ^: fewer ticks detected. v: not all of tick interpolated. ",
++ " ^: bad following of dynamics. v: fewer ticks detected. ",
++ " ^: bad following of dynamics. v: fewer ticks detected. ",
+ " ^: detected tick length too short v: detected tick length longer. ",
+ " ^: only strong ticks detected. v: music-ticks also filtered out. ",
+ " Discard changes. ",
+Index: signpr_doubmed.c
+@@ -19,6 +19,7 @@
+ #endif
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <string.h>
+ #ifndef SWIG
+ #ifndef OLD_CURSES
+ #include <ncurses.h>
+Index: signpr_mean.c
+@@ -19,6 +19,7 @@
+ #endif
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <string.h>
+ #ifndef SWIG
+ #ifndef OLD_CURSES
+ #include <ncurses.h>
+Index: signpr_median.c
+@@ -19,6 +19,7 @@
+ #endif
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <string.h>
+ #ifndef SWIG
+ #ifndef OLD_CURSES
+ #include <ncurses.h>
+Index: signpr_rms.c
+@@ -17,6 +17,7 @@
+ #include "helpline.h"
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <string.h>
+ #include <math.h>
+ #ifndef OLD_CURSES
+ #include <ncurses.h>
+Index: stringinput.c
+@@ -8,6 +8,7 @@
+ */
+
+ #include "stringinput.h"
++#include <string.h>
+ #ifndef OLD_CURSES
+ #include <ncurses.h>
+ #else
+Index: tracksplit_parammenu.c
+@@ -16,6 +16,7 @@
+ #include "helpline.h"
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <string.h>
+ #ifndef OLD_CURSES
+ #include <ncurses.h>
+ #else
+Index: yesnowindow.c
+@@ -11,6 +11,7 @@
+ #include "buttons.h"
+ #include "boxes.h"
+ #include "textwindow.h"
++#include <string.h>
+ #ifndef OLD_CURSES
+ #include <ncurses.h>
+ #else
diff --git a/audio/gramofile/files/patch-aa b/audio/gramofile/files/patch-aa
deleted file mode 100644
index 868e9851ff3b..000000000000
--- a/audio/gramofile/files/patch-aa
+++ /dev/null
@@ -1,26 +0,0 @@
---- Makefile.orig Tue Mar 28 22:23:58 2000
-+++ Makefile Fri Apr 7 12:21:53 2000
-@@ -19,16 +19,16 @@
- ########## CHOOSE YOUR ARCHITECTURE: (NOTE: also see bplaysrc/Makefile!)
-
- # For Linux (and maybe others), use these:
--CFLAGS = -Wall -O2 -DTURBO_MEDIAN -DTURBO_BUFFER
--DEPS = $(OBJS) makebplay
--LIBS = -lncurses -lm
--COPY_A = -a
--
--# For FreeBSD (and maybe others), use these:
- #CFLAGS = -Wall -O2 -DTURBO_MEDIAN -DTURBO_BUFFER
- #DEPS = $(OBJS) makebplay
- #LIBS = -lncurses -lm
--#COPY_A = -p
-+#COPY_A = -a
-+
-+# For FreeBSD (and maybe others), use these:
-+CFLAGS += -Wall -DTURBO_MEDIAN -DTURBO_BUFFER
-+DEPS = $(OBJS) makebplay
-+LIBS = -lncurses -lm
-+COPY_A = -p
-
- # For IRIX (and maybe others), use these:
- #CFLAGS = -Wall -O2 -DTURBO_MEDIAN -DTURBO_BUFFER -DSWAP_ENDIAN -DOLD_CURSES
diff --git a/audio/gramofile/files/patch-ab b/audio/gramofile/files/patch-ab
deleted file mode 100644
index a344f25691e3..000000000000
--- a/audio/gramofile/files/patch-ab
+++ /dev/null
@@ -1,19 +0,0 @@
---- bplaysrc/Makefile.orig Mon Mar 27 23:24:46 2000
-+++ bplaysrc/Makefile Fri Apr 7 12:22:05 2000
-@@ -12,12 +12,12 @@
- ########## CHOOSE YOUR ARCHITECTURE: (NOTE: also see ../Makefile!)
-
- # For Linux (and maybe others), use these:
--CFLAGS = -Wall -O2 -DUSEBUFFLOCK -DREDHAT50 -DLP2CD -DVUMETER # -DDEBUG
--LIBS = -lncurses
-+#CFLAGS = -Wall -O2 -DUSEBUFFLOCK -DREDHAT50 -DLP2CD -DVUMETER # -DDEBUG
-+#LIBS = -lncurses
-
- # For FreeBSD (and maybe others), use these:
--#CFLAGS = -Wall -O2 -DLP2CD -DVUMETER # -DDEBUG
--#LIBS = -lncurses
-+CFLAGS += -Wall -DLP2CD -DVUMETER # -DDEBUG
-+LIBS = -lncurses
-
- # -DOLD_CURSES can be used here, too.
-
diff --git a/audio/gramofile/files/patch-swig b/audio/gramofile/files/patch-swig
new file mode 100644
index 000000000000..396834ea156b
--- /dev/null
+++ b/audio/gramofile/files/patch-swig
@@ -0,0 +1,35 @@
+Index: perl-swig/Makefile
+@@ -6,14 +6,14 @@
+ OBJS := $(patsubst %.c,%.o,$(wildcard *.c))
+ SWIGWRAP := $(patsubst %.c,%_wrap.c,$(wildcard *.c))
+ SWIGOBJS := $(patsubst %.c,%_wrap.o,$(wildcard *.c))
+-PERLCORE = -I/usr/lib/perl5/5.005/i386-linux/CORE
++PERLCORE = -I${PERLCOREDIR}
+ SHELL = /bin/sh
+ SWIG = swig
+ CC = gcc
+-CFLAGS = -c -Wall -O2 -fpic -DSWIG -DTURBO_MEDIAN -DTURBO_BUFFER -Dbool=char
++CFLAGS = -c -Wall -O2 -fpic -DSWIG -DTURBO_MEDIAN -DTURBO_BUFFER -Dbool=char -DPERL_POLLUTE -I${LOCALBASE}/include
+ LD = ld
+ LDFLAGS = -shared
+-LIBS = -lm -ldl
++LIBS = -lm
+
+ swig:: $(LIB)
+
+Index: perl-swig/Gramofile.i
+@@ -6,6 +6,7 @@
+ %import signpr_general.i
+ %import signpr_wav.i
+ %import signpr_cmf2.i
++%import signpr_cmf3.i
+ %import signpr_cmf.i
+ %import signpr_copy.i
+ %import signpr_doubmed.i
+Index: perl-swig/signpr_cmf3.i
+@@ -0,0 +1,5 @@
++%module signpr_cmf3
++%{
++#include "signpr_cmf3.h"
++%}
++%include "signpr_cmf3.h"
diff --git a/audio/gramofile/files/post-patch-Makefile b/audio/gramofile/files/post-patch-Makefile
new file mode 100644
index 000000000000..446740bd0a52
--- /dev/null
+++ b/audio/gramofile/files/post-patch-Makefile
@@ -0,0 +1,26 @@
+Index: Makefile
+@@ -20,16 +20,16 @@
+ ########## CHOOSE YOUR ARCHITECTURE: (NOTE: also see bplaysrc/Makefile!)
+
+ # For Linux (and maybe others), use these:
+-CFLAGS = -Wall -O2 -funroll-loops -DTURBO_MEDIAN -DTURBO_BUFFER
+-DEPS = $(OBJS) makebplay
+-LIBS = -lncurses -lrfftw -lfftw -lm
+-COPY_A = -a
++#CFLAGS = -Wall -O2 -funroll-loops -DTURBO_MEDIAN -DTURBO_BUFFER
++#DEPS = $(OBJS) makebplay
++#LIBS = -lncurses -lrfftw -lfftw -lm
++#COPY_A = -a
+
+ # For FreeBSD (and maybe others), use these:
+-#CFLAGS = -Wall -O2 -DTURBO_MEDIAN -DTURBO_BUFFER
+-#DEPS = $(OBJS) makebplay
+-#LIBS = -lncurses -lrfftw -lfftw -lm
+-#COPY_A = -p
++CFLAGS += -Wall -DTURBO_MEDIAN -DTURBO_BUFFER -I${LOCALBASE}/include
++DEPS = $(OBJS) makebplay
++LIBS = -L${LOCALBASE}/lib -lncurses -lrfftw -lfftw -lm
++COPY_A = -p
+
+ # For IRIX (and maybe others), use these:
+ #CFLAGS = -Wall -O2 -DTURBO_MEDIAN -DTURBO_BUFFER -DSWAP_ENDIAN -DOLD_CURSES
diff --git a/audio/gramofile/files/post-patch-bplay.c b/audio/gramofile/files/post-patch-bplay.c
new file mode 100644
index 000000000000..c436d4421bf5
--- /dev/null
+++ b/audio/gramofile/files/post-patch-bplay.c
@@ -0,0 +1,19 @@
+Index: bplaysrc/bplay.c
+@@ -33,14 +33,16 @@
+ /* Needed for BYTE_ORDER and BIG/LITTLE_ENDIAN macros. */
+ #ifndef _BSD_SOURCE
+ # define _BSD_SOURCE
+-# include <endian.h>
++# include <sys/endian.h>
+ # undef _BSD_SOURCE
+ #else
+ # include <endian.h>
+ #endif
+
+ #include <sys/types.h>
++#ifndef __FreeBSD__
+ #include <byteswap.h>
++#endif
+
+ /* Adapted from the byteorder macros in the Linux kernel. */
+ #if BYTE_ORDER == LITTLE_ENDIAN
diff --git a/audio/gramofile/files/post-patch-cmf3-swig b/audio/gramofile/files/post-patch-cmf3-swig
new file mode 100644
index 000000000000..bee99f2c0697
--- /dev/null
+++ b/audio/gramofile/files/post-patch-cmf3-swig
@@ -0,0 +1,93 @@
+Index: signpr_cmf3.c
+@@ -24,6 +24,7 @@
+ #include "signpr_cmf3.h"
+ #include "signpr_general.h"
+ #include "signpr_l1fit.h"
++#ifndef SWIG
+ #include "errorwindow.h"
+ #include "stringinput.h"
+ #include "buttons.h"
+@@ -31,14 +32,17 @@
+ #include "boxes.h"
+ #include "helpline.h"
+ #include "yesnowindow.h"
++#endif
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <math.h>
++#ifndef SWIG
+ #ifndef OLD_CURSES
+ #include <ncurses.h>
+ #else
+ #include <curses.h>
+ #endif
++#endif
+
+ #ifdef DEBUGFILE
+ static FILE *debugf=NULL;
+@@ -88,6 +92,7 @@
+ #define SIGNPR_CMF3_PARAMSCR_HEADERTEXT "CMF IIF [SIXTH ORDER] - Parameters"
+ #endif
+
++#ifndef SWIG
+ void
+ cond_median3_param_screen (parampointer_t parampointer)
+ {
+@@ -579,6 +584,7 @@
+ free (threshold1str.string);
+ free (threshold2str.string);
+ }
++#endif /* SWIG */
+
+ void
+ init_cond_median3_filter (int filterno, parampointer_t parampointer)
+@@ -886,7 +886,11 @@
+ fillfuncpointer_t cond_median3_gate_pointer = cond_median3_gate;
+
+ sample_t
++#ifndef SWIG
+ cond_median3_filter (parampointer_t parampointer)
++#else
++cond_median3_filter (parampointer_t parampointer, int *filter_type)
++#endif
+ {
+ sample_t sample, gate, returnval;
+ /* Length of the fft we'll do to get the smoothed interpolate */
+@@ -901,7 +901,11 @@
+ int toleft, toright, nfreq;
+ signed short maxval;
+
++#ifndef SWIG
+ advance_current_pos (&parampointer->buffer, parampointer->filterno);
++#else
++ advance_current_pos (&parampointer->buffer, parampointer->filterno, filter_type);
++#endif
+
+ advance_current_pos_custom (&parampointer->buffer4,
+ cond_median3_gate_pointer,
+Index: signpr_cmf3.h
+@@ -23,7 +23,11 @@
+
+ void delete_cond_median3_filter (parampointer_t parampointer);
+
++#ifndef SWIG
+ sample_t cond_median3_filter (parampointer_t parampointer);
++#else
++sample_t cond_median3_filter (parampointer_t parampointer, int *filter_type);
++#endif
+
+
+ #endif /* HAVE_SIGNPR_CMF3_H */
+Index: signpr_general.c
+@@ -627,7 +627,11 @@
+ break;
+
+ case COND_MEDIAN3_FILTER:
++#ifndef SWIG
+ return cond_median3_filter (parampointerarray[filterno]);
++#else
++ return cond_median3_filter (parampointerarray[filterno], filter_type);
++#endif
+ break;
+
+ case EXPERIMENT_FILTER:
diff --git a/audio/gramofile/files/post-patch-playwav.c b/audio/gramofile/files/post-patch-playwav.c
new file mode 100644
index 000000000000..c6e2fe829239
--- /dev/null
+++ b/audio/gramofile/files/post-patch-playwav.c
@@ -0,0 +1,10 @@
+Index: playwav.c
+@@ -32,7 +32,7 @@
+ #include <curses.h>
+ #endif
+
+-#define BPLAYCMD "/usr/lib/gramofile/bplay_gramo"
++#define BPLAYCMD "bplay_gramo"
+
+ void
+ playwav_playit (char *filename, int usebeginendtime, double begintime,
diff --git a/audio/gramofile/files/post-patch-reclp_main.c b/audio/gramofile/files/post-patch-reclp_main.c
new file mode 100644
index 000000000000..eb55442276aa
--- /dev/null
+++ b/audio/gramofile/files/post-patch-reclp_main.c
@@ -0,0 +1,10 @@
+Index: reclp_main.c
+@@ -18,7 +18,7 @@
+ #include <curses.h>
+ #endif
+
+-#define BRECCMD "/usr/lib/gramofile/brec_gramo"
++#define BRECCMD "brec_gramo"
+
+ void
+ record_from_lp (char *startdir)
diff --git a/audio/gramofile/pkg-descr b/audio/gramofile/pkg-descr
index b575efe3c3bb..e7f87cacd9ea 100644
--- a/audio/gramofile/pkg-descr
+++ b/audio/gramofile/pkg-descr
@@ -1,6 +1,6 @@
-This is version 1.5 of GramoFile, released February 15, 1999. With this
-program you can record audio of (for example) gramophone records, process
-the signal and listen to the results. Because sound files of the
+This is version 1.6P-7 of GramoFile (patches are from the debian package).
+With this program you can record audio of (for example) gramophone records,
+process the signal and listen to the results. Because sound files of the
.WAV-format are used, it is possible to exchange the files with many other
programs. Cdrecord(1) can burn CD-Recordables of these, so you can make
CDs with the music of your favorite records. The user interface of
@@ -20,4 +20,4 @@ necessary. Track-times are saved in an editable (plaintext) .tracks file,
that will be used during the signal processing to produce one processed
.wav file for each individual track.
-WWW: http://panic.et.tudelft.nl/~costar/gramofile/
+WWW: http://www.opensourcepartners.nl/~costar/gramofile/
diff --git a/audio/gramofile/pkg-plist b/audio/gramofile/pkg-plist
index d9428bdc731c..b221b9f00c78 100644
--- a/audio/gramofile/pkg-plist
+++ b/audio/gramofile/pkg-plist
@@ -1,5 +1,10 @@
bin/gramofile
bin/bplay_gramo
bin/brec_gramo
+%%SITE_PERL%%/%%PERL_ARCH%%/Gramofile.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Gramofile.so
%%DOCSDIR%%/README
@dirrm %%DOCSDIR%%
+%%EXAMPLESDIR%%/README
+%%EXAMPLESDIR%%/wav2mp3.pl
+@dirrm %%EXAMPLESDIR%%