aboutsummaryrefslogtreecommitdiff
path: root/audio/grip
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-25 08:51:01 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-25 08:51:01 +0000
commitcceedd17eb4da9d47139659e96068199b9676f2c (patch)
treefd84a01f16fe5f59af70dad674c6b7ecb5aae601 /audio/grip
parent1a290667572a81eebcff8b2a140462bce7a0c39e (diff)
downloadports-cceedd17eb4da9d47139659e96068199b9676f2c.tar.gz
ports-cceedd17eb4da9d47139659e96068199b9676f2c.zip
Notes
Diffstat (limited to 'audio/grip')
-rw-r--r--audio/grip/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/audio/grip/Makefile b/audio/grip/Makefile
index 9bc99b5059d8..aa9d5fdc27e6 100644
--- a/audio/grip/Makefile
+++ b/audio/grip/Makefile
@@ -7,7 +7,7 @@
PORTNAME= grip
PORTVERSION= 3.2.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,6 +17,7 @@ COMMENT= GTK front-end to external cd rippers and audio encoders
LIB_DEPENDS= id3-3.8.3:${PORTSDIR}/audio/id3lib \
curl.2:${PORTSDIR}/ftp/curl
+PATCH_DEPENDS= iconv:${PORTSDIR}/converters/libiconv
USE_X_PREFIX= yes
USE_GNOME= gnomehack gnomeprefix gnometarget libgnomeui vte
@@ -36,6 +37,8 @@ OPTIONS= CDPARANOIA "Ripper: Enable cdparanoia support" on \
MP3ENCODE "Encoder: mp3encode: Install audio/mp3encode" off \
VORBIS "Encoder: oggenc: Install audio/vorbis-tools" off
+ISO_LOCALES= de es fr pt_BR ru
+
.include <bsd.port.pre.mk>
.if defined(WITH_CDROM_DEVICE)
@@ -105,5 +108,10 @@ post-patch:
s|{"l3enc","-br %b %w %m","mp3"},|{"faac","-w -b %b %w -o %m", "m4a"},|; \
s|mp3encode|encode|' \
${WRKSRC}/src/gripcfg.c
+.for l in ${ISO_LOCALES}
+ @${MV} ${WRKSRC}/po/${l}.po ${WRKSRC}/po/_${l}.po
+ ${LOCALBASE}/bin/iconv -f ISO-8859-15 -t UTF-8 \
+ ${WRKSRC}/po/_${l}.po > ${WRKSRC}/po/${l}.po
+.endfor
.include <bsd.port.post.mk>