aboutsummaryrefslogtreecommitdiff
path: root/audio/gtkpod
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2011-03-15 15:13:21 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2011-03-15 15:13:21 +0000
commit04c6e4614820c0415965b557b480b693167c9462 (patch)
tree389addbf25da76adee85a033879f0d7b53ad07f7 /audio/gtkpod
parentefef80a00d7028a8d9641d1cf74ce67e30ed687c (diff)
downloadports-04c6e4614820c0415965b557b480b693167c9462.tar.gz
ports-04c6e4614820c0415965b557b480b693167c9462.zip
- Update to version 1.0.0
- Drop gratuitous run dependencies: they are only used in external auxiliary scripts and do not directly affect main program functionality. Users are advised to install them manually if they need them (lame, faad, etc.) - Now that configure script supports disabling of optional features, drop make(1)'s exists()-based heuristics to ensure no hidden dependencies are recorded; user's choice of OPTIONS should now match the reality - Remove now unsupported HAL and GNOME VFS2 options - Remove dependency on external AAC/MP4 library (mp4v2); gtkpod now tries to load it via dlopen(3) and if it fails, will dig for the atom props manually. It probably can be turned into rdep, but first I need to make sure our libmp4v2 ABI matches what gtkpod expects - Add LICENSE (GPLv2)
Notes
Notes: svn path=/head/; revision=270947
Diffstat (limited to 'audio/gtkpod')
-rw-r--r--audio/gtkpod/Makefile71
-rw-r--r--audio/gtkpod/distinfo5
-rw-r--r--audio/gtkpod/files/patch-src__mp4file.c99
-rw-r--r--audio/gtkpod/pkg-plist1
4 files changed, 27 insertions, 149 deletions
diff --git a/audio/gtkpod/Makefile b/audio/gtkpod/Makefile
index e40d9e45d544..64a8889793fc 100644
--- a/audio/gtkpod/Makefile
+++ b/audio/gtkpod/Makefile
@@ -6,18 +6,17 @@
#
PORTNAME= gtkpod
-PORTVERSION= 0.99.14
-PORTREVISION= 7
+PORTVERSION= 1.0.0
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= danfe@FreeBSD.org
COMMENT= GUI for Apple iPod using GTK2
+LICENSE= GPLv2
+
LIB_DEPENDS= id3tag.0:${PORTSDIR}/audio/libid3tag \
- gpod.5:${PORTSDIR}/audio/libgpod
-RUN_DEPENDS= mp3gain:${PORTSDIR}/audio/mp3gain \
- iconv:${PORTSDIR}/converters/libiconv
+ gpod.7:${PORTSDIR}/audio/libgpod
USE_GETTEXT= yes
USE_GMAKE= yes
@@ -25,65 +24,43 @@ USE_GNOME= gtk20 libglade2
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
INSTALLS_ICONS= yes
-WANT_GNOME= yes
MAN1= gtkpod.1
-PORTDOCS= ChangeLog README TODOandBUGS.txt TROUBLESHOOTING
+PORTDOCS= ChangeLog NEWS README TODOandBUGS.txt TROUBLESHOOTING
-OPTIONS= MPEG4IP "Enable AAC and H.264 support with MPEG4IP" off \
- VORBIS "Enable Ogg/Vorbis support (decoding)" on \
- FLAC "Enable FLAC support (decoding)" on \
- LAME "Enable encoding to MP3 format" on \
- GNOMEVFS "Enable iPod autodetection support" off \
- HAL "Enable HAL support" off \
- CURL "Build with coverart download support" on
+OPTIONS= VORBIS "Enable Ogg/Vorbis support" on \
+ FLAC "Enable FLAC support" on \
+ CURL "Enable coverart download support" on
.include <bsd.port.pre.mk>
-.if defined(WITH_MPEG4IP) && !defined(WITHOUT_MPEG4IP)
-LIB_DEPENDS+= mp4v2.10:${PORTSDIR}/multimedia/mp4v2
-CONFIGURE_ARGS+= --with-mp4v2
-# Define HAVE_GTK to unbreak the build with libmp4v2.so (it is built
-# without Gtk support by default, which can result in gtkpod breakage)
-MAKE_ARGS+= CPPFLAGS="-DHAVE_GTK"
+.if defined(WITH_VORBIS)
+LIB_DEPENDS+= vorbisfile.6:${PORTSDIR}/audio/libvorbis
.else
-CONFIGURE_ARGS+= --without-mp4v2
-.endif
-.for x in faac faad
-. if exists(${LOCALBASE}/bin/${x})
-RUN_DEPENDS+= ${x}:${PORTSDIR}/audio/${x}
-. endif
-.endfor
-
-.if defined(WITH_VORBIS) || exists(${LOCALBASE}/lib/libvorbis.so)
-LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
-RUN_DEPENDS+= oggdec:${PORTSDIR}/audio/vorbis-tools
+CONFIGURE_ARGS+= --without-ogg
.endif
-.if defined(WITH_FLAC) || exists(${LOCALBASE}/lib/libFLAC.so)
+.if defined(WITH_FLAC)
LIB_DEPENDS+= FLAC.10:${PORTSDIR}/audio/flac
+.else
+CONFIGURE_ARGS+= --without-flac
.endif
-.if defined(WITH_LAME) || exists(${LOCALBASE}/bin/lame)
-RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame
-.endif
-
-.if defined(WITH_GNOMEVFS) || ${HAVE_GNOME:Mgnomevfs2}
-USE_GNOME+= gnomevfs2
-.endif
-
-.if defined(WITH_HAL) || exists(${LOCALBASE}/lib/libhal.so)
-LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
-.endif
-
-.if defined(WITH_CURL) || exists(${LOCALBASE}/lib/libcurl.so)
+.if defined(WITH_CURL)
LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
+.else
+CONFIGURE_ARGS+= --without-curl
.endif
-pre-configure: .SILENT
+post-patch:
# Install locale files correctly (to share dir instead of lib dir)
- ${REINPLACE_CMD} -e 's|DATADIRNAME=lib|DATADIRNAME=share|' \
+ @${REINPLACE_CMD} -e 's|DATADIRNAME=lib|DATADIRNAME=share|' \
${WRKSRC}/configure
+# FreeBSD does not have libdl
+ @${REINPLACE_CMD} -e 's| -ldl||' ${WRKSRC}/src/Makefile.in
+# Adjust location of <endian.h> header
+ @${REINPLACE_CMD} -e 's|endian\.h|sys/&|' ${WRKSRC}/configure \
+ ${WRKSRC}/src/mp4file.c
post-install:
.if !defined(NOPORTDOCS)
diff --git a/audio/gtkpod/distinfo b/audio/gtkpod/distinfo
index 5ca6ab345690..8c004f1e3a76 100644
--- a/audio/gtkpod/distinfo
+++ b/audio/gtkpod/distinfo
@@ -1,3 +1,2 @@
-MD5 (gtkpod-0.99.14.tar.gz) = f7948eceb955b302f4c47da4c0e1ec12
-SHA256 (gtkpod-0.99.14.tar.gz) = 73e1283482679ae0cc774aa4a07aec9491598288b36986505ec3d1c6a077ec3d
-SIZE (gtkpod-0.99.14.tar.gz) = 1856919
+SHA256 (gtkpod-1.0.0.tar.gz) = d8089455d089b85390daefc522b7d60403ccf24585a57cae9f47b052f4f25f12
+SIZE (gtkpod-1.0.0.tar.gz) = 1899869
diff --git a/audio/gtkpod/files/patch-src__mp4file.c b/audio/gtkpod/files/patch-src__mp4file.c
deleted file mode 100644
index f31f6d23a10c..000000000000
--- a/audio/gtkpod/files/patch-src__mp4file.c
+++ /dev/null
@@ -1,99 +0,0 @@
---- ./src/mp4file.c.orig 2010-07-13 12:23:59.000000000 +0100
-+++ ./src/mp4file.c 2010-07-13 12:39:31.000000000 +0100
-@@ -132,6 +132,8 @@
- /* define metadata bug is present (see note at mp4_write_file_info()) */
- #define MP4V2_HAS_METADATA_BUG TRUE
-
-+#define HAVE_LIBMP4V2_19X 1
-+
- #include <sys/types.h>
- #include <sys/param.h>
- #include <inttypes.h>
-@@ -399,7 +401,7 @@
- #else
- #warning "Album Artist field not supported with this version of libmp4v2. Album Artist support requires at least V1.6.0"
- #endif
--#if HAVE_LIBMP4V2_2
-+#if HAVE_LIBMP4V2_2 && !HAVE_LIBMP4V2_19X
- if (MP4GetMetadataComposer(mp4File, &value) && value != NULL)
- #else
- if (MP4GetMetadataWriter(mp4File, &value) && value != NULL)
-@@ -413,7 +415,7 @@
- track->comment = charset_to_utf8 (value);
- g_free(value);
- }
--#if HAVE_LIBMP4V2_2
-+#if HAVE_LIBMP4V2_2 && !HAVE_LIBMP4V2_19X
- if (MP4GetMetadataReleaseDate(mp4File, &value) && value != NULL)
- #else
- if (MP4GetMetadataYear(mp4File, &value) && value != NULL)
-@@ -447,7 +449,7 @@
- track->genre = charset_to_utf8 (value);
- g_free(value);
- }
--#if HAVE_LIBMP4V2_2
-+#if HAVE_LIBMP4V2_2 && !HAVE_LIBMP4V2_19X
- if (MP4GetMetadataBPM (mp4File, &numvalue))
- #else
- if (MP4GetMetadataTempo (mp4File, &numvalue))
-@@ -541,7 +543,7 @@
- &m_track, &m_tracks);
- gboolean has_disk = MP4GetMetadataDisk (mp4File,
- &m_disk, &m_disks);*/
--#if HAVE_LIBMP4V2_2
-+#if HAVE_LIBMP4V2_2 && !HAVE_LIBMP4V2_19X
- gboolean has_tempo = MP4GetMetadataBPM (mp4File,
- &m_tempo);
- #else
-@@ -553,13 +555,13 @@
- /* MP4GetMetadataName (mp4File, &m_name);
- MP4GetMetadataArtist (mp4File, &m_artist);
- MP4GetMetadataAlbumArtist (mp4File, &m_albumartist);
--#if HAVE_LIBMP4V2_2
-+#if HAVE_LIBMP4V2_2 && !HAVE_LIBMP4V2_19X
- MP4GetMetadataComposer (mp4File, &m_writer);
- #else
- MP4GetMetadataWriter (mp4File, &m_writer);
- #endif
- MP4GetMetadataComment (mp4File, &m_comment);
--#if HAVE_LIBMP4V2_2
-+#if HAVE_LIBMP4V2_2 && !HAVE_LIBMP4V2_19X
- MP4GetMetadataReleaseDate (mp4File, &m_year);
- #else
- MP4GetMetadataYear (mp4File, &m_year);
-@@ -584,7 +586,7 @@
- g_free (value);
- #endif
- value = charset_from_utf8 (track->composer);
--#if HAVE_LIBMP4V2_2
-+#if HAVE_LIBMP4V2_2 && !HAVE_LIBMP4V2_19X
- MP4SetMetadataComposer (mp4File, value);
- #else
- MP4SetMetadataWriter (mp4File, value);
-@@ -596,7 +598,7 @@
- g_free (value);
-
- value = g_strdup_printf ("%d", track->year);
--#if HAVE_LIBMP4V2_2
-+#if HAVE_LIBMP4V2_2 && !HAVE_LIBMP4V2_19X
- MP4SetMetadataReleaseDate (mp4File, value);
- #else
- MP4SetMetadataYear (mp4File, value);
-@@ -611,7 +613,7 @@
-
- MP4SetMetadataDisk (mp4File, track->cd_nr, track->cds);
-
--#if HAVE_LIBMP4V2_2
-+#if HAVE_LIBMP4V2_2 && !HAVE_LIBMP4V2_19X
- MP4SetMetadataBPM (mp4File, track->BPM);
- #else
- MP4SetMetadataTempo (mp4File, track->BPM);
-@@ -626,7 +628,7 @@
- g_free (value);
-
- #if MP4V2_HAS_METADATA_BUG
--#if HAVE_LIBMP4V2_2
-+#if HAVE_LIBMP4V2_2 && !HAVE_LIBMP4V2_19X
- if (has_tempo) MP4SetMetadataBPM (mp4File, m_tempo);
- #else
- if (has_tempo) MP4SetMetadataTempo (mp4File, m_tempo);
diff --git a/audio/gtkpod/pkg-plist b/audio/gtkpod/pkg-plist
index 86d18abb894e..cb11f71fa775 100644
--- a/audio/gtkpod/pkg-plist
+++ b/audio/gtkpod/pkg-plist
@@ -101,6 +101,7 @@ share/icons/hicolor/48x48/apps/gtkpod.png
share/icons/hicolor/64x64/apps/gtkpod.png
share/icons/hicolor/scalable/apps/gtkpod.svg
share/applications/gtkpod.desktop
+share/locale/ca/LC_MESSAGES/gtkpod.mo
share/locale/de/LC_MESSAGES/gtkpod.mo
share/locale/es/LC_MESSAGES/gtkpod.mo
share/locale/fr/LC_MESSAGES/gtkpod.mo