aboutsummaryrefslogtreecommitdiff
path: root/audio/gtkpod
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2009-08-24 20:39:42 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2009-08-24 20:39:42 +0000
commit7be7bfd4f1411bdf6d7d4c5fb6a8b633a611a88b (patch)
treedb5d852e7f1c00ffff329ef42ae17b08c129bd7b /audio/gtkpod
parent20fc645e9ff5a3dbf96d9fea5dfdd4be294c87a3 (diff)
downloadports-7be7bfd4f1411bdf6d7d4c5fb6a8b633a611a88b.tar.gz
ports-7be7bfd4f1411bdf6d7d4c5fb6a8b633a611a88b.zip
- Update to version 0.99.14 [1]
- Drop `libgnomecanvas' dependency: cairo is now used for coverart display effects - Add missing runtime dependency for Ogg conversion to work [2] - Similarly to [2], register dependencies for MPEG-4 audio encoding/decoding and MP3 encoding via LAME - Flip cURL support knob to "on", since vorbis-tools require it anyways (and Ogg support is "on" by default). This is OK since cURL is likely to be installed on a typical desktop system; lots of other software wants it - Convert to use PORTDOCS and simplify their installation (get rid of `for' loop in Makefile) - Augment some OPTIONS text, clean up pkg-plist PR: ports/138007 [1], ports/126760 [2] Submitted by: keramida [1], ehaupt [2]
Notes
Notes: svn path=/head/; revision=240280
Diffstat (limited to 'audio/gtkpod')
-rw-r--r--audio/gtkpod/Makefile33
-rw-r--r--audio/gtkpod/distinfo6
-rw-r--r--audio/gtkpod/pkg-plist101
3 files changed, 92 insertions, 48 deletions
diff --git a/audio/gtkpod/Makefile b/audio/gtkpod/Makefile
index 96eb427cb4b4..a78b4b87ea41 100644
--- a/audio/gtkpod/Makefile
+++ b/audio/gtkpod/Makefile
@@ -6,49 +6,57 @@
#
PORTNAME= gtkpod
-PORTVERSION= 0.99.12
-PORTREVISION= 5
+PORTVERSION= 0.99.14
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= danfe@FreeBSD.org
-COMMENT= GUI for Apple iPods using GTK2
+COMMENT= GUI for Apple iPod using GTK2
LIB_DEPENDS= id3tag.0:${PORTSDIR}/audio/libid3tag \
gpod.5:${PORTSDIR}/audio/libgpod
RUN_DEPENDS= mp3gain:${PORTSDIR}/audio/mp3gain \
iconv:${PORTSDIR}/converters/libiconv
-BROKEN= does not build
-
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GNOME= gtk20 libglade2 libgnomecanvas
+USE_GNOME= gtk20 libglade2
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
INSTALLS_ICONS= yes
WANT_GNOME= yes
+MAN1= gtkpod.1
+
+PORTDOCS= ChangeLog README TODOandBUGS.txt TROUBLESHOOTING
OPTIONS= MPEG4IP "Enable AAC and H.264 support with MPEG4IP" off \
- VORBIS "Enable Ogg/Vorbis support" on \
- FLAC "Enable FLAC support" on \
+ VORBIS "Enable Ogg/Vorbis support (decoding)" on \
+ FLAC "Enable FLAC support (decoding)" on \
+ LAME "Enable encoding to MP3 format" on \
GNOMEVFS "Enable iPod autodetection support" off \
HAL "Enable HAL support" off \
- CURL "Build with coverart download support" off
+ CURL "Build with coverart download support" on
.include <bsd.port.pre.mk>
.if defined(WITH_MPEG4IP) || exists(${LOCALBASE}/lib/libmp4v2.so)
LIB_DEPENDS+= mp4v2.0:${PORTSDIR}/multimedia/mpeg4ip-libmp4v2
+RUN_DEPENDS+= faac:${PORTSDIR}/audio/faac faad:${PORTSDIR}/audio/faad
.endif
.if defined(WITH_VORBIS) || exists(${LOCALBASE}/lib/libvorbis.so)
LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+RUN_DEPENDS+= oggdec:${PORTSDIR}/audio/vorbis-tools
.endif
.if defined(WITH_FLAC) || exists(${LOCALBASE}/lib/libFLAC.so)
LIB_DEPENDS+= FLAC.10:${PORTSDIR}/audio/flac
.endif
+.if defined(WITH_LAME) || exists(${LOCALBASE}/bin/lame)
+RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame
+.endif
+
.if defined(WITH_GNOMEVFS) || ${HAVE_GNOME:Mgnomevfs2}
USE_GNOME+= gnomevfs2
.endif
@@ -61,9 +69,6 @@ LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
LIB_DEPENDS+= curl.5:${PORTSDIR}/ftp/curl
.endif
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include"
-CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
-
pre-configure: .SILENT
# install locale correctly (share dir instead of lib dir)
${REINPLACE_CMD} -e 's|DATADIRNAME=lib|DATADIRNAME=share|' \
@@ -72,9 +77,7 @@ pre-configure: .SILENT
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for f in ChangeLog README TODOandBUGS.txt TROUBLESHOOTING
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
.include <bsd.port.post.mk>
diff --git a/audio/gtkpod/distinfo b/audio/gtkpod/distinfo
index d5a4d3fcd4b5..5ca6ab345690 100644
--- a/audio/gtkpod/distinfo
+++ b/audio/gtkpod/distinfo
@@ -1,3 +1,3 @@
-MD5 (gtkpod-0.99.12.tar.gz) = 13162a7e9912028922aafcf81d908394
-SHA256 (gtkpod-0.99.12.tar.gz) = cf8cc91b0a4e817ba470c3d56b196048c2a38ef50c9a5b882eaddd5f40e9c33b
-SIZE (gtkpod-0.99.12.tar.gz) = 1218052
+MD5 (gtkpod-0.99.14.tar.gz) = f7948eceb955b302f4c47da4c0e1ec12
+SHA256 (gtkpod-0.99.14.tar.gz) = 73e1283482679ae0cc774aa4a07aec9491598288b36986505ec3d1c6a077ec3d
+SIZE (gtkpod-0.99.14.tar.gz) = 1856919
diff --git a/audio/gtkpod/pkg-plist b/audio/gtkpod/pkg-plist
index 1ce76466f1e3..bb5d58943e34 100644
--- a/audio/gtkpod/pkg-plist
+++ b/audio/gtkpod/pkg-plist
@@ -1,27 +1,60 @@
bin/gtkpod
-%%DATADIR%%/data/gtkpod.glade
-%%DATADIR%%/data/cdshine.png
-%%DATADIR%%/data/cdshine_main.png
%%DATADIR%%/data/default-cover.png
-%%DATADIR%%/data/gphoto_album_menuitem-32.png
-%%DATADIR%%/data/gphoto_album_menuitem-48.png
-%%DATADIR%%/data/gphoto_images_menuitem-32.png
-%%DATADIR%%/data/gphoto_images_menuitem-48.png
-%%DATADIR%%/data/gphoto_tools_menuitem-32.png
-%%DATADIR%%/data/gphoto_tools_menuitem-48.png
-%%DATADIR%%/data/gphoto_playlist_icon-48.png
%%DATADIR%%/data/gtkpod-add-dirs.png
%%DATADIR%%/data/gtkpod-add-files.png
%%DATADIR%%/data/gtkpod-add-playlists.png
-%%DATADIR%%/data/gtkpod-icon-32.png
%%DATADIR%%/data/gtkpod-icon-32-2.png
+%%DATADIR%%/data/gtkpod-icon-32.png
%%DATADIR%%/data/gtkpod-icon-48.png
%%DATADIR%%/data/gtkpod-logo.png
-%%DATADIR%%/data/gtkpod-new-playlist.png
-%%DATADIR%%/data/gtkpod-read.png
%%DATADIR%%/data/gtkpod-read-16.png
-%%DATADIR%%/data/gtkpod-sync.png
-%%DATADIR%%/data/tunes_playlist_icon-48.png
+%%DATADIR%%/data/gtkpod-read.png
+%%DATADIR%%/data/gtkpod.glade
+%%DATADIR%%/data/photo-toolbar-album.png
+%%DATADIR%%/data/photo-toolbar-photos.png
+%%DATADIR%%/doc/adding-cover-art-from-a-browser.html
+%%DATADIR%%/doc/adding-files-and-folders.html
+%%DATADIR%%/doc/advanced-features.html
+%%DATADIR%%/doc/copying-content-to-the-ipod.html
+%%DATADIR%%/doc/cover-art.html
+%%DATADIR%%/doc/exporting-files-from-the-ipod.html
+%%DATADIR%%/doc/figures/add-folders.png
+%%DATADIR%%/doc/figures/cover-fullsize.png
+%%DATADIR%%/doc/figures/cover-popupmenu.png
+%%DATADIR%%/doc/figures/cover-setfromfile.png
+%%DATADIR%%/doc/figures/coverart.png
+%%DATADIR%%/doc/figures/edit-track-details.png
+%%DATADIR%%/doc/figures/gtkpod.png
+%%DATADIR%%/doc/getting-started.html
+%%DATADIR%%/doc/gtkpod-info.html
+%%DATADIR%%/doc/gtkpod.html
+%%DATADIR%%/doc/gtkpod.xml
+%%DATADIR%%/doc/hooking-up-the-ipod.html
+%%DATADIR%%/doc/ipod-and-content.html
+%%DATADIR%%/doc/ipod-file-recovery.html
+%%DATADIR%%/doc/layout-of-gtkpod.html
+%%DATADIR%%/doc/managing-playlists.html
+%%DATADIR%%/doc/playcounts-and-ratings.html
+%%DATADIR%%/doc/playlists-podcasts-and-photos.html
+%%DATADIR%%/doc/setting-ipod-properties.html
+%%DATADIR%%/doc/the-sysinfo-file.html
+%%DATADIR%%/doc/troubleshooting-faq.html
+%%DATADIR%%/doc/view-and-edit-track-details.html
+%%DATADIR%%/icons/hicolor/16x16/places/playlist-photo.png
+%%DATADIR%%/icons/hicolor/16x16/places/playlist.png
+%%DATADIR%%/icons/hicolor/16x16/status/star-none.png
+%%DATADIR%%/icons/hicolor/16x16/status/star-set.png
+%%DATADIR%%/icons/hicolor/16x16/status/star-unset.png
+%%DATADIR%%/icons/hicolor/22x22/places/playlist-photo.png
+%%DATADIR%%/icons/hicolor/22x22/places/playlist.png
+%%DATADIR%%/icons/hicolor/24x24/places/playlist-photo.png
+%%DATADIR%%/icons/hicolor/24x24/places/playlist.png
+%%DATADIR%%/icons/hicolor/32x32/places/playlist-photo.png
+%%DATADIR%%/icons/hicolor/32x32/places/playlist.png
+%%DATADIR%%/icons/hicolor/48x48/places/playlist-photo.png
+%%DATADIR%%/icons/hicolor/48x48/places/playlist.png
+%%DATADIR%%/icons/hicolor/scalable/places/playlist-photo.svg
+%%DATADIR%%/icons/hicolor/scalable/places/playlist.svg
%%DATADIR%%/scripts/convert-2m4a.sh
%%DATADIR%%/scripts/convert-2mp3.sh
%%DATADIR%%/scripts/gtkpod-convert-common.sh
@@ -36,26 +69,38 @@ bin/gtkpod
%%DATADIR%%/scripts/sync-ldif.sh
%%DATADIR%%/scripts/sync-notes.sh
%%DATADIR%%/scripts/sync-palm-jppy.py
-%%DATADIR%%/scripts/sync-thunderbird.sh
%%DATADIR%%/scripts/sync-thunderbird-nano.sh
+%%DATADIR%%/scripts/sync-thunderbird.sh
%%DATADIR%%/scripts/sync-tomboy.sh
%%DATADIR%%/scripts/sync-webcalendar.sh
@dirrm %%DATADIR%%/scripts
+@dirrm %%DATADIR%%/icons/hicolor/scalable/places
+@dirrm %%DATADIR%%/icons/hicolor/scalable
+@dirrm %%DATADIR%%/icons/hicolor/48x48/places
+@dirrm %%DATADIR%%/icons/hicolor/48x48
+@dirrm %%DATADIR%%/icons/hicolor/32x32/places
+@dirrm %%DATADIR%%/icons/hicolor/32x32
+@dirrm %%DATADIR%%/icons/hicolor/24x24/places
+@dirrm %%DATADIR%%/icons/hicolor/24x24
+@dirrm %%DATADIR%%/icons/hicolor/22x22/places
+@dirrm %%DATADIR%%/icons/hicolor/22x22
+@dirrm %%DATADIR%%/icons/hicolor/16x16/status
+@dirrm %%DATADIR%%/icons/hicolor/16x16/places
+@dirrm %%DATADIR%%/icons/hicolor/16x16
+@dirrm %%DATADIR%%/icons/hicolor
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%/doc/figures
+@dirrm %%DATADIR%%/doc
@dirrm %%DATADIR%%/data
@dirrm %%DATADIR%%
+share/icons/hicolor/16x16/apps/gtkpod.png
+share/icons/hicolor/22x22/apps/gtkpod.png
+share/icons/hicolor/24x24/apps/gtkpod.png
share/icons/hicolor/32x32/apps/gtkpod.png
share/icons/hicolor/48x48/apps/gtkpod.png
share/icons/hicolor/64x64/apps/gtkpod.png
+share/icons/hicolor/scalable/apps/gtkpod.svg
share/applications/gtkpod.desktop
-@dirrmtry share/applications
-@dirrmtry share/icons/hicolor/64x64/apps
-@dirrmtry share/icons/hicolor/64x64
-@dirrmtry share/icons/hicolor/48x48/apps
-@dirrmtry share/icons/hicolor/48x48
-@dirrmtry share/icons/hicolor/32x32/apps
-@dirrmtry share/icons/hicolor/32x32
-@dirrmtry share/icons/hicolor
-@dirrmtry share/icons
share/locale/de/LC_MESSAGES/gtkpod.mo
share/locale/es/LC_MESSAGES/gtkpod.mo
share/locale/fr/LC_MESSAGES/gtkpod.mo
@@ -65,8 +110,4 @@ share/locale/ja/LC_MESSAGES/gtkpod.mo
share/locale/ro/LC_MESSAGES/gtkpod.mo
share/locale/ru/LC_MESSAGES/gtkpod.mo
share/locale/sv/LC_MESSAGES/gtkpod.mo
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODOandBUGS.txt
-%%PORTDOCS%%%%DOCSDIR%%/TROUBLESHOOTING
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+share/locale/zh_CN/LC_MESSAGES/gtkpod.mo