aboutsummaryrefslogtreecommitdiff
path: root/audio/guidolib
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-01-27 06:19:51 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-01-27 06:19:51 +0000
commit6387716686a42df5b747dacf1baa85cda66c7a41 (patch)
tree046fe03d461aaa2ef542cba9b12c6713d98a01a4 /audio/guidolib
parent86b232e1c2bdbbc92d10bdc5c8df6ed19a798479 (diff)
downloadports-6387716686a42df5b747dacf1baa85cda66c7a41.tar.gz
ports-6387716686a42df5b747dacf1baa85cda66c7a41.zip
New port: audio/guidolib: Library for graphic rendering of music scores
Guidolib implements a new way to encode and typeset music on computer. The common, most ubuiquitous way is MusicXML. It is the XML schema that is hardly readable for humans. Guidolib takes an alternative approach, and represents music notation in a way very similar to a computer program. It is easily readable and writable by humans. http://guidolib.sourceforge.net/ PR: 221838 Approved by: tcberner (mentor) Differential Revision: D13705
Notes
Notes: svn path=/head/; revision=460075
Diffstat (limited to 'audio/guidolib')
-rw-r--r--audio/guidolib/Makefile107
-rw-r--r--audio/guidolib/distinfo3
-rw-r--r--audio/guidolib/pkg-descr20
-rw-r--r--audio/guidolib/pkg-plist66
4 files changed, 196 insertions, 0 deletions
diff --git a/audio/guidolib/Makefile b/audio/guidolib/Makefile
new file mode 100644
index 000000000000..a055e61cb710
--- /dev/null
+++ b/audio/guidolib/Makefile
@@ -0,0 +1,107 @@
+# $FreeBSD$
+
+PORTNAME= guidolib
+DISTVERSIONPREFIX= v
+DISTVERSION= 164-61
+DISTVERSIONSUFFIX= -gbcd5705d
+CATEGORIES= audio graphics print
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Library for graphic rendering of music scores
+
+LICENSE= MPL20
+
+BUILD_DEPENDS= cmake:devel/cmake
+
+USES= gmake pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= grame-cncm
+USE_QT5= core gui widgets printsupport xml buildtools_build qmake_build
+USE_GL= gl
+USE_GNOME= cairo
+USE_LDCONFIG= yes
+BUILD_WRKSRC= ${WRKSRC}/build
+
+MAKE_ARGS= LINUXMIDI=no
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+PORTDOCS= *
+PORTEXAMPLES= *
+
+post-extract:
+ @${RM} -r ${WRKSRC}/src/midisharelight
+
+post-patch:
+ @${REINPLACE_CMD} -i '' -E ' \
+ s|Linux|FreeBSD|; \
+ s|-DMIDIEXPORT=yes|-DMIDIEXPORT=off|' \
+ $$(${FIND} ${WRKSRC} -name Makefile) \
+ $$(${FIND} ${WRKSRC}/environments/Qt -name Make.shared)
+ @${REINPLACE_CMD} -i '' -e ' \
+ s|PUBLIC_HEADER DESTINATION /usr/include/guido|PUBLIC_HEADER DESTINATION ${PREFIX}/include/guido|; \
+ s|LIBDEST /usr/lib|LIBDEST ${PREFIX}/lib|; \
+ s|LIBPATH "/usr/lib"|LIBPATH "${LOCALBASE}/lib"|; \
+ s|-L/usr/local|-L${LOCALBASE}|' \
+ ${WRKSRC}/build/CMakeLists.txt
+ @${REINPLACE_CMD} -i '' -e ' \
+ s|-lGUIDOEngine|-L${WRKSRC}/build -lGUIDOEngine|' \
+ ${WRKSRC}/environments/Qt/apps/GUIDOEngine.shared \
+ ${WRKSRC}/environments/Qt/GuidoServer/GUIDOEngineLink.pri \
+ ${WRKSRC}/environments/Qt/libs/GuidoQt/GuidoQt.pro \
+ ${WRKSRC}/environments/Qt/apps/guido2image/Makefile \
+ ${WRKSRC}/src/tools/Makefile \
+ ${WRKSRC}/validate/Makefile
+ @${REINPLACE_CMD} -i '' -e ' \
+ s|!android:CONFIG += staticlib|#!android:CONFIG += staticlib|' \
+ ${WRKSRC}/environments/Qt/libs/GuidoQt/GuidoQt.pro
+ @${REINPLACE_CMD} -i '' -e ' \
+ s|/usr|$$(DESTDIR)$$(PREFIX)|; \
+ s|libGuidoQt.a|libGuidoQt.*|' \
+ ${WRKSRC}/environments/Qt/libs/Makefile
+ @${REINPLACE_CMD} -i '' -e ' \
+ s|SET(CMAKE_INSTALL_PREFIX /usr )|SET(CMAKE_INSTALL_PREFIX ${PREFIX} )|' \
+ ${WRKSRC}/build/CMakeLists.txt \
+ ${WRKSRC}/src/tools/build/CMakeLists.txt
+
+do-install:
+ ${INSTALL_PROGRAM} \
+ ${WRKSRC}/environments/Qt/apps/GuidoEditor/GuidoEditor \
+ ${WRKSRC}/environments/Qt/apps/GuidoSceneComposer/GuidoSceneComposer \
+ ${WRKSRC}/environments/Qt/apps/guido2image/guido2image \
+ ${WRKSRC}/src/tools/build/linux/midi2proll \
+ ${WRKSRC}/src/tools/build/linux/guido* \
+ ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${PREFIX}/include/guido
+ ${INSTALL_DATA} \
+ ${WRKSRC}/src/engine/include/*.h \
+ ${WRKSRC}/platforms/linux/src/Cairo*.h \
+ ${WRKSRC}/environments/Qt/libs/GuidoQt/include/*.h \
+ ${STAGEDIR}${PREFIX}/include/guido
+ ${INSTALL_LIB} \
+ ${WRKSRC}/build/libGUIDOEngine.* \
+ ${WRKSRC}/environments/Qt/libs/libGuidoQt.* \
+ ${STAGEDIR}${PREFIX}/lib
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/fonts/guido
+ ${INSTALL_DATA} \
+ ${WRKSRC}/src/guido2.ttf \
+ ${STAGEDIR}${PREFIX}/share/fonts/guido
+.for sz in 48 128
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${sz}x${sz}/apps
+ ${INSTALL_DATA} \
+ ${WRKSRC}/environments/Qt/package/debianbase/usr/share/icons/hicolor/${sz}x${sz}/apps/* \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${sz}x${sz}/apps
+.endfor
+ ${INSTALL_DATA} \
+ ${WRKSRC}/environments/Qt/package/debianbase/usr/share/applications/*.desktop \
+ ${STAGEDIR}${DESKTOPDIR}
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/package/doc/*.pdf ${STAGEDIR}${DOCSDIR}
+ ${CP} -r ${WRKSRC}/package/doc/html ${STAGEDIR}${DOCSDIR}
+
+do-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${CP} -r ${WRKSRC}/gmn-examples/* ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/audio/guidolib/distinfo b/audio/guidolib/distinfo
new file mode 100644
index 000000000000..f0aae4969ab6
--- /dev/null
+++ b/audio/guidolib/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1514688196
+SHA256 (grame-cncm-guidolib-v164-61-gbcd5705d_GH0.tar.gz) = 2a8edde89e6c1edb64ee8bc430e86524dc89979671912e4f0faefdb6a2e3ae15
+SIZE (grame-cncm-guidolib-v164-61-gbcd5705d_GH0.tar.gz) = 24893281
diff --git a/audio/guidolib/pkg-descr b/audio/guidolib/pkg-descr
new file mode 100644
index 000000000000..5cefc1a7babc
--- /dev/null
+++ b/audio/guidolib/pkg-descr
@@ -0,0 +1,20 @@
+The Guido Engine Library is a generic, portable library and API for the
+graphical rendering of musical scores. The library is based on the GUIDO
+Music Notation Format as the underlying data format. It takes account of
+the conventional music notation system and should be flexible enough to
+include any graphical sign and musical information if necessary.
+
+The GUIDO Music Notation Format [GMN] is a formal language for score level
+music representation. It is a plain-text, i.e. readable and platform
+independent format capable of representing all information contained in
+conventional musical scores. The basic GUIDO Format is very flexible and can
+be easily extended and adapted to capture a wide variety of musical features
+beyond conventional musical notation (CMN). The GUIDO design is strongly
+influenced by the objective to facilitate an adequate representation of musical
+material, from tiny motives up to complex symphonic scores. GUIDO is a general
+purpose musical notation format; the intended range of application includes
+notation software, compositional and analytical systems and tools, performance
+systems, and large musical databases. It is powerful, flexible, easily
+portable, and human readable.
+
+WWW: http://guidolib.sourceforge.net/
diff --git a/audio/guidolib/pkg-plist b/audio/guidolib/pkg-plist
new file mode 100644
index 000000000000..145b028ad01d
--- /dev/null
+++ b/audio/guidolib/pkg-plist
@@ -0,0 +1,66 @@
+bin/GuidoEditor
+bin/GuidoSceneComposer
+bin/guido2abstract
+bin/guido2image
+bin/guido2midi
+bin/guido2proll
+bin/guido2svg
+bin/guido2svgmap
+bin/guidoar2gr
+bin/guidodraw
+bin/guidogetpagecount
+bin/guidogetpagemap
+bin/guidogetstaffmap
+bin/guidogetsystemmap
+bin/guidogettimemap
+bin/guidogetversion
+bin/guidogetvoicecount
+bin/guidogetvoicemap
+bin/guidoparse
+bin/midi2proll
+include/guido/CairoDevice.h
+include/guido/CairoFont.h
+include/guido/CairoSystem.h
+include/guido/Colors.h
+include/guido/GDeviceQt.h
+include/guido/GFontQt.h
+include/guido/GSystemQt.h
+include/guido/GUIDO2Midi.h
+include/guido/GUIDOEngine.h
+include/guido/GUIDOEngineAdapter.h
+include/guido/GUIDOExport.h
+include/guido/GUIDOFactory.h
+include/guido/GUIDOFactoryAdapter.h
+include/guido/GUIDOParse.h
+include/guido/GUIDOPianoRoll.h
+include/guido/GUIDOPianoRollAdapter.h
+include/guido/GUIDOReducedProportional.h
+include/guido/GUIDOReducedProportionalAdapter.h
+include/guido/GUIDOScoreMap.h
+include/guido/GUIDOScoreMapAdapter.h
+include/guido/Guido2Image.h
+include/guido/QGuidoGraphicsItem.h
+include/guido/QGuidoImporter.h
+include/guido/QGuidoPainter.h
+include/guido/QGuidoWidget.h
+include/guido/QPageManager.h
+include/guido/TRect.h
+include/guido/VGColor.h
+include/guido/VGDevice.h
+include/guido/VGFont.h
+include/guido/VGPen.h
+include/guido/VGSystem.h
+lib/libGUIDOEngine.so
+lib/libGUIDOEngine.so.1
+lib/libGUIDOEngine.so.1.65
+lib/libGuidoQt.so
+lib/libGuidoQt.so.1
+lib/libGuidoQt.so.1.0
+lib/libGuidoQt.so.1.0.0
+share/applications/GuidoEditor.desktop
+share/applications/GuidoSceneComposer.desktop
+share/fonts/guido/guido2.ttf
+share/icons/hicolor/128x128/apps/guidoeditor.png
+share/icons/hicolor/128x128/apps/guidoscenecomposer.png
+share/icons/hicolor/48x48/apps/guidoeditor.png
+share/icons/hicolor/48x48/apps/guidoscenecomposer.png