aboutsummaryrefslogtreecommitdiff
path: root/audio/hexter
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-04-12 18:17:45 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-04-12 18:17:45 +0000
commit6f3d81280186f24eb94b92eb4be1cd2465e25d02 (patch)
tree80f479d8fe14aa1ffe63ee6f874b9cde33bc6faa /audio/hexter
parent5ec71d30af38d7cb471732ced73f09d24a9a5d19 (diff)
downloadports-6f3d81280186f24eb94b92eb4be1cd2465e25d02.tar.gz
ports-6f3d81280186f24eb94b92eb4be1cd2465e25d02.zip
- Remove TODO from DOCS
- Add REINPLACE, fix build on FreeBSD 11, Clang not have -finline-limit - Strip library
Notes
Notes: svn path=/head/; revision=351116
Diffstat (limited to 'audio/hexter')
-rw-r--r--audio/hexter/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/audio/hexter/Makefile b/audio/hexter/Makefile
index f0dbc66878ed..0d6199011efe 100644
--- a/audio/hexter/Makefile
+++ b/audio/hexter/Makefile
@@ -21,11 +21,15 @@ USES= gmake pkgconfig
GNU_CONFIGURE= yes
USE_GNOME= gtk20
-PORTDOCS= AUTHORS ChangeLog README TODO
-
+PORTDOCS= AUTHORS ChangeLog README
OPTIONS_DEFINE= DOCS
+post-patch:
+ @${REINPLACE_CMD} -e 's|-finline-limit=5000||' ${WRKSRC}/configure
+
post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/dssi/hexter.so
+
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}