aboutsummaryrefslogtreecommitdiff
path: root/audio/hydrogen
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-10 19:50:23 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-10 19:50:23 +0000
commit3b7bd0a1490f574288fc9a02617a19cf238254e0 (patch)
treec05d182f965de6bace293ed87ece71bd45e7c422 /audio/hydrogen
parent913e08e52dca0eafb130dc0942c6275a178095ea (diff)
downloadports-3b7bd0a1490f574288fc9a02617a19cf238254e0.tar.gz
ports-3b7bd0a1490f574288fc9a02617a19cf238254e0.zip
Fix problems with missing libs when the linker enforces explicit linking
(a* to d* categories) PR: 192062
Notes
Notes: svn path=/head/; revision=364564
Diffstat (limited to 'audio/hydrogen')
-rw-r--r--audio/hydrogen/Makefile4
-rw-r--r--audio/hydrogen/files/patch-Sconstruct12
2 files changed, 11 insertions, 5 deletions
diff --git a/audio/hydrogen/Makefile b/audio/hydrogen/Makefile
index d4974c968fea..b5b368cc28cf 100644
--- a/audio/hydrogen/Makefile
+++ b/audio/hydrogen/Makefile
@@ -28,7 +28,7 @@ OPTIONS_DEFAULT= JACK
LIBARCHIVE_DESC= LibArchive support
post-patch:
- ${REINPLACE_CMD} -e "s|includes = \[\]|includes = \['-I${QT_INCDIR}/QtCore', '-I${QT_INCDIR}/QtXml', '-I${QT_INCDIR}/QtGui', '-I${QT_INCDIR}', '-I${QT_INCDIR}/Qt', '-I${LOCALBASE}/include', '-I${LOCALBASE}/include/raptor2'\]|g; s|ldflags = \[\]|ldflags = \['-L${QT_LIBDIR}','-L${LOCALBASE}/lib'\,'-lQtCore', '-lQtGui', '-lQtXml', '-lQtNetwork', '${PTHREAD_LIBS}']|g" ${WRKSRC}/Sconstruct
+ ${REINPLACE_CMD} -e "s|includes = \[\]|includes = \['-I${QT_INCDIR}/QtCore', '-I${QT_INCDIR}/QtXml', '-I${QT_INCDIR}/QtGui', '-I${QT_INCDIR}', '-I${QT_INCDIR}/Qt', '-I${LOCALBASE}/include', '-I${LOCALBASE}/include/raptor2'\]|g; s|ldflags = \[\]|ldflags = \['-L${QT_LIBDIR}','-L${LOCALBASE}/lib'\,'-lQtCore', '-lQtGui', '-lQtXml', '-lQtNetwork']|g" ${WRKSRC}/Sconstruct
.include <bsd.port.options.mk>
@@ -36,8 +36,6 @@ MAKE_ARGS+= oss=1
.if ${PORT_OPTIONS:MJACK}
LIB_DEPENDS+= libjack.so:${PORTSDIR}/audio/jack
-CPPFLAGS+= ${PTHREAD_CFLAGS}
-LDFLAGS+= ${PTHREAD_LIBS}
MAKE_ARGS+= jack=1
.else
MAKE_ARGS+= jack=0
diff --git a/audio/hydrogen/files/patch-Sconstruct b/audio/hydrogen/files/patch-Sconstruct
index cce4295e0f11..f817238e3c03 100644
--- a/audio/hydrogen/files/patch-Sconstruct
+++ b/audio/hydrogen/files/patch-Sconstruct
@@ -18,12 +18,21 @@
ldflags.append('-lpthread')
ldflags.append('-lasound')
# ldflags.append('-lrubberband')
-
+
+ elif sys.platform > 'freebsd' :
+ print "Alsa disabled; nothing to do"
elif sys.platform == "win32":
includes.append( '3rdparty\libsndfile-1_0_17' )
includes.append( 'build\pthreads\include' )
+@@ -279,7 +281,7 @@
+ if str(env['lash']) == "1":
+ env.ParseConfig('pkg-config --cflags --libs lash-1.0')
+
+- if sys.platform == "darwin" or sys.platform == "linux2" or sys.platform == "linux3":
++ if sys.platform == "darwin" or sys.platform == "linux2" or sys.platform == "linux3" or sys.platform > "freebsd":
+ env.Append( LIBS = ["z"] )
+ env.Append( LIBS = ["pthread"] )
+
@@ -299,7 +301,7 @@
for N in glob.glob('./data/i18n/hydrogen.*'):
@@ -46,4 +55,3 @@
print ""
-