aboutsummaryrefslogtreecommitdiff
path: root/audio/hydrogen
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-12-29 22:19:01 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-12-29 22:19:01 +0000
commitab1393f70519810221d7be12237abb477134d776 (patch)
tree7dc7bc8f24d34b1c742a273fe6a4f840d3293e27 /audio/hydrogen
parente8a4f85fe207e568dea1f1c54d2fab556640944d (diff)
downloadports-ab1393f70519810221d7be12237abb477134d776.tar.gz
ports-ab1393f70519810221d7be12237abb477134d776.zip
- Convert to new options framework
- remove shlib numbers - trim headers PR: ports/173795 Submitted by: Chris Petrik <c.petrik.sosa@gmail.com> Approved by: maintainer timeout (1 month)
Notes
Notes: svn path=/head/; revision=309634
Diffstat (limited to 'audio/hydrogen')
-rw-r--r--audio/hydrogen/Makefile40
1 files changed, 18 insertions, 22 deletions
diff --git a/audio/hydrogen/Makefile b/audio/hydrogen/Makefile
index 4191c0e92e67..4213357f993a 100644
--- a/audio/hydrogen/Makefile
+++ b/audio/hydrogen/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Hydrogen
-# Date created: 23 Jun 2004
-# Whom: Jean-Yves Lefort <jylefort@brutele.be>
-#
+# Created by: Jean-Yves Lefort <jylefort@brutele.be>
# $FreeBSD$
-#
PORTNAME= hydrogen
PORTVERSION= 0.9.5
@@ -13,24 +9,23 @@ MASTER_SITES= SF/${PORTNAME}/Hydrogen/${MAJORVERSION}%20Sources
MAINTAINER= devel@stasyan.com
COMMENT= An advanced drum machine
-LIB_DEPENDS+= sndfile:${PORTSDIR}/audio/libsndfile \
- tar.0:${PORTSDIR}/devel/libtar \
- lrdf.2:${PORTSDIR}/textproc/liblrdf
-
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+LIB_DEPENDS+= sndfile:${PORTSDIR}/audio/libsndfile \
+ tar:${PORTSDIR}/devel/libtar \
+ lrdf:${PORTSDIR}/textproc/liblrdf
+
BROKEN= does not install
MAJORVERSION= 0.9.5
USE_QT4= corelib gui linguist_build moc_build network qt3support rcc_build sql uic_build xml
USE_SCONS= yes
-OPTIONS= JACK "JACK support" on \
- ALSA "ALSA support" off \
- PORTAUDIO "PortAudio support" off \
- LIBARCHIVE "LibArchive support" off \
- LASH "Lash support" off
+OPTIONS_DEFINE= JACK ALSA PORTAUDIO LIBARCHIVE LASH
+OPTIONS_DEFAULT= JACK
+
+LIBARCHIVE_DESC= LibArchive support
post-patch:
${REINPLACE_CMD} -e "s|includes = \[\]|includes = \['-I${QT_INCDIR}/QtCore', '-I${QT_INCDIR}/QtXml', '-I${QT_INCDIR}/QtGui', '-I${QT_INCDIR}', '-I${QT_INCDIR}/Qt', '-I${LOCALBASE}/include'\]|g; s|ldflags = \[\]|ldflags = \['-L${QT_LIBDIR}','-L${LOCALBASE}/lib'\,'-lQtCore', '-lQtGui', '-lQtXml', '-lQtNetwork', '${PTHREAD_LIBS}']|g" ${WRKSRC}/Sconstruct
@@ -38,7 +33,8 @@ post-patch:
.include <bsd.port.options.mk>
SCONS_ENV+= oss=1
-.if defined(WITH_JACK)
+
+.if ${PORT_OPTIONS:MJACK}
LIB_DEPENDS+= jack:${PORTSDIR}/audio/jack
CPPFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS}
@@ -47,30 +43,30 @@ SCONS_ENV+= jack=1
SCONS_ENV+= jack=0
.endif
-.if defined(WITH_PORTAUDIO)
-LIB_DEPENDS+= portaudio.0:${PORTSDIR}/audio/portaudio
+.if ${PORT_OPTIONS:MPORTAUDIO}
+LIB_DEPENDS+= portaudio:${PORTSDIR}/audio/portaudio
SCONS_ENV+= portaudio=1
.else
SCONS_ENV+= portaudio=0
.endif
-.if defined(WITH_LIBARCHIVE)
+.if ${PORT_OPTIONS:MLIBARCHIVE}
LIB_DEPENDS+= archive:${PORTSDIR}/archivers/libarchive
SCONS_ENV+= libarchive=1
.else
SCONS_ENV+= libarchive=0
.endif
-.if defined(WITH_ALSA)
-LIB_DEPENDS+= asound.2:${PORTSDIR}/audio/alsa-lib
+.if ${PORT_OPTIONS:MALSA}
+LIB_DEPENDS+= asound:${PORTSDIR}/audio/alsa-lib
RUN_DEPENDS+= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:${PORTSDIR}/audio/alsa-plugins
SCONS_ENV+= alsa=1
.else
SCONS_ENV+= alsa=0
.endif
-.if defined(WITH_LASH)
-LIB_DEPENDS+= lash.2:${PORTSDIR}/audio/lash
+.if ${PORT_OPTIONS:MLASH}
+LIB_DEPENDS+= lash:${PORTSDIR}/audio/lash
SCONS_ENV+= lash=1
.else
SCONS_ENV+= lash=0