aboutsummaryrefslogtreecommitdiff
path: root/audio/icecast
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-06-01 17:11:34 +0000
committerWill Andrews <will@FreeBSD.org>2000-06-01 17:11:34 +0000
commit22ef18a5109885c8cc837c482d398b1da433394f (patch)
tree0f4c585bc84d2ac3e576430f47db92e16030af7f /audio/icecast
parenta7dd0f880ea8199514cdeec74dd8d9408da1b2b4 (diff)
downloadports-22ef18a5109885c8cc837c482d398b1da433394f.tar.gz
ports-22ef18a5109885c8cc837c482d398b1da433394f.zip
Update to 1.3.5. I cleaned up the Makefile in addition to the PR, and
made pkg/MESSAGE respect PREFIX (which made this port finally pass the mandatory ``portlint -ac'' test). PR: 18834 Submitted by: Zach Zurflu <zach@pabst.bendnet.com>
Notes
Notes: svn path=/head/; revision=29064
Diffstat (limited to 'audio/icecast')
-rw-r--r--audio/icecast/Makefile70
-rw-r--r--audio/icecast/distinfo2
-rw-r--r--audio/icecast/pkg-comment2
-rw-r--r--audio/icecast/pkg-descr10
-rw-r--r--audio/icecast/pkg-message22
-rw-r--r--audio/icecast/pkg-plist73
6 files changed, 64 insertions, 115 deletions
diff --git a/audio/icecast/Makefile b/audio/icecast/Makefile
index 0bbb8c5100b1..a9a3e360b496 100644
--- a/audio/icecast/Makefile
+++ b/audio/icecast/Makefile
@@ -1,62 +1,34 @@
-# New ports collection makefile for: icecast
-# Date created: 28 Jan 1999
-# Whom: Chip Marshall <chip@eboai.org>
+# New ports collection makefile for: icecast
+# Date created: 28 Jan 1999
+# Whom: Chip Marshall <chip@eboai.org>
#
# $FreeBSD$
#
PORTNAME= icecast
-PORTVERSION= 1.3.0
+PORTVERSION= 1.3.5
CATEGORIES= audio net
-MASTER_SITES= http://www.icecast.org/releases/ \
- ftp://ftp.eboai.org/pub/icecast/
+MASTER_SITES= http://www.icecast.org/releases/
MAINTAINER= chip@eboai.org
-WRKSRC= ${WRKDIR}/icecast-1.3
-
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libwrap
-
-ALL_TARGET= all mkpasswd
-
-post-extract:
- @( cd ${WRKSRC}; ${RM} -f shout/calibrate shout/stresstest )
-
-post-configure:
- @${MAKE} WRKSRC=${WRKSRC}/liveice do-configure
-
-post-build:
- @${MAKE} WRKSRC=${WRKSRC}/liveice ALL_TARGET=all do-build
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS=--with-libwrap
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/icecast ${PREFIX}/sbin
- ${INSTALL_PROGRAM} ${WRKSRC}/mkpasswd ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/shout/listen ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/shout/shout ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/shout/calibrate ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/shout/stresstest ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/liveice/liveice ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/shout/iceplay ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/icecast
- ${INSTALL_MAN} ${WRKSRC}/doc/* ${PREFIX}/share/doc/icecast
- ${INSTALL_MAN} ${WRKSRC}/liveice/README.liveice ${PREFIX}/share/doc/icecast
- ${INSTALL_MAN} ${WRKSRC}/liveice/README.xingmp3enc ${PREFIX}/share/doc/icecast
- ${INSTALL_MAN} ${WRKSRC}/liveice/README_new_mixer.txt ${PREFIX}/share/doc/icecast
- ${MKDIR} ${PREFIX}/share/examples/icecast
- ${INSTALL_MAN} ${WRKSRC}/icecast.conf ${PREFIX}/share/examples/icecast
- ${INSTALL_MAN} ${WRKSRC}/liveice/liveice.cfg ${PREFIX}/share/examples/icecast
- ${INSTALL_MAN} ${WRKSRC}/shout/shoutrc.example ${PREFIX}/share/examples/icecast
- ${INSTALL_MAN} ${WRKSRC}/shout/playlist.example ${PREFIX}/share/examples/icecast
- ${INSTALL_MAN} ${WRKSRC}/shout/radio.tcl.example ${PREFIX}/share/examples/icecast
- ${MKDIR} ${PREFIX}/share/examples/icecast/icedir
- ${INSTALL_MAN} ${WRKSRC}/icedir/* ${PREFIX}/share/examples/icecast/icedir
- ${MKDIR} ${PREFIX}/share/examples/icecast/templates
- ${INSTALL_MAN} ${WRKSRC}/templates/* ${PREFIX}/share/examples/icecast/templates
- ${INSTALL_MAN} ${WRKSRC}/liveice/frontend.tcl ${PREFIX}/share/examples/icecast
- ${INSTALL_MAN} ${WRKSRC}/liveice/liveiceconfigure.tk ${PREFIX}/share/examples/icecast
-.endif
- @${CAT} ${PKGDIR}/MESSAGE
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/icecast ${PREFIX}/sbin
+ ${MKDIR} ${PREFIX}/etc/icecast/conf
+ ${MKDIR} ${PREFIX}/etc/icecast/templates
+.for CONF in groups.aut.dist icecast.conf.dist mounts.aut.dist users.aut.dist
+ ${INSTALL_DATA} ${WRKSRC}/conf/${CONF} ${PREFIX}/etc/icecast/conf
+.endfor
+.for TEMPL in 306.html 400.html 403.html 404.html 504.html bodytag.html info.html \
+ list_directory.html mountlist.html statistics.html admin_describe.html \
+ admin.html alias_add.html manual.html alias_del.html
+ ${INSTALL_DATA} ${WRKSRC}/templates/${TEMPL} ${PREFIX}/etc/icecast/templates
+.endfor
+ ${MKDIR} ${PREFIX}/share/doc/icecast/
+ ${INSTALL_DATA} ${WRKSRC}/doc/manual.html ${PREFIX}/share/doc/icecast/
+ @${CAT} ${PKGDIR}/MESSAGE | ${SED} -e 's,%%PREFIX%%,${PREFIX},g'
.include <bsd.port.mk>
diff --git a/audio/icecast/distinfo b/audio/icecast/distinfo
index 45815d8e8ec7..cabfdcadedd8 100644
--- a/audio/icecast/distinfo
+++ b/audio/icecast/distinfo
@@ -1 +1 @@
-MD5 (icecast-1.3.0.tar.gz) = d322cc60b5f3185a764bf65adca282e4
+MD5 (icecast-1.3.5.tar.gz) = 29f762ab1f48c9b45b2eec4a7922c063
diff --git a/audio/icecast/pkg-comment b/audio/icecast/pkg-comment
index 0f379ec1fb9d..3f6bcecbfc0a 100644
--- a/audio/icecast/pkg-comment
+++ b/audio/icecast/pkg-comment
@@ -1 +1 @@
-A SHOUTcast-compatible streaming MP3 server
+Icecast is a streaming mp3 audio server
diff --git a/audio/icecast/pkg-descr b/audio/icecast/pkg-descr
index 2d2606179da3..05b40f4b6f12 100644
--- a/audio/icecast/pkg-descr
+++ b/audio/icecast/pkg-descr
@@ -1,7 +1,7 @@
-Icecast provides nearly all the functionality of the Shoutcast
-server. It will accept encoding streams from either iceplay or WinAmp.
-It can also add itself to a directory server such as our own
-icecast.linuxpower.org or Nullsoft's yp.shoutcast.com. It does not yet
-support redirection of streams from other icecast servers, but soon will.
+This is a port for icecast. Icecast is a streaming mp3 audio server.
+Icecast provides nearly all the functionality of the Shoutcast server.
+It will accept encoding streams from either iceplay or WinAmp. It can
+also add itself to a directory server such as our own
+icecast.linuxpower.org or Nullsoft's yp.shoutcast.com.
WWW: http://www.icecast.org/
diff --git a/audio/icecast/pkg-message b/audio/icecast/pkg-message
index dff2cbd91856..34690c5d02ae 100644
--- a/audio/icecast/pkg-message
+++ b/audio/icecast/pkg-message
@@ -1,11 +1,15 @@
-**********************************************************************
+-----------------------------------------------------------------
- FYI, there a several useful programs included in the
- icecast distribution that are not installed as part
- of this port. These include two ways of sending data
- to the server, a program for listening to the server,
- and another for managing a listing of servers. These
- are located in the subdirectories icedir and iceplay
- under the working directory.
+Icecast's various components have been installed in the following
+directories:
-**********************************************************************
+ - The icecast server:
+ %%PREFIX%%/sbin/icecast
+
+ - Icecast configuration files have been installed in:
+ %%PREFIX%%/etc/icecast/
+
+ - Icecast documentation is located in:
+ %%PREFIX%%/share/doc/icecast/
+
+-----------------------------------------------------------------
diff --git a/audio/icecast/pkg-plist b/audio/icecast/pkg-plist
index 3195443ba037..fe9d62e30d96 100644
--- a/audio/icecast/pkg-plist
+++ b/audio/icecast/pkg-plist
@@ -1,53 +1,26 @@
-bin/mkpasswd
-bin/listen
-bin/shout
-bin/calibrate
-bin/stresstest
-bin/liveice
-bin/iceplay
sbin/icecast
-share/doc/icecast/AUTHORS
-share/doc/icecast/BUGS
-share/doc/icecast/CHANGES
-share/doc/icecast/COPYING
-share/doc/icecast/FAQ
-share/doc/icecast/INSTALL
-share/doc/icecast/README
-share/doc/icecast/TESTED
-share/doc/icecast/TODO
+etc/icecast/conf/groups.aut.dist
+etc/icecast/conf/icecast.conf.dist
+etc/icecast/conf/mounts.aut.dist
+etc/icecast/conf/users.aut.dist
+etc/icecast/templates/306.html
+etc/icecast/templates/400.html
+etc/icecast/templates/403.html
+etc/icecast/templates/404.html
+etc/icecast/templates/504.html
+etc/icecast/templates/bodytag.html
+etc/icecast/templates/info.html
+etc/icecast/templates/list_directory.html
+etc/icecast/templates/mountlist.html
+etc/icecast/templates/statistics.html
+etc/icecast/templates/admin_describe.html
+etc/icecast/templates/admin.html
+etc/icecast/templates/alias_add.html
+etc/icecast/templates/manual.html
+etc/icecast/templates/alias_del.html
share/doc/icecast/manual.html
-share/doc/icecast/README.liveice
-share/doc/icecast/README.xingmp3enc
-share/doc/icecast/README_new_mixer.txt
-share/examples/icecast/icecast.conf
-share/examples/icecast/liveice.cfg
-share/examples/icecast/shoutrc.example
-share/examples/icecast/playlist.example
-share/examples/icecast/icedir/addsrv
-share/examples/icecast/icedir/byserver.php3
-share/examples/icecast/icedir/bystream.php3
-share/examples/icecast/icedir/db_mysql.inc
-share/examples/icecast/icedir/example.html
-share/examples/icecast/icedir/example.phtml
-share/examples/icecast/icedir/functions.phps
-share/examples/icecast/icedir/gen-playlist
-share/examples/icecast/icedir/gen-playlist.pls
-share/examples/icecast/icedir/icedir_cleanup.pl
-share/examples/icecast/icedir/remsrv
-share/examples/icecast/icedir/servers.sql
-share/examples/icecast/icedir/sources.sql
-share/examples/icecast/icedir/tchsrv
-share/examples/icecast/icedir/touch
-share/examples/icecast/icedir/yp.inc
-share/examples/icecast/radio.tcl.example
-share/examples/icecast/templates/bodytag.html
-share/examples/icecast/templates/info.html
-share/examples/icecast/templates/list_directory.html
-share/examples/icecast/templates/mountlist.html
-share/examples/icecast/templates/statistics.html
-share/examples/icecast/frontend.tcl
-share/examples/icecast/liveiceconfigure.tk
+
+@dirrm etc/icecast/conf
+@dirrm etc/icecast/templates
+@dirrm etc/icecast
@dirrm share/doc/icecast
-@dirrm share/examples/icecast/icedir
-@dirrm share/examples/icecast/templates
-@dirrm share/examples/icecast