aboutsummaryrefslogtreecommitdiff
path: root/audio/id3ed
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-01-14 19:16:49 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-01-14 19:16:49 +0000
commitc50b19684504d57bf7dfdb93342b7a88292132c1 (patch)
tree2e090e8b1be6fee76eca9ca7b669b5d623830d00 /audio/id3ed
parent8df6c0e0e2e348af622c3d6daf2940876db93df9 (diff)
downloadports-c50b19684504d57bf7dfdb93342b7a88292132c1.tar.gz
ports-c50b19684504d57bf7dfdb93342b7a88292132c1.zip
- Unbreak with CLANG/GCC46
PR: 163368 Submitted by: Jan Beich <jbeich@tormail.net> Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=289220
Diffstat (limited to 'audio/id3ed')
-rw-r--r--audio/id3ed/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/audio/id3ed/Makefile b/audio/id3ed/Makefile
index cfeac7e521f5..f8e810638ca2 100644
--- a/audio/id3ed/Makefile
+++ b/audio/id3ed/Makefile
@@ -24,4 +24,12 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/id3ed ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/id3ed.1 ${MANPREFIX}/man/man1
+post-patch:
+ @${REINPLACE_CMD} '/main/s/unsigned int/int/' \
+ ${WRKSRC}/examples/demo_*.cpp
+ @${REINPLACE_CMD} 's/\(iomanip\)\.h/\1/' ${WRKSRC}/configure
+ @${REINPLACE_CMD} '/include.*/{ p; s//include <cstring>/; n;n;n; }' \
+ ${WRKSRC}/include/id3/id3lib_strings.h \
+ ${WRKSRC}/include/id3/writers.h
+
.include <bsd.port.mk>