aboutsummaryrefslogtreecommitdiff
path: root/audio/id3lib
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-01-17 12:14:00 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-01-17 12:14:00 +0000
commit2bb92e4f1172b40413655ba66f991fa4756a22ab (patch)
tree4226c1989ada99e6495e6e8648c6c06dd43a3698 /audio/id3lib
parentec9ab59a7741ce072ea758bbf6d5b599823705be (diff)
downloadports-2bb92e4f1172b40413655ba66f991fa4756a22ab.tar.gz
ports-2bb92e4f1172b40413655ba66f991fa4756a22ab.zip
Unbreak audio/id3lib for -current
Submitted by: "Simon 'corecode' Schubert" <corecode@corecode.ath.cx> Approved by: Roman Shterenzon <roman@xpert.com> (maintainer)
Notes
Notes: svn path=/head/; revision=73336
Diffstat (limited to 'audio/id3lib')
-rw-r--r--audio/id3lib/Makefile20
1 files changed, 16 insertions, 4 deletions
diff --git a/audio/id3lib/Makefile b/audio/id3lib/Makefile
index a85f492e3817..5502b5487047 100644
--- a/audio/id3lib/Makefile
+++ b/audio/id3lib/Makefile
@@ -16,14 +16,26 @@ MAINTAINER= roman@xpert.com
LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
INSTALLS_SHLIB= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS}"
+
+LDFLAGS= -L${LOCALBASE}/lib
+
+.if ${CC} == cc || ${CC} == gcc
+COMPILER?= gcc
+.else
+COMPILER?= ${CC}
+.endif
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500000
-BROKEN= "Doesn't link properly, std::char_traits<wchar_t> thingie"
+RUN_DEPENDS= ${LOCALBASE}/lib/libstlport_${COMPILER}.so:${PORTSDIR}/devel/stlport${COMPILER:C/^/-/:S/-gcc//}
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+LDFLAGS+= -lstlport_${COMPILER}
+CPPFLAGS+= -I${LOCALBASE}/include/stlport
.endif
post-extract: