aboutsummaryrefslogtreecommitdiff
path: root/audio/id3lib
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2017-07-13 14:34:01 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2017-07-13 14:34:01 +0000
commit332c2161933e209eb423a36817d7a448e180b824 (patch)
tree3c1b3fe91ef2c3d693872ef3a167c1cf94aeaae7 /audio/id3lib
parentb25852e0a1896c6c4ac72f9d08341c89083fb47c (diff)
downloadports-332c2161933e209eb423a36817d7a448e180b824.tar.gz
ports-332c2161933e209eb423a36817d7a448e180b824.zip
audio/id3lib: fix stack corruption bug
Add a patch to fix stack corruption bug when reading IDv3 tags and VBR header information. PR: 220374 Submitted by: bob@eager.cx Obtained from: https://sourceforge.net/p/id3lib/bugs/189/ MFH: 2017Q3 Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=445652
Diffstat (limited to 'audio/id3lib')
-rw-r--r--audio/id3lib/Makefile2
-rw-r--r--audio/id3lib/files/patch-src_mp3__parse.cpp11
2 files changed, 12 insertions, 1 deletions
diff --git a/audio/id3lib/Makefile b/audio/id3lib/Makefile
index b936c005ca83..6ce2c679a237 100644
--- a/audio/id3lib/Makefile
+++ b/audio/id3lib/Makefile
@@ -3,7 +3,7 @@
PORTNAME= id3lib
PORTVERSION= 3.8.3
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= audio
MASTER_SITES= SF
diff --git a/audio/id3lib/files/patch-src_mp3__parse.cpp b/audio/id3lib/files/patch-src_mp3__parse.cpp
new file mode 100644
index 000000000000..b6c7e96be950
--- /dev/null
+++ b/audio/id3lib/files/patch-src_mp3__parse.cpp
@@ -0,0 +1,11 @@
+--- src/mp3_parse.cpp.orig 2017-07-13 13:36:15 UTC
++++ src/mp3_parse.cpp
+@@ -465,7 +465,7 @@ bool Mp3Info::Parse(ID3_Reader& reader, size_t mp3size
+ // from http://www.xingtech.com/developer/mp3/
+
+ const size_t VBR_HEADER_MIN_SIZE = 8; // "xing" + flags are fixed
+- const size_t VBR_HEADER_MAX_SIZE = 116; // frames, bytes, toc and scale are optional
++ const size_t VBR_HEADER_MAX_SIZE = 120; // frames, bytes, toc and scale are optional
+
+ if (mp3size >= vbr_header_offest + VBR_HEADER_MIN_SIZE)
+ {