aboutsummaryrefslogtreecommitdiff
path: root/audio/id3lib
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-01-23 20:39:56 +0000
committerChris Rees <crees@FreeBSD.org>2012-01-23 20:39:56 +0000
commita53eac738414f4be5543b6d3888c66016aa9c5c8 (patch)
tree732ccf8f6a04e7b4ecdb11ea3ad753feb00b9e06 /audio/id3lib
parentf2c674e5eff1f140b64ee6727fad9e8e500fc77e (diff)
downloadports-a53eac738414f4be5543b6d3888c66016aa9c5c8.tar.gz
ports-a53eac738414f4be5543b6d3888c66016aa9c5c8.zip
Unbreak clang/gcc46 build
PR: ports/163368 Submitted by: Jan Beich <jbeich@tormail.net> Approved by: maintainer timeout (kaeru@inigo-tech.com, >28d)
Notes
Notes: svn path=/head/; revision=289689
Diffstat (limited to 'audio/id3lib')
-rw-r--r--audio/id3lib/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/audio/id3lib/Makefile b/audio/id3lib/Makefile
index a2d5c2daefcc..76ed0fa7e102 100644
--- a/audio/id3lib/Makefile
+++ b/audio/id3lib/Makefile
@@ -25,4 +25,12 @@ LDFLAGS+= -L${LOCALBASE}/lib
post-extract:
@${RM} -rf ${WRKSRC}/zlib
+post-patch:
+ @${REINPLACE_CMD} '/main/s/unsigned int/int/' \
+ ${WRKSRC}/examples/demo_*.cpp
+ @${REINPLACE_CMD} 's/\(iomanip\)\.h/\1/' ${WRKSRC}/configure
+ @${REINPLACE_CMD} '/include.*/{ p; s//include <cstring>/; n;n;n; }' \
+ ${WRKSRC}/include/id3/id3lib_strings.h \
+ ${WRKSRC}/include/id3/writers.h
+
.include <bsd.port.mk>