aboutsummaryrefslogtreecommitdiff
path: root/audio/id3lib
diff options
context:
space:
mode:
authorBrian Feldman <green@FreeBSD.org>2004-02-22 22:51:59 +0000
committerBrian Feldman <green@FreeBSD.org>2004-02-22 22:51:59 +0000
commitb7a539b61995f3af19af84a97d080d210fc2db0d (patch)
treedfd2a3063d5d71fcbd4ee81a6c90be065b1246dc /audio/id3lib
parent6910c38c65e7cbce496cb16c1de44f03bd62ef24 (diff)
downloadports-b7a539b61995f3af19af84a97d080d210fc2db0d.tar.gz
ports-b7a539b61995f3af19af84a97d080d210fc2db0d.zip
Correct a C syntax error in the <id3/globals.h> header that causes, e.g.,
xmms-imms to fail to build. Mail to ${MAINTAINER} bounces.
Notes
Notes: svn path=/head/; revision=101759
Diffstat (limited to 'audio/id3lib')
-rw-r--r--audio/id3lib/Makefile1
-rw-r--r--audio/id3lib/files/patch-globals.h11
2 files changed, 12 insertions, 0 deletions
diff --git a/audio/id3lib/Makefile b/audio/id3lib/Makefile
index e4cdacbbe733..8ea5f1fb6d5b 100644
--- a/audio/id3lib/Makefile
+++ b/audio/id3lib/Makefile
@@ -10,6 +10,7 @@ PORTVERSION= 3.8.3
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
+PORTREVISION= 1
MAINTAINER= roman@xpert.com
COMMENT= Library for manipulating ID3v1/v1.1 and ID3v2 tags
diff --git a/audio/id3lib/files/patch-globals.h b/audio/id3lib/files/patch-globals.h
new file mode 100644
index 000000000000..b3c07d59f5c1
--- /dev/null
+++ b/audio/id3lib/files/patch-globals.h
@@ -0,0 +1,11 @@
+--- include/id3/globals.h.orig Sun Feb 22 17:38:28 2004
++++ include/id3/globals.h Sun Feb 22 17:38:22 2004
+@@ -480,7 +480,7 @@
+ MP3FREQUENCIES_24000HZ = 24000,
+ MP3FREQUENCIES_32000HZ = 32000,
+ MP3FREQUENCIES_48000HZ = 48000,
+- MP3FREQUENCIES_44100HZ = 44100,
++ MP3FREQUENCIES_44100HZ = 44100
+ };
+
+ ID3_ENUM(Mp3_ChannelMode)