aboutsummaryrefslogtreecommitdiff
path: root/audio/id3lib
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2006-12-20 13:45:00 +0000
committerVasil Dimov <vd@FreeBSD.org>2006-12-20 13:45:00 +0000
commitc90b84d8e1d60909ddbbd6af839f5990a3138169 (patch)
tree1c239e1bf418dc55cd7d088e62be8d4b61489deb /audio/id3lib
parent59a026b0f19ca2d3ca690f04c2c418a6c923dc4a (diff)
downloadports-c90b84d8e1d60909ddbbd6af839f5990a3138169.tar.gz
ports-c90b84d8e1d60909ddbbd6af839f5990a3138169.zip
* Remove code which is only entered when
${OSVERSION} >= 500000 && ${OSVERSION} < 501103 because this OSVERSION is not supported anymore and the code in question includes references to the deprecated port devel/stlport-icc * Switch to USE_LDCONFIG Approved by: maintainer (implicit)
Notes
Notes: svn path=/head/; revision=180274
Diffstat (limited to 'audio/id3lib')
-rw-r--r--audio/id3lib/Makefile26
1 files changed, 2 insertions, 24 deletions
diff --git a/audio/id3lib/Makefile b/audio/id3lib/Makefile
index c2450726e148..ecc566e56e53 100644
--- a/audio/id3lib/Makefile
+++ b/audio/id3lib/Makefile
@@ -18,34 +18,12 @@ COMMENT= Library for manipulating ID3v1/v1.1 and ID3v2 tags
USE_ICONV= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
-CC_BASENAME= ${CC:T}
-# Should run ${CC} -v and check the output instead
-.if ${CC_BASENAME} == cc || ${CC_BASENAME} == gcc
-COMPILER?= gcc
-STLPORT_PORT?= devel/stlport
-.elif ${CC_BASENAME} == icc
-COMPILER?= icc
-STLPORT_PORT?= devel/stlport-icc
-.else
-STLPORT_PORT?= # empty
-.endif
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500000 && ${OSVERSION} < 501103 && !empty(STLPORT_PORT)
-RUN_DEPENDS= ${LOCALBASE}/lib/libstlport_${COMPILER}.so:${PORTSDIR}/${STLPORT_PORT}
-BUILD_DEPENDS:= ${RUN_DEPENDS}
-
-LDFLAGS+= -lstlport_${COMPILER}
-CPPFLAGS+= -I${LOCALBASE}/include/stlport
-.endif
-
post-extract:
@${RM} -rf ${WRKSRC}/zlib
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>