aboutsummaryrefslogtreecommitdiff
path: root/audio/ifp-line
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-10-13 23:47:49 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-10-13 23:47:49 +0000
commitc204644ec469e6b6264c0a607bfdd5b67f43071d (patch)
treefcfa147812e35fdbd93050ae61ccb7975aed645b /audio/ifp-line
parentfbcc2f642af5075f3735202b7fd21c1352167054 (diff)
downloadports-c204644ec469e6b6264c0a607bfdd5b67f43071d.tar.gz
ports-c204644ec469e6b6264c0a607bfdd5b67f43071d.zip
[New port] audio/ifp-line (interface to iRiver music players)
This port provides a simple but easy to use, and via scriptability powerful interface to control iRiver's great 'ifp' series portable music players. If there is a 'manager firmware' installed on this device, it's not possible to gain access via umass(4). This port uses libusb to connect directly via ugen. PR: ports/71987 Submitted by: Thomas E. Zander <riggs@rrr.de>
Notes
Notes: svn path=/head/; revision=119339
Diffstat (limited to 'audio/ifp-line')
-rw-r--r--audio/ifp-line/Makefile27
-rw-r--r--audio/ifp-line/distinfo2
-rw-r--r--audio/ifp-line/files/patch-Makefile31
-rw-r--r--audio/ifp-line/pkg-descr9
-rw-r--r--audio/ifp-line/pkg-message8
5 files changed, 77 insertions, 0 deletions
diff --git a/audio/ifp-line/Makefile b/audio/ifp-line/Makefile
new file mode 100644
index 000000000000..6744beed7454
--- /dev/null
+++ b/audio/ifp-line/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# New ports collection makefile for: ifp-line
+# Date created: Sep 21, 2004
+# Whom: riggs
+#
+# $FreeBSD$
+#
+
+PORTNAME= ifp-line
+PORTVERSION= 0.2.4.4
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ifp-driver
+
+MAINTAINER= riggs@rrr.de
+COMMENT= Command line interface to iRiver music players
+
+LIB_DEPENDS= usb-0.1.7:${PORTSDIR}/devel/libusb
+
+MAN1= ifp.1
+
+PLIST_FILES+= bin/ifp
+
+post-install:
+ @${CAT} ${.CURDIR}/pkg-message
+
+.include <bsd.port.mk>
diff --git a/audio/ifp-line/distinfo b/audio/ifp-line/distinfo
new file mode 100644
index 000000000000..234b03ede0a0
--- /dev/null
+++ b/audio/ifp-line/distinfo
@@ -0,0 +1,2 @@
+MD5 (ifp-line-0.2.4.4.tar.gz) = 188b41668cc74cea0f1b848c39637776
+SIZE (ifp-line-0.2.4.4.tar.gz) = 23879
diff --git a/audio/ifp-line/files/patch-Makefile b/audio/ifp-line/files/patch-Makefile
new file mode 100644
index 000000000000..81d9663330d2
--- /dev/null
+++ b/audio/ifp-line/files/patch-Makefile
@@ -0,0 +1,31 @@
+--- Makefile.orig Sun May 30 17:05:29 2004
++++ Makefile Tue Sep 21 10:48:59 2004
+@@ -1,10 +1,5 @@
+-# $Id: Makefile,v 1.8 2004/05/30 15:05:29 yamajun Exp $
+-
+-CFLAGS = `libusb-config --cflags` -Wall -g
+-LDFLAGS = `libusb-config --libs`
+-PREFIX ?= /usr/local
+-MANDIR ?= ${PREFIX}/man/man1
+-INSTALL ?= /usr/bin/install
++CFLAGS+= `libusb-config --cflags`
++LDFLAGS+= `libusb-config --libs`
+
+ OBJS = ifp.o ifp_routines.o unicodehack.o
+
+@@ -12,12 +7,9 @@
+ ifp: $(OBJS)
+ $(CC) -o ifp $(OBJS) $(LDFLAGS)
+
+-$(MANDIR):
+- mkdir -p $(MANDIR)
+-
+-install: ifp $(MANDIR)
+- $(INSTALL) -c ifp $(PREFIX)/bin
+- $(INSTALL) -c -m 644 ifp.1 $(MANDIR)
++install: ifp
++ @${BSD_INSTALL_PROGRAM} ifp $(PREFIX)/bin
++ @${BSD_INSTALL_MAN} ifp.1 $(PREFIX)/man/man1
+
+ ifp.o: ifp_routines.h
+ ifp_routines.o: ifp_routines.h unicodehack.h
diff --git a/audio/ifp-line/pkg-descr b/audio/ifp-line/pkg-descr
new file mode 100644
index 000000000000..91c663af0bb3
--- /dev/null
+++ b/audio/ifp-line/pkg-descr
@@ -0,0 +1,9 @@
+ifp-line is a simple command-line tool to provide basic
+functionality to manage files on iRiver music players
+which are using the "manager firmware".
+Using this tool, you can
+o add/remove files on the player
+o view information about the player, e.g. battery status
+o flash your firmware using an .hex file
+
+WWW: http://ifp-driver.sourceforge.net/
diff --git a/audio/ifp-line/pkg-message b/audio/ifp-line/pkg-message
new file mode 100644
index 000000000000..1b2dfa5bb326
--- /dev/null
+++ b/audio/ifp-line/pkg-message
@@ -0,0 +1,8 @@
+NOTE:
+ifp directly accesses the usb/ugen devices via libusb. So
+if you want to use this application as a non-root user, you
+have to make sure that the corresponding device nodes
+/dev/usb<somenumber> and /dev/ugen<somenumber> where
+<somenumber> is dependent on your personal usb environment
+are readable and writable by the user intended to use the
+tool.