aboutsummaryrefslogtreecommitdiff
path: root/audio/jack
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-03-28 12:19:44 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-03-28 12:19:44 +0000
commit8f0c8ba97b45f7b350acb6820f9d5fd643ae01be (patch)
tree44cc6da87968c66acd28aa49c553be6e1e4c8257 /audio/jack
parentab3c7c49fa3d5fe2be58f3b916aed37ace040869 (diff)
downloadports-8f0c8ba97b45f7b350acb6820f9d5fd643ae01be.tar.gz
ports-8f0c8ba97b45f7b350acb6820f9d5fd643ae01be.zip
Notes
Diffstat (limited to 'audio/jack')
-rw-r--r--audio/jack/Makefile54
-rw-r--r--audio/jack/pkg-descr19
2 files changed, 34 insertions, 39 deletions
diff --git a/audio/jack/Makefile b/audio/jack/Makefile
index be9e42a84d6b..1c6b110821ef 100644
--- a/audio/jack/Makefile
+++ b/audio/jack/Makefile
@@ -1,9 +1,5 @@
-# New ports collection Makefile for: jackit
-# Date created: 14 May 2002
-# Whom: arved
-#
+# Created by: Tilman Linneweh <arved@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= jackit
PORTVERSION= 0.121.3
@@ -13,56 +9,56 @@ MASTER_SITES= http://jackaudio.org/downloads/
DISTNAME= jack-audio-connection-kit-${PORTVERSION}
MAINTAINER= multimedia@FreeBSD.org
-COMMENT= A low-latency audio server
+COMMENT= Low latency audio server
-LIB_DEPENDS= portaudio.0:${PORTSDIR}/audio/portaudio \
- sndfile.1:${PORTSDIR}/audio/libsndfile \
- samplerate.1:${PORTSDIR}/audio/libsamplerate \
- celt0.2:${PORTSDIR}/audio/celt
+LIB_DEPENDS= portaudio:${PORTSDIR}/audio/portaudio \
+ sndfile:${PORTSDIR}/audio/libsndfile \
+ samplerate:${PORTSDIR}/audio/libsamplerate \
+ celt0:${PORTSDIR}/audio/celt
-LATEST_LINK= jack
-LIBS+= ${PTHREAD_LIBS}
-LDFLAGS+= -L${LOCALBASE}/lib
-CPPFLAGS+= -I${LOCALBASE}/include
-CFLAGS+= ${PTHREAD_CFLAGS}
-CONFIGURE_ENV= LIBS="${LIBS}"
-CONFIGURE_ARGS+=--enable-portaudio \
- --with-default-tmpdir=/tmp
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
-USE_GNOME= pkgconfig gnomehack
+USES= pathfix
+
+CONFIGURE_ENV= LIBS="-pthread"
+CONFIGURE_ARGS= --enable-portaudio \
+ --with-default-tmpdir=/tmp
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+LATEST_LINK= jack
MAN1= jackd.1 jackstart.1
-OPTIONS_DEFINE= ALSA DOCS
+OPTIONS_DEFINE= ALSA DOXYGEN
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MDOCS}
-BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
+.if ${PORT_OPTIONS:MDOXYGEN}
+BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
PLIST_SUB+= DOCS=""
.else
CONFIGURE_ENV+= ac_cv_prog_HAVE_DOXYGEN="false"
PLIST_SUB+= DOCS="@comment "
.endif
-.if exists(${LOCALBASE}/lib/libreadline.so.6)
-LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
+.if exists(${LOCALBASE}/lib/libreadline.so)
+LIB_DEPENDS+= readline:${PORTSDIR}/devel/readline
.endif
.if ${PORT_OPTIONS:MALSA}
-LIB_DEPENDS+= asound.2:${PORTSDIR}/audio/alsa-lib
+LIB_DEPENDS+= asound:${PORTSDIR}/audio/alsa-lib
PLIST_SUB+= ALSA=""
.else
-CONFIGURE_ARGS+=--disable-alsa
+CONFIGURE_ARGS+= --disable-alsa
PLIST_SUB+= ALSA="@comment "
.endif
post-patch:
@${REINPLACE_CMD} -e 's|define USE_MLOCK|undef USE_MLOCK|' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS}," \
+ @${REINPLACE_CMD} -e "s,-lpthread,-pthread," \
${WRKSRC}/configure ${WRKSRC}/libjack/Makefile.in \
${WRKSRC}/jackd/Makefile.in \
${WRKSRC}/example-clients/Makefile.in ${WRKSRC}/jack.pc.in
@@ -78,4 +74,4 @@ post-patch:
post-build:
@${RM} -f ${WRKSRC}/doc/reference/html/dir__2F*
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/jack/pkg-descr b/audio/jack/pkg-descr
index 5c1c621a03c7..46accbd57d2f 100644
--- a/audio/jack/pkg-descr
+++ b/audio/jack/pkg-descr
@@ -1,12 +1,11 @@
-JACK is a low-latency audio server, written for POSIX conformant
-operating systems. It can connect a number of different applications
-to an audio device, as well as allowing them to share audio between
-themselves. Its clients can run in their own processes (ie. as normal
-applications), or can they can run within the JACK server (ie. as a
-"plugin").
+JACK is a low latency audio server, written for POSIX-conformant operating
+systems. It can connect a number of different applications to an audio
+device, as well as allowing them to share audio between themselves. Its
+clients can run in their own processes (i.e. as normal applications), or
+can they can run within the JACK server (i.e. as a "plugin").
-JACK was designed from the ground up for professional audio work, and
-its design focuses on two key areas: synchronous execution of all
-clients, and low latency operation.
+JACK was designed from the ground up for professional audio work, and its
+design focuses on two key areas: synchronous execution of all clients, and
+low latency operation.
-WWW: http://jackaudio.org/
+WWW: http://jackaudio.org/