aboutsummaryrefslogtreecommitdiff
path: root/audio/jamulus
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-03-30 19:03:32 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-03-30 19:03:32 +0000
commitaa09f5cc2eeb0dcbe011ae8af721e700b6f73d8b (patch)
treeaf0670eee74619414a01a4ce426c583cee88dcbf /audio/jamulus
parentd02c485634369560baccf299cee336abfa146ef3 (diff)
downloadports-aa09f5cc2eeb0dcbe011ae8af721e700b6f73d8b.tar.gz
ports-aa09f5cc2eeb0dcbe011ae8af721e700b6f73d8b.zip
New port: audio/jamulus: Internet jam session software
Notes
Notes: svn path=/head/; revision=529903
Diffstat (limited to 'audio/jamulus')
-rw-r--r--audio/jamulus/Makefile34
-rw-r--r--audio/jamulus/distinfo3
-rw-r--r--audio/jamulus/pkg-descr6
3 files changed, 43 insertions, 0 deletions
diff --git a/audio/jamulus/Makefile b/audio/jamulus/Makefile
new file mode 100644
index 000000000000..557287b01ccc
--- /dev/null
+++ b/audio/jamulus/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= jamulus
+DISTVERSION= 3.4.4
+CATEGORIES= audio
+MASTER_SITES= SF/llcon/${NAME}/${DISTVERSION}/
+DISTNAME= ${NAME}-${PORTVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Internet jam session software
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libjack.so:audio/jack
+
+USES= qmake qt:5
+USE_QT= core gui network widgets xml buildtools_build
+
+NAME= Jamulus
+
+WRKSRC= ${WRKDIR}/${NAME}${PORTVERSION}
+
+DESKTOP_ENTRIES= "${NAME}" "${COMMENT}" "${NAME}" \
+ "${PORTNAME}" "AudioVideo;Audio;Mixer;Qt;" true
+
+PLIST_FILES= bin/${NAME} \
+ share/pixmaps/jamulus.png
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${NAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/src/res/fronticon.png ${STAGEDIR}${PREFIX}/share/pixmaps/jamulus.png
+
+.include <bsd.port.mk>
diff --git a/audio/jamulus/distinfo b/audio/jamulus/distinfo
new file mode 100644
index 000000000000..feca98ff635e
--- /dev/null
+++ b/audio/jamulus/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1585542387
+SHA256 (Jamulus-3.4.4.tar.gz) = 886611f452d64e6a0245ef2f8ae2911a746b78bbdaad9b296116e627974e6c97
+SIZE (Jamulus-3.4.4.tar.gz) = 1509046
diff --git a/audio/jamulus/pkg-descr b/audio/jamulus/pkg-descr
new file mode 100644
index 000000000000..8a3da2951355
--- /dev/null
+++ b/audio/jamulus/pkg-descr
@@ -0,0 +1,6 @@
+The Jamulus software enables musicians to perform real-time jam sessions over
+the Internet. There is one server running the Jamulus server software which
+collects the audio data from each Jamulus client, mixes the audio data and sends
+the mix back to each client.
+
+WWW: http://llcon.sourceforge.net/