aboutsummaryrefslogtreecommitdiff
path: root/audio/ladspa
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2006-12-14 19:36:31 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2006-12-14 19:36:31 +0000
commit3a8252941a7b1a511453092e2a78f93c3f6d86aa (patch)
tree27d52b91c5ef29fa151e27b44e25ea95a3a60771 /audio/ladspa
parentfa2720effd5e8aa73a4f4038a2279b37aa9a26d7 (diff)
downloadports-3a8252941a7b1a511453092e2a78f93c3f6d86aa.tar.gz
ports-3a8252941a7b1a511453092e2a78f93c3f6d86aa.zip
Notes
Diffstat (limited to 'audio/ladspa')
-rw-r--r--audio/ladspa/Makefile5
-rw-r--r--audio/ladspa/files/patch-src-plugins-sine.cpp18
2 files changed, 21 insertions, 2 deletions
diff --git a/audio/ladspa/Makefile b/audio/ladspa/Makefile
index 5d223f0c1965..8262945b4683 100644
--- a/audio/ladspa/Makefile
+++ b/audio/ladspa/Makefile
@@ -17,13 +17,14 @@ COMMENT= Linux Audio Developer's Simple Plugin API
WRKSRC= ${WRKDIR}/ladspa_sdk
USE_GMAKE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
PROGRAM_FILES= analyseplugin applyplugin listplugins
PLUGIN_FILES= amp.so delay.so filter.so noise.so sine.so
PLUGIN_DIR?= ${PREFIX}/lib/ladspa/
post-patch:
- ${REINPLACE_CMD} -e 's,-ldl,,; s,-O3,${CFLAGS},' ${WRKSRC}/src/makefile
+ ${REINPLACE_CMD} -e 's,-ldl,,; s,-O3,${CFLAGS},; s,CPP,CXX,' \
+ ${WRKSRC}/src/makefile
do-build:
cd ${WRKSRC}/src; ${SETENV} ${MAKE_ENV} ${GMAKE} -f makefile targets
diff --git a/audio/ladspa/files/patch-src-plugins-sine.cpp b/audio/ladspa/files/patch-src-plugins-sine.cpp
new file mode 100644
index 000000000000..d313a99ef0dd
--- /dev/null
+++ b/audio/ladspa/files/patch-src-plugins-sine.cpp
@@ -0,0 +1,18 @@
+--- ladspa_sdk/src/plugins/sine.cpp.orig 2002-07-06 17:23:17.000000000
+0000
++++ src/plugins/sine.cpp 2005-11-25 11:15:11.691087784 +0000
+@@ -59,6 +59,15 @@
+
+ /*****************************************************************************/
+
++LADSPA_Handle instantiateSineOscillator(const LADSPA_Descriptor *, unsigned long SampleRate);
++void connectPortToSineOscillator(LADSPA_Handle Instance, unsigned long Port, LADSPA_Data * DataLocation);
++void activateSineOscillator(void * pvHandle);
++void runSineOscillator_FreqAudio_AmpAudio(LADSPA_Handle Instance, unsigned long SampleCount);
++void runSineOscillator_FreqAudio_AmpCtrl(LADSPA_Handle Instance, unsigned long SampleCount);
++void runSineOscillator_FreqCtrl_AmpAudio(LADSPA_Handle Instance, unsigned long SampleCount);
++void runSineOscillator_FreqCtrl_AmpCtrl(LADSPA_Handle Instance, unsigned long SampleCount);
++void cleanupSineOscillator(void *pvHandle);
++
+ class SineOscillator {
+ private: