aboutsummaryrefslogtreecommitdiff
path: root/audio/ladspa
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-30 16:47:22 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-30 16:47:22 +0000
commit97f54f04dc434ae6665ac329cb59ea170c926986 (patch)
tree6dce9a223a89549eb0f211d00141f43c18693965 /audio/ladspa
parentd2dda23309920854785d061730b37e458a515e4c (diff)
downloadports-97f54f04dc434ae6665ac329cb59ea170c926986.tar.gz
ports-97f54f04dc434ae6665ac329cb59ea170c926986.zip
Notes
Diffstat (limited to 'audio/ladspa')
-rw-r--r--audio/ladspa/Makefile35
-rw-r--r--audio/ladspa/distinfo1
-rw-r--r--audio/ladspa/files/patch-applyplugin.c11
-rw-r--r--audio/ladspa/files/patch-makefile67
-rw-r--r--audio/ladspa/pkg-comment1
-rw-r--r--audio/ladspa/pkg-descr14
-rw-r--r--audio/ladspa/pkg-plist10
7 files changed, 139 insertions, 0 deletions
diff --git a/audio/ladspa/Makefile b/audio/ladspa/Makefile
new file mode 100644
index 000000000000..3e6f900a80b8
--- /dev/null
+++ b/audio/ladspa/Makefile
@@ -0,0 +1,35 @@
+# New ports collection Makefile for: ladspa
+# Date created: 11 May 2002
+# Whom: Tilman Linneweh <freebsdports@arved.de
+#
+# $FreeBSD$
+
+PORTNAME= ladspa
+PORTVERSION= 0
+CATEGORIES= audio
+MASTER_SITES= http://www.ladspa.org/download/
+DISTNAME= ladspa_sdk
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= freebsdports@arved.de
+
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+MAKEFILE= makefile
+ALL_TARGET= targets
+
+PROGRAM_FILES= analyseplugin applyplugin listplugins
+PLUGIN_FILES= amp.so delay.so filter.so noise.so sine.so
+PLUGIN_DIR= ${PREFIX}/lib/ladspa/
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/ladspa.h ${PREFIX}/include
+.for file in ${PROGRAM_FILES}
+ @${INSTALL_PROGRAM} ${WRKSRC}/../bin/${file} ${PREFIX}/bin
+.endfor
+ @${MKDIR} ${PLUGIN_DIR}
+.for file in ${PLUGIN_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/../plugins/${file} ${PLUGIN_DIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/audio/ladspa/distinfo b/audio/ladspa/distinfo
new file mode 100644
index 000000000000..21fd618bcfee
--- /dev/null
+++ b/audio/ladspa/distinfo
@@ -0,0 +1 @@
+MD5 (ladspa_sdk.tgz) = 00b34b8f9a80a1fe141b643e64ac1681
diff --git a/audio/ladspa/files/patch-applyplugin.c b/audio/ladspa/files/patch-applyplugin.c
new file mode 100644
index 000000000000..8829dd2d5c04
--- /dev/null
+++ b/audio/ladspa/files/patch-applyplugin.c
@@ -0,0 +1,11 @@
+--- applyplugin.c.orig Sat May 11 23:31:00 2002
++++ applyplugin.c Sat May 11 23:31:09 2002
+@@ -6,7 +6,7 @@
+ /*****************************************************************************/
+
+ #include <dlfcn.h>
+-#include <endian.h>
++#include <machine/endian.h>
+ #include <errno.h>
+ #include <math.h>
+ #include <stdlib.h>
diff --git a/audio/ladspa/files/patch-makefile b/audio/ladspa/files/patch-makefile
new file mode 100644
index 000000000000..9133a95d7a58
--- /dev/null
+++ b/audio/ladspa/files/patch-makefile
@@ -0,0 +1,67 @@
+--- makefile.orig Wed Nov 22 21:34:58 2000
++++ makefile Sat May 11 23:29:17 2002
+@@ -5,19 +5,18 @@
+ # Change these if you want to install somewhere else. In particularly
+ # you may wish to remove the middle "local/" part of each entry.
+
+ INSTALL_PLUGINS_DIR = /usr/local/lib/ladspa/
+ INSTALL_INCLUDE_DIR = /usr/include/
+ INSTALL_BINARY_DIR = /usr/local/bin/
+
+ ###############################################################################
+ #
+ # GENERAL
+ #
+
+-INCLUDES = -I.
+-LIBRARIES = -ldl -lm
+-CFLAGS = $(INCLUDES) -Wall -Werror -O3 -fPIC
+-CXXFLAGS = $(CFLAGS)
++CFLAGS += -I.
++CXXFLAGS += -I.
++LDFLAGS += -lm
+ PLUGINS = ../plugins/amp.so \
+ ../plugins/delay.so \
+ ../plugins/filter.so \
+@@ -26,9 +25,6 @@
+ PROGRAMS = ../bin/analyseplugin \
+ ../bin/applyplugin \
+ ../bin/listplugins
+-CC = cc
+-CPP = c++
+-
+ ###############################################################################
+ #
+ # RULES TO BUILD PLUGINS FROM C OR C++ CODE
+@@ -39,8 +35,8 @@
+ $(LD) -o ../plugins/$*.so plugins/$*.o -shared
+
+ ../plugins/%.so: plugins/%.cpp ladspa.h
+- $(CPP) $(CXXFLAGS) -o plugins/$*.o -c plugins/$*.cpp
+- $(CPP) -o ../plugins/$*.so plugins/$*.o -shared
++ $(CXX) $(CXXFLAGS) -o plugins/$*.o -c plugins/$*.cpp
++ $(CXX) -o ../plugins/$*.so plugins/$*.o -shared
+
+ ###############################################################################
+ #
+@@ -90,17 +86,17 @@
+ #
+
+ ../bin/applyplugin: applyplugin.o load.o
+- $(CC) $(CFLAGS) $(LIBRARIES) \
++ $(CC) $(CFLAGS) $(LDFLAGS) \
+ -o ../bin/applyplugin \
+ applyplugin.o load.o
+
+ ../bin/analyseplugin: analyseplugin.o load.o
+- $(CC) $(CFLAGS) $(LIBRARIES) \
++ $(CC) $(CFLAGS) $(LDFLAGS) \
+ -o ../bin/analyseplugin \
+ analyseplugin.o load.o
+
+ ../bin/listplugins: listplugins.o search.o
+- $(CC) $(CFLAGS) $(LIBRARIES) \
++ $(CC) $(CFLAGS) $(LDFLAGS) \
+ -o ../bin/listplugins \
+ listplugins.o search.o
+
diff --git a/audio/ladspa/pkg-comment b/audio/ladspa/pkg-comment
new file mode 100644
index 000000000000..4697eef4ed6c
--- /dev/null
+++ b/audio/ladspa/pkg-comment
@@ -0,0 +1 @@
+Linux Audio Developer's Simple Plugin API
diff --git a/audio/ladspa/pkg-descr b/audio/ladspa/pkg-descr
new file mode 100644
index 000000000000..856f547b89eb
--- /dev/null
+++ b/audio/ladspa/pkg-descr
@@ -0,0 +1,14 @@
+Many audio synthesis and recording packages are in use or in
+development. These work in many different ways. LADSPA
+provides a standard way for `plugin' audio processors to be used with
+a wide range of these packages.
+
+For instance, this allows a developer to make a reverb program and
+bundle it into a LADSPA `plugin library.' Ordinary users can then use
+this reverb within any LADSPA-friendly audio application.
+
+Author: Richard Furse <richard@muse.demon.co.uk.>
+WWW: http://www.ladspa.org
+
+- Tilman Linneweh
+freebsdports@arved.de
diff --git a/audio/ladspa/pkg-plist b/audio/ladspa/pkg-plist
new file mode 100644
index 000000000000..f171abceddfe
--- /dev/null
+++ b/audio/ladspa/pkg-plist
@@ -0,0 +1,10 @@
+bin/analyseplugin
+bin/applyplugin
+bin/listplugins
+include/ladspa.h
+lib/ladspa/amp.so
+lib/ladspa/delay.so
+lib/ladspa/filter.so
+lib/ladspa/noise.so
+lib/ladspa/sine.so
+@dirrm lib/ladspa