aboutsummaryrefslogtreecommitdiff
path: root/audio/last-cmus/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-12-01 21:08:04 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-12-01 21:08:04 +0000
commit6e434b6f359c9aded0b223f39ab736035b7d6104 (patch)
tree85d6a6c5aa30fbb0084da6038a2e0970767b6934 /audio/last-cmus/Makefile
parente7b3e41930ab0d7a4d4196f6b79440c6a79b619a (diff)
This is a last.fm plugin for the CMUS
ncurses based music-player. Written in Python. WWW: http://code.google.com/p/last-cmus/ PR: ports/129299 Submitted by: Dennis Herrmann <adox at mcx2.org>
Notes
Notes: svn path=/head/; revision=223677
Diffstat (limited to 'audio/last-cmus/Makefile')
-rw-r--r--audio/last-cmus/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/audio/last-cmus/Makefile b/audio/last-cmus/Makefile
new file mode 100644
index 000000000000..23c3880fb113
--- /dev/null
+++ b/audio/last-cmus/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: last-cmus
+# Date created: 30 November 2008
+# Whom: Dennis Herrmann <adox@mcx2.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= last
+PORTVERSION= 1.0
+CATEGORIES= audio
+MASTER_SITES= http://last-cmus.googlecode.com/files/ \
+ http://mirror.mcx2.org/
+PKGNAMESUFFIX= -cmus
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}.py
+EXTRACT_SUFX= # none
+
+MAINTAINER= adox@mcx2.org
+COMMENT= Cmus plugin for submitting songs into last.fm
+
+USE_PYTHON= yes
+SUB_FILES= pkg-message
+NO_BUILD= yes
+PLIST_FILES= bin/${DISTNAME}
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${_DISTDIR}/last-cmus.py ${WRKSRC}
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} ${PREFIX}/bin/
+ @${CHMOD} +x ${PREFIX}/bin/${DISTNAME}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>