aboutsummaryrefslogtreecommitdiff
path: root/audio/last.fm
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-09-12 08:48:58 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-09-12 08:48:58 +0000
commitee80b88a36ccbc57d61dbc6d053b0ea12455bcbe (patch)
tree78b5d3e562e977c05fc94423e5da2907bcb20211 /audio/last.fm
parentd3560e2560989ab085f8e8457bed2f19a2e9f674 (diff)
downloadports-ee80b88a36ccbc57d61dbc6d053b0ea12455bcbe.tar.gz
ports-ee80b88a36ccbc57d61dbc6d053b0ea12455bcbe.zip
Notes
Diffstat (limited to 'audio/last.fm')
-rw-r--r--audio/last.fm/Makefile2
-rw-r--r--audio/last.fm/files/patch-src_mp3transcode_mp3transcode.cpp11
2 files changed, 12 insertions, 1 deletions
diff --git a/audio/last.fm/Makefile b/audio/last.fm/Makefile
index ef073a765425..739d8820c2f7 100644
--- a/audio/last.fm/Makefile
+++ b/audio/last.fm/Makefile
@@ -28,7 +28,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
-BROKEN= Does not install
+USE_GCC=4.2+
.endif
post-patch:
diff --git a/audio/last.fm/files/patch-src_mp3transcode_mp3transcode.cpp b/audio/last.fm/files/patch-src_mp3transcode_mp3transcode.cpp
new file mode 100644
index 000000000000..4f9fe9e64aed
--- /dev/null
+++ b/audio/last.fm/files/patch-src_mp3transcode_mp3transcode.cpp
@@ -0,0 +1,11 @@
+--- src/mp3transcode/mp3transcode.cpp.orig 2007-09-27 17:37:07.000000000 +0300
++++ src/mp3transcode/mp3transcode.cpp 2008-09-08 01:43:36.000000000 +0300
+@@ -281,7 +281,7 @@
+ {
+ int length;
+ int cnt;
+- length = qMin( numBytes, ssize_t( getDecodedBufferFilled() ) );
++ length = qMin( numBytes, getDecodedBufferFilled() );
+
+ while (length > 0)
+ {