aboutsummaryrefslogtreecommitdiff
path: root/audio/libadplug
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-05-18 20:21:22 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-05-18 20:21:22 +0000
commit7d16a4e78d809a32da322495f6a1ab6320d9f65b (patch)
treee97f58d826e8907f00504392290a34ce857b5799 /audio/libadplug
parent82df1e2847132413ab7faab37199f71d34951531 (diff)
downloadports-7d16a4e78d809a32da322495f6a1ab6320d9f65b.tar.gz
ports-7d16a4e78d809a32da322495f6a1ab6320d9f65b.zip
Update to 2.0
Notes
Notes: svn path=/head/; revision=162737
Diffstat (limited to 'audio/libadplug')
-rw-r--r--audio/libadplug/Makefile29
-rw-r--r--audio/libadplug/distinfo6
-rw-r--r--audio/libadplug/pkg-descr5
-rw-r--r--audio/libadplug/pkg-plist65
4 files changed, 51 insertions, 54 deletions
diff --git a/audio/libadplug/Makefile b/audio/libadplug/Makefile
index 6dad42334a53..30b6e4266863 100644
--- a/audio/libadplug/Makefile
+++ b/audio/libadplug/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libadplug
-PORTVERSION= 1.5.1
-PORTREVISION= 3
+PORTVERSION= 2.0
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= adplug
@@ -19,8 +18,9 @@ COMMENT= AdLib emulator library supporting many formats
LIB_DEPENDS= binio.1:${PORTSDIR}/devel/libbinio
INSTALLS_SHLIB= yes
-GNU_CONFIGURE= yes
+GNU_CONFIGURE= yes
USE_GCC= 3.4+
+USE_GNOME= pkgconfig
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -30,26 +30,23 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} ${CPPFLAGS}" \
CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
+INFO= libadplug
MAN1= adplugdb.1
post-patch:
- @${REINPLACE_CMD} -e 's|\(binio\.h\)|libbinio/\1|' \
+ @${REINPLACE_CMD} -E 's#<(binfile.h|binio.h|binstr.h)>#<libbinio/\1>#' \
+ ${WRKSRC}/adplugdb/adplugdb.cpp \
+ ${WRKSRC}/src/adplug.cpp \
+ ${WRKSRC}/src/fprovide.cpp \
${WRKSRC}/src/database.cpp \
+ ${WRKSRC}/src/rix.cpp \
+ ${WRKSRC}/src/fprovide.h \
${WRKSRC}/src/database.h \
${WRKSRC}/src/fprovide.cpp \
- ${WRKSRC}/src/fprovide.h
- @${REINPLACE_CMD} -e 's|\(binfile\.h\)|libbinio/\1|' \
- ${WRKSRC}/adplugdb/adplugdb.cpp \
- ${WRKSRC}/src/adplug.cpp \
${WRKSRC}/src/database.cpp \
- ${WRKSRC}/src/fprovide.cpp
- @${REINPLACE_CMD} -e 's|\(binstr\.h\)|libbinio/\1|' \
${WRKSRC}/src/dmo.cpp
- @${REINPLACE_CMD} -e 's|^\(SUBDIRS\ =\).*|\1 src adplugdb test|' \
- ${WRKSRC}/Makefile.in
-
-post-install:
- ${MKDIR} ${MANPREFIX}/man/man1
- ${INSTALL_MAN} ${WRKSRC}/doc/adplugdb.1 ${MANPREFIX}/man/man1
+ @${REINPLACE_CMD} -e 's|^\(pkgconfigdir\ =.*\)|\1 $$(prefix)/libdata/pkgconfig|' \
+ ${WRKSRC}/Makefile.in \
+ ${WRKSRC}/Makefile.am
.include <bsd.port.mk>
diff --git a/audio/libadplug/distinfo b/audio/libadplug/distinfo
index db3f625c8926..1ea372fe262b 100644
--- a/audio/libadplug/distinfo
+++ b/audio/libadplug/distinfo
@@ -1,3 +1,3 @@
-MD5 (adplug-1.5.1.tar.gz) = 9c97fbc3a122f059b5c86206ddd9b6e9
-SHA256 (adplug-1.5.1.tar.gz) = 1f64b40c0d73c5a8f1d6fb3c7e727465f737e100c92ad9811409dbe695e4d856
-SIZE (adplug-1.5.1.tar.gz) = 955980
+MD5 (adplug-2.0.tar.gz) = 06869885099dcc79765ffb1ab5d31207
+SHA256 (adplug-2.0.tar.gz) = 8e0f8fef212384532f95f8557eb6482fac7db2faa5fdc232e3a8336ec06f2546
+SIZE (adplug-2.0.tar.gz) = 966816
diff --git a/audio/libadplug/pkg-descr b/audio/libadplug/pkg-descr
index 6d2f3b2c9ea7..61d022e615dc 100644
--- a/audio/libadplug/pkg-descr
+++ b/audio/libadplug/pkg-descr
@@ -4,9 +4,4 @@ sound data, originally created for the AdLib (OPL2) audio board, directly
from its original format on top of an OPL2 emulator or by using the real
hardware. No OPL chip is required for playback.
-AdPlug itself is just the backend to many different audio player frontends,
-which are also being developed here. There are plugins for popular audio
-players, like Winamp and XMMS, as well as stand-alone players for many
-different systems available.
-
WWW: http://adplug.sourceforge.net/
diff --git a/audio/libadplug/pkg-plist b/audio/libadplug/pkg-plist
index 68f61f05daa3..5a3922d748e5 100644
--- a/audio/libadplug/pkg-plist
+++ b/audio/libadplug/pkg-plist
@@ -1,55 +1,60 @@
bin/adplugdb
-include/adplug/a2m.h
-include/adplug/adlibemu.h
include/adplug/adplug.h
-include/adplug/adtrack.h
+include/adplug/emuopl.h
+include/adplug/fmopl.h
+include/adplug/silentopl.h
+include/adplug/opl.h
+include/adplug/diskopl.h
+include/adplug/a2m.h
include/adplug/amd.h
include/adplug/bam.h
-include/adplug/bmf.h
-include/adplug/cff.h
include/adplug/d00.h
-include/adplug/database.h
include/adplug/dfm.h
-include/adplug/diskopl.h
-include/adplug/dmo.h
-include/adplug/dro.h
-include/adplug/dtm.h
-include/adplug/emuopl.h
-include/adplug/flash.h
-include/adplug/fmc.h
-include/adplug/fmopl.h
-include/adplug/fprovide.h
include/adplug/hsc.h
include/adplug/hsp.h
-include/adplug/hybrid.h
-include/adplug/hyp.h
include/adplug/imf.h
-include/adplug/kemuopl.h
include/adplug/ksm.h
include/adplug/lds.h
-include/adplug/mad.h
include/adplug/mid.h
include/adplug/mkj.h
include/adplug/mtk.h
-include/adplug/opl.h
-include/adplug/player.h
-include/adplug/players.h
include/adplug/protrack.h
-include/adplug/psi.h
include/adplug/rad.h
-include/adplug/rat.h
include/adplug/raw.h
-include/adplug/rol.h
include/adplug/s3m.h
include/adplug/sa2.h
-include/adplug/silentopl.h
include/adplug/sng.h
include/adplug/u6m.h
+include/adplug/player.h
+include/adplug/fmc.h
+include/adplug/mad.h
include/adplug/xad.h
+include/adplug/bmf.h
+include/adplug/flash.h
+include/adplug/hyp.h
+include/adplug/psi.h
+include/adplug/rat.h
+include/adplug/hybrid.h
+include/adplug/rol.h
+include/adplug/adtrack.h
+include/adplug/cff.h
+include/adplug/dtm.h
+include/adplug/dmo.h
+include/adplug/fprovide.h
+include/adplug/database.h
+include/adplug/players.h
include/adplug/xsm.h
-lib/libadplug-1.5.1.so
-lib/libadplug-1.5.1.so.0
-lib/libadplug.a
-lib/libadplug.la
+include/adplug/adlibemu.h
+include/adplug/kemuopl.h
+include/adplug/dro.h
+include/adplug/realopl.h
+include/adplug/analopl.h
+include/adplug/temuopl.h
+include/adplug/msc.h
+include/adplug/rix.h
+lib/libadplug-2.0.so.0
+lib/libadplug-2.0.so
lib/libadplug.so
+lib/libadplug.la
+lib/libadplug.a
@dirrm include/adplug