aboutsummaryrefslogtreecommitdiff
path: root/audio/libamrnb
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-07-14 21:33:04 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-07-14 21:33:04 +0000
commit6b0c72f87f5298ff56ef417fb0045e46472a3293 (patch)
tree5ac74f0ac78337d65e6f353b444a58764a9e916c /audio/libamrnb
parentd82231dcb7af4898903041728a0db9d47efc72ef (diff)
downloadports-6b0c72f87f5298ff56ef417fb0045e46472a3293.tar.gz
ports-6b0c72f87f5298ff56ef417fb0045e46472a3293.zip
- Fix Build
- Makefile cleanup PR: 113627 Submitted by: pointyhat via kris/pav Thanks to: Fredrik Lindberg, linimon Reviewed by: sat
Notes
Notes: svn path=/head/; revision=195608
Diffstat (limited to 'audio/libamrnb')
-rw-r--r--audio/libamrnb/Makefile39
-rw-r--r--audio/libamrnb/distinfo3
-rw-r--r--audio/libamrnb/files/patch-Makefile.in24
-rw-r--r--audio/libamrnb/files/patch-configure15
-rw-r--r--audio/libamrnb/files/patch-prepare_sources.sh31
-rw-r--r--audio/libamrnb/files/pkg-message.in17
-rw-r--r--audio/libamrnb/pkg-descr10
7 files changed, 127 insertions, 12 deletions
diff --git a/audio/libamrnb/Makefile b/audio/libamrnb/Makefile
index 539fbae4d5e4..59c3f46ccbf6 100644
--- a/audio/libamrnb/Makefile
+++ b/audio/libamrnb/Makefile
@@ -7,17 +7,21 @@
PORTNAME= libamrnb
PORTVERSION= 6.1.0.4
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= audio
-MASTER_SITES= http://ftp.penguin.cz/pub/users/utx/amr/
+MASTER_SITES= http://ftp.penguin.cz/pub/users/utx/amr/ \
+ http://www.3gpp.org/ftp/Specs/archive/26_series/26.104/:3GPP
DISTNAME= amrnb-${DISTVERSION}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${SRC3GPP}:3GPP
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= tatsuki_makino@hotmail.com
-COMMENT= Adaptive Multi-Rate (AMR) Speech Codec
+COMMENT= 3GPP floating-point Adaptive Multi-Rate (AMR) Speech Codec
-BUILD_DEPENDS= wget:${PORTSDIR}/ftp/wget \
- ${UNZIP_CMD}:${PORTSDIR}/archivers/unzip \
- bash:${PORTSDIR}/shells/bash
+BUILD_DEPENDS= ${UNZIP_CMD}:${PORTSDIR}/archivers/unzip
+
+SRC3GPP= 26104-610.zip
USE_BZIP2= yes
USE_GMAKE= yes
@@ -25,11 +29,26 @@ USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
CONFIGURE_ENV+= LANG=C
USE_LDCONFIG= yes
-RESTRICTED= See Important legal notice of http://www.penguin.cz/~utx/amr.en.html
+RESTRICTED= license prohibits redistribution
+RESTRICTED_FILES= ${SRC3GPP}
+PORTDOCS= AUTHORS COPYING ChangeLog NEWS README TODO readme.txt
+SUB_FILES= pkg-message
+MAKE_ENV= LANG=C
+
+post-extract:
+ @${CP} ${DISTDIR}/${SRC3GPP} ${WRKSRC}
-post-patch:
- @${REINPLACE_CMD} -E \
- -e "s!(/bin/bash)!${LOCALBASE}\\1!" \
- ${WRKSRC}/prepare_sources.sh
+post-install:
+.ifndef(NOPORTDOCS)
+ @${ECHO} -n Install documents:
+ @${MKDIR} ${DOCSDIR}
+. for FILE in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+ @${ECHO} -n " ${FILE}"
+. endfor
+ @${ECHO} .
+ @${ECHO}
+.endif
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/audio/libamrnb/distinfo b/audio/libamrnb/distinfo
index ca21a69766b3..59e48155716b 100644
--- a/audio/libamrnb/distinfo
+++ b/audio/libamrnb/distinfo
@@ -1,3 +1,6 @@
MD5 (amrnb-6.1.0.4.tar.bz2) = f482cdd0584469ba23ff33c6b331acbd
SHA256 (amrnb-6.1.0.4.tar.bz2) = 6f2df7089205cd6127d434e8ec8fac4cccc163d4df5ec4437211c884fbd9fe75
SIZE (amrnb-6.1.0.4.tar.bz2) = 224932
+MD5 (26104-610.zip) = cfd9012bff83afdf5ad069b86d3063b6
+SHA256 (26104-610.zip) = 8dc9453f9b93202247b4800a1d946ae6eaa3b9d0c48237ae8848144feb88399e
+SIZE (26104-610.zip) = 292640
diff --git a/audio/libamrnb/files/patch-Makefile.in b/audio/libamrnb/files/patch-Makefile.in
new file mode 100644
index 000000000000..230e40eee64c
--- /dev/null
+++ b/audio/libamrnb/files/patch-Makefile.in
@@ -0,0 +1,24 @@
+--- Makefile.in.orig Sat May 26 04:34:54 2007
++++ Makefile.in Sun Jul 15 00:48:06 2007
+@@ -250,7 +250,7 @@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+ EXTRA_DIST = amrnb-any-cflags.patch amrnb-intsizes.patch amrnb-strict-aliasing.patch prepare_sources.sh amrnb.spec
+-DISTCLEANFILES = 26104-610.zip 26104-610.doc 26104-610_ANSI_C_source_code.zip
++DISTCLEANFILES = 26104-610.doc 26104-610_ANSI_C_source_code.zip
+ lib_LTLIBRARIES = \
+ libamrnb.la
+
+@@ -922,10 +922,10 @@
+ chmod og-w 26104-610.doc
+
+ 26104-610.zip:
+- $(WGET) -N http://www.3gpp.org/ftp/Specs/archive/26_series/26.104/26104-610.zip
++ test -e 26104-610.zip
+
+ extraclean:
+- rm -f $(distdir)/*.c $(distdir)/*.h $(distdir)/readme.txt $(distdir)/26104-610.zip $(distdir)/26104-610.doc $(distdir)/26104-610_ANSI_C_source_code.zip
++ rm -f $(distdir)/*.c $(distdir)/*.h $(distdir)/readme.txt $(distdir)/26104-610.doc $(distdir)/26104-610_ANSI_C_source_code.zip
+
+ # WARNING: These commands use internal automake command and may fail in future version.
+ extradist-gzip: distdir extraclean
diff --git a/audio/libamrnb/files/patch-configure b/audio/libamrnb/files/patch-configure
new file mode 100644
index 000000000000..4e6b0385f3e1
--- /dev/null
+++ b/audio/libamrnb/files/patch-configure
@@ -0,0 +1,15 @@
+--- configure.orig Fri Jun 22 12:43:20 2007
++++ configure Fri Jun 22 12:43:24 2007
+@@ -20338,12 +20338,6 @@
+ fi
+
+
+-if test x"$WGET" = x -a ! "(" -f "26104-610.zip" -o -f "sp_enc.c" ")" ; then
+- { { echo "$as_me:$LINENO: error: You need wget utility to download sources." >&5
+-echo "$as_me: error: You need wget utility to download sources." >&2;}
+- { (exit 1); exit 1; }; }
+-fi
+-
+ # Checks for libraries.
+ { echo "$as_me:$LINENO: checking for library containing sqrt" >&5
+ echo $ECHO_N "checking for library containing sqrt... $ECHO_C" >&6; }
diff --git a/audio/libamrnb/files/patch-prepare_sources.sh b/audio/libamrnb/files/patch-prepare_sources.sh
new file mode 100644
index 000000000000..cab31005100f
--- /dev/null
+++ b/audio/libamrnb/files/patch-prepare_sources.sh
@@ -0,0 +1,31 @@
+--- prepare_sources.sh.orig Wed Jun 6 23:52:12 2007
++++ prepare_sources.sh Sat Jul 14 23:35:53 2007
+@@ -1,10 +1,10 @@
+-#! /bin/bash
++#! /bin/sh
+
+ set -o errexit
+-trap "rm -rf c-code *.c *.h readme.txt *.new *.def *.all" ERR
++trap "rm -rf c-code *.c *.h readme.txt *.new *.def *.all" 0
+
+ if [ "$0" = prepare_sources.sh ] ; then
+- cd "$(if ! which 2>/dev/null prepare_sources.sh ; then echo . fi )"
++ cd "$(if ! which 2>/dev/null prepare_sources.sh ; then echo . ; fi )"
+ else
+ cd "${0%/*}"
+ fi
+@@ -23,7 +23,7 @@
+ patch <amrnb-strict-aliasing.patch
+ patch <amrnb-any-cflags.patch
+
+-for FILE in interf_{dec,enc}.{c,h} ; do
++for FILE in interf_dec.[ch] interf_enc.[ch] ; do
+ echo "modifying file $FILE"
+ if test $FILE = ${FILE%.h} ; then
+ ENDSTRING="^}"
+@@ -100,3 +100,5 @@
+ rm $FILE.def $FILE.all
+ done
+ done
++
++trap 0
diff --git a/audio/libamrnb/files/pkg-message.in b/audio/libamrnb/files/pkg-message.in
new file mode 100644
index 000000000000..eed7dd4140e8
--- /dev/null
+++ b/audio/libamrnb/files/pkg-message.in
@@ -0,0 +1,17 @@
+
+AMR codecs incorporate several patents, held by Ericsson,
+Universite de Sherbrooke (VoiceAge) and Nokia.
+VoiceAge claims to provide patent portfolio for AMR codecs. Depending on law in
+your country, manufacturers and developers may need to get a license.
+Because it is a shared library, you may need a special contract for each one
+application, which links against this library, directly or indirectly.
+
+* 3GPP policy on licensing and 3G Patent Platform:
+ http://www.3gpp.org/faq/faq_2005_2.htm#A3.1
+* Intellectual property in ETSI standards:
+ http://webapp.etsi.org/IPR/home.asp
+* On 3GPP legal issues:
+ http://www.3gpp.org/legal/legal.htm
+* On VoiceAge licensing:
+ http://www.voiceage.com/licensing.php
+
diff --git a/audio/libamrnb/pkg-descr b/audio/libamrnb/pkg-descr
index d8fc4761c5fb..2c1f90e94548 100644
--- a/audio/libamrnb/pkg-descr
+++ b/audio/libamrnb/pkg-descr
@@ -1,6 +1,12 @@
-Adaptive Multi-Rate Narrow-Band decoder and encoder library.
+3GPP floating-point Adaptive Multi-Rate (AMR) Speech Codec
(3GPP TS 26.104 V 6.1.0)
-
http://www.3gpp.org/ftp/Specs/html-info/26104.htm
+AMR is an audio data compression scheme optimized for speech coding.
+AMR was adopted as the standard speech codec by 3GPP in October 1998
+and is now widely used in GSM.
+
+Note that depending on law in your country, you may need a license for
+distribution, any use, commercial use or even development.
+
WWW: http://www.penguin.cz/~utx/amr