aboutsummaryrefslogtreecommitdiff
path: root/audio/libao/Makefile
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2003-10-08 16:17:10 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2003-10-08 16:17:10 +0000
commit8d7a265eddc3f162a7faaa16d944af4ec3ac5d3b (patch)
tree33534249e332aa97ba2177e9d22de89b7baafd50 /audio/libao/Makefile
parent39b94d499d030b53e09df1d8b8421dc70ca643c5 (diff)
downloadports-8d7a265eddc3f162a7faaa16d944af4ec3ac5d3b.tar.gz
ports-8d7a265eddc3f162a7faaa16d944af4ec3ac5d3b.zip
Notes
Diffstat (limited to 'audio/libao/Makefile')
-rw-r--r--audio/libao/Makefile39
1 files changed, 23 insertions, 16 deletions
diff --git a/audio/libao/Makefile b/audio/libao/Makefile
index 7c83aee53b95..8c47a4f76f89 100644
--- a/audio/libao/Makefile
+++ b/audio/libao/Makefile
@@ -6,20 +6,16 @@
#
PORTNAME= libao
-PORTVERSION= 0.8.3
-PORTREVISION= 1
+PORTVERSION= 0.8.4
CATEGORIES= audio
-MASTER_SITES= http://www.vorbis.com/files/1.0/unix/ \
- ftp://ftp.wiles.org/pub/mirrors/Vorbis/unix/ \
- http://www.casterclub.com/vorbis/unix/ \
- http://www.math.utoledo.edu/~chaese/Vorbis/unix/
+MASTER_SITES= http://www.xiph.org/ao/src/
MAINTAINER= naddy@FreeBSD.org
COMMENT= Portable audio output library
-WANT_GNOME= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
+WANT_GNOME= yes
.if defined(NOPORTDOCS)
MAKE_ENV= DOC=""
@@ -29,6 +25,26 @@ MAKE_ENV= DOC=doc
MAN5= libao.conf.5
+.if defined(WITH_ARTS)
+LIB_DEPENDS= artsc.0:${PORTSDIR}/audio/arts
+PLIST_SUB+= ARTS=""
+.else
+CONFIGURE_ARGS+= --disable-arts
+PLIST_SUB+= ARTS="@comment "
+pre-everything::
+ @${ECHO_MSG} "Define WITH_ARTS to enable the aRts module."
+.endif
+
+.if defined(WITH_NAS)
+LIB_DEPENDS= audio.2:${PORTSDIR}/audio/nas
+PLIST_SUB+= NAS=""
+.else
+CONFIGURE_ARGS+= --disable-nas
+PLIST_SUB+= NAS="@comment "
+pre-everything::
+ @${ECHO_MSG} "Define WITH_NAS to enable the NAS module."
+.endif
+
.include <bsd.port.pre.mk>
.if ${HAVE_GNOME:Mesound}
@@ -40,13 +56,4 @@ CONFIGURE_ARGS+= --disable-esd
PLIST_SUB+= ESOUND="@comment "
.endif
-# XXX This needs a better check.
-.if exists(${LOCALBASE}/bin/artsc-config)
-LIB_DEPENDS= artsc.0:${PORTSDIR}/audio/arts
-PLIST_SUB+= ARTS=""
-.else
-PLIST_SUB+= ARTS="@comment "
-CONFIGURE_ARGS+= --disable-arts
-.endif
-
.include <bsd.port.post.mk>