aboutsummaryrefslogtreecommitdiff
path: root/audio/libaudec
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-01-06 04:51:41 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-01-06 04:51:41 +0000
commit173bb602cd4430c83a300116eab0d98eaa265293 (patch)
treea7ebc5dd6448fb9bc465dc4bcaa758185453033b /audio/libaudec
parent6d388c3a5f792f7f22879897e7ee1f70fb3c5c7b (diff)
downloadports-173bb602cd4430c83a300116eab0d98eaa265293.tar.gz
ports-173bb602cd4430c83a300116eab0d98eaa265293.zip
New port: audio/libaudec: Wrapper library over ffmpeg, sndfile and libsamplerate
Notes
Notes: svn path=/head/; revision=522202
Diffstat (limited to 'audio/libaudec')
-rw-r--r--audio/libaudec/Makefile26
-rw-r--r--audio/libaudec/distinfo3
-rw-r--r--audio/libaudec/files/patch-meson.build11
-rw-r--r--audio/libaudec/pkg-descr5
4 files changed, 45 insertions, 0 deletions
diff --git a/audio/libaudec/Makefile b/audio/libaudec/Makefile
new file mode 100644
index 000000000000..6eeaf9fae060
--- /dev/null
+++ b/audio/libaudec/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= libaudec
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.1
+CATEGORIES= audio devel
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Wrapper library over ffmpeg, sndfile and libsamplerate
+
+LICENSE= AGPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libsamplerate.so:audio/libsamplerate \
+ libsndfile.so:audio/libsndfile
+
+USES= compiler:c11 meson pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= alex-tee
+USE_LDCONFIG= yes
+
+PLIST_FILES= include/audec/audec.h \
+ lib/libaudec.so \
+ libdata/pkgconfig/audec.pc
+
+.include <bsd.port.mk>
diff --git a/audio/libaudec/distinfo b/audio/libaudec/distinfo
new file mode 100644
index 000000000000..2191aedc5d37
--- /dev/null
+++ b/audio/libaudec/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1578285717
+SHA256 (alex-tee-libaudec-v0.1_GH0.tar.gz) = 5a001391ce208a1abaf21064e4069418919e175258a23c3c748fad22ae42fd0a
+SIZE (alex-tee-libaudec-v0.1_GH0.tar.gz) = 75019
diff --git a/audio/libaudec/files/patch-meson.build b/audio/libaudec/files/patch-meson.build
new file mode 100644
index 000000000000..74a6fea4e44d
--- /dev/null
+++ b/audio/libaudec/files/patch-meson.build
@@ -0,0 +1,11 @@
+--- meson.build.orig 2020-01-06 04:43:34 UTC
++++ meson.build
+@@ -160,7 +160,7 @@ config_h_dep = declare_dependency (
+ )
+ audec_deps += config_h_dep
+
+-audec = static_library (
++audec = shared_library (
+ 'audec',
+ sources: srcs,
+ dependencies: [
diff --git a/audio/libaudec/pkg-descr b/audio/libaudec/pkg-descr
new file mode 100644
index 000000000000..ed59a90cde3a
--- /dev/null
+++ b/audio/libaudec/pkg-descr
@@ -0,0 +1,5 @@
+libaudec (lib audio decoder) is a wrapper library over ffmpeg, sndfile and
+libsamplerate for reading and resampling audio files, based on Robin Gareus'
+audio_decoder code (https://github.com/x42/silan/tree/master/audio_decoder).
+
+WWW: https://github.com/alex-tee/libaudec