aboutsummaryrefslogtreecommitdiff
path: root/audio/libaudec
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-05-20 19:07:11 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-05-20 19:07:11 +0000
commitae9f0898b04d177d58a8fc38b0ab6a361a254bd3 (patch)
tree795b925a4c7f2e43630adf88202228f22032ed57 /audio/libaudec
parent466840846475fc0082564730eb09191c11304372 (diff)
downloadports-ae9f0898b04d177d58a8fc38b0ab6a361a254bd3.tar.gz
ports-ae9f0898b04d177d58a8fc38b0ab6a361a254bd3.zip
audio/libaudec: Remove tests from build
This fixes the i386 build. Reported by: fallout (failed on i386)
Notes
Notes: svn path=/head/; revision=536016
Diffstat (limited to 'audio/libaudec')
-rw-r--r--audio/libaudec/Makefile2
-rw-r--r--audio/libaudec/files/patch-meson.build15
2 files changed, 15 insertions, 2 deletions
diff --git a/audio/libaudec/Makefile b/audio/libaudec/Makefile
index f01baa159275..e6834f5bfaa1 100644
--- a/audio/libaudec/Makefile
+++ b/audio/libaudec/Makefile
@@ -19,6 +19,8 @@ USE_GITHUB= yes
GH_ACCOUNT= alex-tee
USE_LDCONFIG= yes
+MESON_ARGS= -Dbuild-tests=false
+
PLIST_FILES= bin/audec \
include/audec/audec.h \
lib/libaudec.so \
diff --git a/audio/libaudec/files/patch-meson.build b/audio/libaudec/files/patch-meson.build
index 74a6fea4e44d..3efa8a6de476 100644
--- a/audio/libaudec/files/patch-meson.build
+++ b/audio/libaudec/files/patch-meson.build
@@ -1,6 +1,6 @@
---- meson.build.orig 2020-01-06 04:43:34 UTC
+--- meson.build.orig 2020-05-16 11:50:13 UTC
+++ meson.build
-@@ -160,7 +160,7 @@ config_h_dep = declare_dependency (
+@@ -177,7 +177,7 @@ config_h_dep = declare_dependency (
)
audec_deps += config_h_dep
@@ -9,3 +9,14 @@
'audec',
sources: srcs,
dependencies: [
+@@ -212,7 +212,9 @@ audec_exe = executable (
+ install: not meson.is_subproject(),
+ )
+
+-subdir('tests')
++if get_variable('build-tests', true)
++ subdir('tests')
++endif
+
+ summary = [
+ '',