aboutsummaryrefslogtreecommitdiff
path: root/audio/libcanberra
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-05-10 21:19:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-05-10 21:19:08 +0000
commit48e62d9a379cd45a15f6ae89d564f81b3c13d16e (patch)
treeb627baa77f19bb1eab2fa4dee08aab1908131cd0 /audio/libcanberra
parentfbdf96410f8e803568c33397323dd9d8d3af995f (diff)
downloadports-48e62d9a379cd45a15f6ae89d564f81b3c13d16e.tar.gz
ports-48e62d9a379cd45a15f6ae89d564f81b3c13d16e.zip
Presenting GNOME 2.30.1 for FreeBSD. The offical release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.30/ . This release brings initial PackageKit support, Upower (replaces power management part of hal), cuse4bsd integration with HAL and cheese, and a faster Evolution. Sadly GNOME 2.30.x will be the last release with FreeBSD 6.X support. This will also be the last of the 2.x releases. The next release will be the highly-anticipated GNOME 3.0 which will bring with it a new UI experience. Currently, there are a few bugs with GNOME 2.30 that may be of note for our users. Be sure to consult the UPGRADING note or the 2.30 upgrade FAQ at http://www.freebsd.org/gnome/docs/faq230.html for specific upgrading instructions, and the up-to-date list of known issues. This release features commits by avl, ahze, bland, marcus, mezz, and myself. The FreeBSD GNOME Team would like to thank Anders F Bjorklund for doing the initual packagekit porting. And the following contributors & testers for there help with this release: Eric L. Chen Vladimir Grebenschikov Sergio de Almeida Lenzi DomiX walder crsd Kevin Oberman Michal Varga Pavel Plesov Bapt kevin and ITetcu for two exp-run PR: ports/143852 ports/145347 ports/144980 ports/145830 ports/145511
Notes
Notes: svn path=/head/; revision=254099
Diffstat (limited to 'audio/libcanberra')
-rw-r--r--audio/libcanberra/Makefile4
-rw-r--r--audio/libcanberra/distinfo6
-rw-r--r--audio/libcanberra/files/patch-src_oss.c14
3 files changed, 12 insertions, 12 deletions
diff --git a/audio/libcanberra/Makefile b/audio/libcanberra/Makefile
index 3d0acb9477bc..d3d7fcb8c28c 100644
--- a/audio/libcanberra/Makefile
+++ b/audio/libcanberra/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= libcanberra
-PORTVERSION= 0.22
-PORTREVISION= 3
+PORTVERSION= 0.23
+PORTREVISION= 1
CATEGORIES= audio devel
MASTER_SITES= http://0pointer.de/lennart/projects/libcanberra/
diff --git a/audio/libcanberra/distinfo b/audio/libcanberra/distinfo
index f771edecc145..55a248f02acd 100644
--- a/audio/libcanberra/distinfo
+++ b/audio/libcanberra/distinfo
@@ -1,3 +1,3 @@
-MD5 (libcanberra-0.22.tar.gz) = e24e2f956fedfbcc58edfa40471b18d8
-SHA256 (libcanberra-0.22.tar.gz) = 6a87737c3d045549a4a9c789cfc565a48185a586aa1a59243dea6421e9978581
-SIZE (libcanberra-0.22.tar.gz) = 459404
+MD5 (libcanberra-0.23.tar.gz) = 83fb2fb7608c77f91904e12a867534fd
+SHA256 (libcanberra-0.23.tar.gz) = a7d0cf282a9fc8d1e41c082b72a2bf4cf86a6d599f0262484bac95bab57a0960
+SIZE (libcanberra-0.23.tar.gz) = 460205
diff --git a/audio/libcanberra/files/patch-src_oss.c b/audio/libcanberra/files/patch-src_oss.c
index d4b910a3c0a8..098792d93125 100644
--- a/audio/libcanberra/files/patch-src_oss.c
+++ b/audio/libcanberra/files/patch-src_oss.c
@@ -1,11 +1,11 @@
---- src/oss.c.orig 2009-08-26 21:58:16.000000000 -0400
-+++ src/oss.c 2009-11-25 20:47:07.000000000 -0500
-@@ -260,7 +260,7 @@ static int open_oss(ca_context *c, struc
- val = AFMT_S16_NE;
- break;
+--- src/oss.c.orig 2010-02-19 18:39:40.000000000 -0500
++++ src/oss.c 2010-03-14 15:04:16.000000000 -0400
+@@ -262,7 +262,7 @@ static int open_oss(ca_context *c, struc
+ val = AFMT_S16_NE;
+ break;
case CA_SAMPLE_S16RE:
-#if __BYTE_ORDER == __LITTLE_ENDIAN
+#if _BYTE_ORDER == _LITTLE_ENDIAN
- val = AFMT_S16_BE;
+ val = AFMT_S16_BE;
#else
- val = AFMT_S16_LE;
+ val = AFMT_S16_LE;