aboutsummaryrefslogtreecommitdiff
path: root/audio/libcoverart
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2012-10-18 12:40:02 +0000
committerJason E. Hale <jhale@FreeBSD.org>2012-10-18 12:40:02 +0000
commit04e708dc7633d08b16b31d88732395e33e5190dd (patch)
tree0390606a257e4104e2f800ff96d34e3ac7eefb0b /audio/libcoverart
parent56d1842d2fb96aabf57ecccc06dd6e30d3e0681e (diff)
downloadports-04e708dc7633d08b16b31d88732395e33e5190dd.tar.gz
ports-04e708dc7633d08b16b31d88732395e33e5190dd.zip
Libcoverart is a client library for accessing the MusicBrainz cover
art archive. WWW: http://coverartarchive.org/ Approved by: makc (mentor) Feature safe: yes
Notes
Notes: svn path=/head/; revision=306067
Diffstat (limited to 'audio/libcoverart')
-rw-r--r--audio/libcoverart/Makefile30
-rw-r--r--audio/libcoverart/distinfo2
-rw-r--r--audio/libcoverart/pkg-descr4
-rw-r--r--audio/libcoverart/pkg-plist15
4 files changed, 51 insertions, 0 deletions
diff --git a/audio/libcoverart/Makefile b/audio/libcoverart/Makefile
new file mode 100644
index 000000000000..ea61ab351e5b
--- /dev/null
+++ b/audio/libcoverart/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= libcoverart
+PORTVERSION= 1.0.0
+CATEGORIES= audio
+MASTER_SITES= https://cloud.github.com/downloads/metabrainz/${PORTNAME}/
+
+MAINTAINER= jhale@FreeBSD.org
+COMMENT= Library for accessing the MusicBrainz cover art archive
+
+LICENSE= LGPL20
+
+LIB_DEPENDS= jansson:${PORTSDIR}/devel/jansson \
+ neon:${PORTSDIR}/www/neon29
+
+USE_CMAKE= yes
+USE_LDCONFIG= yes
+
+MAKE_JOBS_SAFE= yes
+
+# {PROJECT_VERSION} is not a variable nor a typo, just part of the directory name
+WRKSRC= ${WRKDIR}/${PORTNAME}-{PROJECT_VERSION}
+
+post-patch:
+ ${REINPLACE_CMD} -e '/pkgconfig/s|$${LIB_INSTALL_DIR}|libdata|' \
+ ${WRKSRC}/CMakeLists.txt
+ ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
+ ${WRKSRC}/cmake/modules/*.cmake
+
+.include <bsd.port.mk>
diff --git a/audio/libcoverart/distinfo b/audio/libcoverart/distinfo
new file mode 100644
index 000000000000..21bca8632ffd
--- /dev/null
+++ b/audio/libcoverart/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libcoverart-1.0.0.tar.gz) = e4cb78939003a4b5e5c4db68e42e86fbbbea5e69d3166b43ca01a7065916a121
+SIZE (libcoverart-1.0.0.tar.gz) = 57950
diff --git a/audio/libcoverart/pkg-descr b/audio/libcoverart/pkg-descr
new file mode 100644
index 000000000000..1c33d7ec9807
--- /dev/null
+++ b/audio/libcoverart/pkg-descr
@@ -0,0 +1,4 @@
+Libcoverart is a client library for accessing the MusicBrainz cover
+art archive.
+
+WWW: http://coverartarchive.org/
diff --git a/audio/libcoverart/pkg-plist b/audio/libcoverart/pkg-plist
new file mode 100644
index 000000000000..2eabb3604479
--- /dev/null
+++ b/audio/libcoverart/pkg-plist
@@ -0,0 +1,15 @@
+include/coverart/CoverArt.h
+include/coverart/HTTPFetch.h
+include/coverart/Image.h
+include/coverart/ImageList.h
+include/coverart/ReleaseInfo.h
+include/coverart/Thumbnails.h
+include/coverart/Type.h
+include/coverart/TypeList.h
+include/coverart/caa_c.h
+include/coverart/defines.h
+lib/libcoverart.so
+lib/libcoverart.so.0
+lib/libcoverart.so.0.0.1
+libdata/pkgconfig/libcoverart.pc
+@dirrm include/coverart