aboutsummaryrefslogtreecommitdiff
path: root/audio/libebur128
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-05-02 15:45:59 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-05-02 15:45:59 +0000
commit4e74521ff0ee509456093eeb8115ad448555f6eb (patch)
treeca56d5b12129c68710b84184b49ce3d07212b704 /audio/libebur128
parent57e1777e91936a84f4ca0ca0ab62fdc9da78cf30 (diff)
downloadports-4e74521ff0ee509456093eeb8115ad448555f6eb.tar.gz
ports-4e74521ff0ee509456093eeb8115ad448555f6eb.zip
- New port: audio/libebur128
libebur128 is a library that implements the EBU R 128 standard for loudness normalisation. WWW: https://github.com/jiixyj/libebur128
Notes
Notes: svn path=/head/; revision=352819
Diffstat (limited to 'audio/libebur128')
-rw-r--r--audio/libebur128/Makefile25
-rw-r--r--audio/libebur128/distinfo2
-rw-r--r--audio/libebur128/pkg-descr4
-rw-r--r--audio/libebur128/pkg-plist5
4 files changed, 36 insertions, 0 deletions
diff --git a/audio/libebur128/Makefile b/audio/libebur128/Makefile
new file mode 100644
index 000000000000..4f7521217268
--- /dev/null
+++ b/audio/libebur128/Makefile
@@ -0,0 +1,25 @@
+# Created by: gahr
+# $FreeBSD$
+
+PORTNAME= libebur128
+PORTVERSION= 1.0.1
+CATEGORIES= audio
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= Implementation of the EBU R128 loudness standard
+
+LICENSE= MIT
+
+LIB_DEPENDS= libspeexdsp.so:${PORTSDIR}/audio/speex
+
+USES= cmake:outsource pkgconfig
+
+USE_GITHUB= yes
+GH_ACCOUNT= jiixyj
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= 1214547
+
+PLIST_SUB+= VER1=${PORTVERSION:R:R} \
+ VER3=${PORTVERSION}
+
+.include <bsd.port.mk>
diff --git a/audio/libebur128/distinfo b/audio/libebur128/distinfo
new file mode 100644
index 000000000000..5022fac75a15
--- /dev/null
+++ b/audio/libebur128/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libebur128-1.0.1.tar.gz) = ede2e0052afa6b7f57cec808985586891c1d46b7fa1d3e1496d18bc711cbd546
+SIZE (libebur128-1.0.1.tar.gz) = 29770
diff --git a/audio/libebur128/pkg-descr b/audio/libebur128/pkg-descr
new file mode 100644
index 000000000000..5a7a8a8686d0
--- /dev/null
+++ b/audio/libebur128/pkg-descr
@@ -0,0 +1,4 @@
+libebur128 is a library that implements the EBU R 128 standard for loudness
+normalisation.
+
+WWW: https://github.com/jiixyj/libebur128
diff --git a/audio/libebur128/pkg-plist b/audio/libebur128/pkg-plist
new file mode 100644
index 000000000000..20d6dae1b866
--- /dev/null
+++ b/audio/libebur128/pkg-plist
@@ -0,0 +1,5 @@
+include/ebur128.h
+lib/libebur128.a
+lib/libebur128.so
+lib/libebur128.so.%%VER1%%
+lib/libebur128.so.%%VER3%%