aboutsummaryrefslogtreecommitdiff
path: root/audio/libechonest
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2013-03-06 22:53:30 +0000
committerNicola Vitale <nivit@FreeBSD.org>2013-03-06 22:53:30 +0000
commit5f4ec43f7eb81a0bd47b1a470f0d6382da3e7434 (patch)
treebd706c1ac58156351453d8a7862d9c7a13e03cb1 /audio/libechonest
parentc29f6bcc8143c4388ac05843faa3a9421a5445f1 (diff)
downloadports-5f4ec43f7eb81a0bd47b1a470f0d6382da3e7434.tar.gz
ports-5f4ec43f7eb81a0bd47b1a470f0d6382da3e7434.zip
libechonest is a collection of C++/Qt classes designed to make a developer's
life easy when trying to use the APIs provided by The Echo Nest. WWW: http://github.com/dschimdt/libechonest
Notes
Notes: svn path=/head/; revision=313551
Diffstat (limited to 'audio/libechonest')
-rw-r--r--audio/libechonest/Makefile29
-rw-r--r--audio/libechonest/distinfo2
-rw-r--r--audio/libechonest/files/patch-CMakeLists.txt33
-rw-r--r--audio/libechonest/pkg-descr4
-rw-r--r--audio/libechonest/pkg-plist21
5 files changed, 89 insertions, 0 deletions
diff --git a/audio/libechonest/Makefile b/audio/libechonest/Makefile
new file mode 100644
index 000000000000..ec47d4ba8413
--- /dev/null
+++ b/audio/libechonest/Makefile
@@ -0,0 +1,29 @@
+# Created by: Nicola Vitale <nivit@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libechonest
+PORTVERSION= 2.0.1
+#PORTREVISION= 0
+CATEGORIES= audio
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Collection of C++/Qt classes designed to use the APIs of The Echo Nest
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= qjson:${PORTSDIR}/devel/qjson
+
+CMAKE_ARGS= -DCMAKE_COLOR_MAKEFILE:BOOL="OFF"
+
+GH_ACCOUNT= dschmidt
+GH_PROJECT= ${PORTNAME}
+GH_TAGNAME= master
+GH_COMMIT= f9a55d1
+
+USE_CMAKE= yes
+USE_GITHUB= yes
+USE_LDCONFIG= yes
+
+USE_QT4= qmake_build moc_build network qtestlib rcc_build xml
+
+.include <bsd.port.mk>
diff --git a/audio/libechonest/distinfo b/audio/libechonest/distinfo
new file mode 100644
index 000000000000..bde0d8c94e51
--- /dev/null
+++ b/audio/libechonest/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libechonest-2.0.1.tar.gz) = 7d7f76d38d7814f4e234f518a2e9c74ae48817a3c3b0ab3650def4c91d6819cb
+SIZE (libechonest-2.0.1.tar.gz) = 12075130
diff --git a/audio/libechonest/files/patch-CMakeLists.txt b/audio/libechonest/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..cecdd917fe4c
--- /dev/null
+++ b/audio/libechonest/files/patch-CMakeLists.txt
@@ -0,0 +1,33 @@
+--- ./CMakeLists.txt.orig 2012-07-21 19:14:04.000000000 +0200
++++ ./CMakeLists.txt 2013-02-13 00:12:06.000000000 +0100
+@@ -21,7 +21,7 @@
+ set( ECHONEST_LIB_PATCH_VERSION "1" )
+ set( ECHONEST_LIB_VERSION "${ECHONEST_LIB_MAJOR_VERSION}.${ECHONEST_LIB_MINOR_VERSION}.${ECHONEST_LIB_PATCH_VERSION}" )
+
+-set( ECHONEST_LIB_VERSION_SONAME "${ECHONEST_LIB_MAJOR_VERSION}.${ECHONEST_LIB_MINOR_VERSION}")
++set( ECHONEST_LIB_VERSION_SONAME "${ECHONEST_LIB_MAJOR_VERSION}")
+
+ if (CMAKE_COMPILER_IS_GNUCXX)
+ ADD_DEFINITIONS( -Wall -Wundef -Wcast-align -Wchar-subscripts -Wpointer-arith
+@@ -32,9 +32,9 @@
+ endif()
+
+ # disable -Werror on ARM since Qt containers cause a lot of alignment warnings
+- if ( NOT CMAKE_SYSTEM_PROCESSOR MATCHES "arm" )
+- add_definitions( -Werror )
+- endif()
++ #if ( NOT CMAKE_SYSTEM_PROCESSOR MATCHES "arm" )
++ # add_definitions( -Werror )
++ #endif()
+
+ # to be added:
+ # -Wshadow
+@@ -79,7 +79,7 @@
+ ${CMAKE_CURRENT_BINARY_DIR}/libechonest.pc
+ @ONLY)
+ INSTALL (FILES ${CMAKE_CURRENT_BINARY_DIR}/libechonest.pc
+- DESTINATION lib${LIB_SUFFIX}/pkgconfig)
++ DESTINATION libdata/pkgconfig)
+ ENDIF (NOT WIN32)
+
+ include(CPack)
diff --git a/audio/libechonest/pkg-descr b/audio/libechonest/pkg-descr
new file mode 100644
index 000000000000..ad546ae73360
--- /dev/null
+++ b/audio/libechonest/pkg-descr
@@ -0,0 +1,4 @@
+libechonest is a collection of C++/Qt classes designed to make a developer's
+life easy when trying to use the APIs provided by The Echo Nest.
+
+WWW: http://github.com/dschimdt/libechonest
diff --git a/audio/libechonest/pkg-plist b/audio/libechonest/pkg-plist
new file mode 100644
index 000000000000..8898fddc8df9
--- /dev/null
+++ b/audio/libechonest/pkg-plist
@@ -0,0 +1,21 @@
+@comment $FreeBSD$
+include/echonest/Artist.h
+include/echonest/ArtistTypes.h
+include/echonest/AudioSummary.h
+include/echonest/Catalog.h
+include/echonest/CatalogArtist.h
+include/echonest/CatalogItem.h
+include/echonest/CatalogSong.h
+include/echonest/CatalogUpdateEntry.h
+include/echonest/Config.h
+include/echonest/Playlist.h
+include/echonest/Song.h
+include/echonest/Track.h
+include/echonest/TypeInformation.h
+include/echonest/Util.h
+include/echonest/echonest_export.h
+lib/libechonest.so
+lib/libechonest.so.2
+lib/libechonest.so.2.0.1
+libdata/pkgconfig/libechonest.pc
+@dirrm include/echonest