aboutsummaryrefslogtreecommitdiff
path: root/audio/libg722
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2016-07-29 23:28:13 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2016-07-29 23:28:13 +0000
commitab188f9af7586b1cd9bf0cdd9b0b07283068a776 (patch)
tree7ad3411c1319c5473a0e51aa8a4ac087e2f5ebf1 /audio/libg722
parent9b2f0c704c643e1ad85853396e3468ccca2862b4 (diff)
downloadports-ab188f9af7586b1cd9bf0cdd9b0b07283068a776.tar.gz
ports-ab188f9af7586b1cd9bf0cdd9b0b07283068a776.zip
Add libg722, a software G.722 decoding/encoding library that is
bit-compatible with the ITU-T specifications.
Notes
Notes: svn path=/head/; revision=419278
Diffstat (limited to 'audio/libg722')
-rw-r--r--audio/libg722/Makefile29
-rw-r--r--audio/libg722/distinfo3
-rw-r--r--audio/libg722/pkg-descr8
-rw-r--r--audio/libg722/pkg-plist4
4 files changed, 44 insertions, 0 deletions
diff --git a/audio/libg722/Makefile b/audio/libg722/Makefile
new file mode 100644
index 000000000000..99bb6a7576dc
--- /dev/null
+++ b/audio/libg722/Makefile
@@ -0,0 +1,29 @@
+# Created by: sobomax
+# $FreeBSD$
+
+PORTNAME= libg722
+PORTVERSION= 1.0.0
+#PORTREVISION= 1
+CATEGORIES= misc
+
+MAINTAINER= ports@sippysoft.com
+COMMENT= Software G.722 decoding/encoding library
+
+LICENSE= PUBLIC_DOMAIN
+LICENSE_NAME= ${LICENSE:S/_/ /}
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+USE_GITHUB= yes
+GH_ACCOUNT= sippy
+GH_TAGNAME= v_1_0_0
+
+MAKE_ENV= MAKEOBJDIR=${WRKDIR}
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/g722.h ${STAGEDIR}${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/g722_decoder.h ${STAGEDIR}${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/g722_encoder.h ${STAGEDIR}${PREFIX}/include
+ ${INSTALL_DATA} ${WRKDIR}/libg722.a ${STAGEDIR}${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/audio/libg722/distinfo b/audio/libg722/distinfo
new file mode 100644
index 000000000000..5ec15c939633
--- /dev/null
+++ b/audio/libg722/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1469834457
+SHA256 (sippy-libg722-1.0.0-v_1_0_0_GH0.tar.gz) = 4d1a79d72a6cb0562a34041ededa7bc4784258541084c9fda33b33821ef0f894
+SIZE (sippy-libg722-1.0.0-v_1_0_0_GH0.tar.gz) = 109428
diff --git a/audio/libg722/pkg-descr b/audio/libg722/pkg-descr
new file mode 100644
index 000000000000..711e35948a68
--- /dev/null
+++ b/audio/libg722/pkg-descr
@@ -0,0 +1,8 @@
+The G.722 module is a bit exact implementation of the ITU G.722 specification
+for all three specified bit rates - 64000bps, 56000bps and 48000bps. It passes
+the ITU tests.
+
+To allow fast and flexible interworking with narrow band telephony, the encoder
+and decoder support an option for the linear audio to be an 8k samples/second
+stream. In this mode the codec is considerably faster, and still fully
+compatible with wideband terminals using G.722.
diff --git a/audio/libg722/pkg-plist b/audio/libg722/pkg-plist
new file mode 100644
index 000000000000..92cde281641b
--- /dev/null
+++ b/audio/libg722/pkg-plist
@@ -0,0 +1,4 @@
+lib/libg722.a
+include/g722.h
+include/g722_decoder.h
+include/g722_encoder.h