aboutsummaryrefslogtreecommitdiff
path: root/audio/libgme
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-04-12 14:15:14 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-04-12 14:15:14 +0000
commit7012a8c384103c93ea9780cc57dc62b861d450a2 (patch)
tree04cda915a360871bcec2702192a6b43ae474df24 /audio/libgme
parent494ef0d872fe057f3eb494eb5bd71e7d6b299bb0 (diff)
downloadports-7012a8c384103c93ea9780cc57dc62b861d450a2.tar.gz
ports-7012a8c384103c93ea9780cc57dc62b861d450a2.zip
- Update to version 0.6.0 and clean up the Makefile
- Install handful of documentation files (seem useful) PR: 199210
Notes
Notes: svn path=/head/; revision=383870
Diffstat (limited to 'audio/libgme')
-rw-r--r--audio/libgme/Makefile17
-rw-r--r--audio/libgme/distinfo4
-rw-r--r--audio/libgme/pkg-plist17
3 files changed, 18 insertions, 20 deletions
diff --git a/audio/libgme/Makefile b/audio/libgme/Makefile
index 134e76cf4cdd..f869f83aac43 100644
--- a/audio/libgme/Makefile
+++ b/audio/libgme/Makefile
@@ -1,11 +1,11 @@
# $FreeBSD$
PORTNAME= libgme
-PORTVERSION= 0.5.5
+PORTVERSION= 0.6.0
CATEGORIES= audio
MASTER_SITES= GOOGLE_CODE
+PROJECTHOST= game-music-emu
DISTNAME= ${PROJECTHOST}-${PORTVERSION}
-EXTRACT_SUFX= .tbz2
MAINTAINER= ports@FreeBSD.org
COMMENT= Collection of video game music emulators
@@ -13,8 +13,19 @@ COMMENT= Collection of video game music emulators
LICENSE= LGPL21 LGPL3
LICENSE_COMB= dual
-PROJECTHOST= game-music-emu
USES= tar:bzip2 cmake dos2unix ninja
USE_LDCONFIG= yes
+PORTDOCS= changes.txt design.txt gme.txt readme.txt
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e '/pkgconfig/s,lib/,libdata/,' \
+ ${WRKSRC}/gme/CMakeLists.txt
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>
diff --git a/audio/libgme/distinfo b/audio/libgme/distinfo
index 3fdf4aa959b4..d309ba81b395 100644
--- a/audio/libgme/distinfo
+++ b/audio/libgme/distinfo
@@ -1,2 +1,2 @@
-SHA256 (game-music-emu-0.5.5.tbz2) = ecb3586aac9feff2b3141167835f73da0c997efbdd32e559f99477ad01e19089
-SIZE (game-music-emu-0.5.5.tbz2) = 161954
+SHA256 (game-music-emu-0.6.0.tar.bz2) = 506e81d0c61e1a26d503fbf5351503e0b31f9fbb374cb1f09979758b46a24987
+SIZE (game-music-emu-0.6.0.tar.bz2) = 170202
diff --git a/audio/libgme/pkg-plist b/audio/libgme/pkg-plist
index 2cac61a68276..026ab5e7bfaf 100644
--- a/audio/libgme/pkg-plist
+++ b/audio/libgme/pkg-plist
@@ -1,18 +1,5 @@
-include/gme/Blip_Buffer.h
-include/gme/Classic_Emu.h
-include/gme/Data_Reader.h
-include/gme/Dual_Resampler.h
-include/gme/Effects_Buffer.h
-include/gme/Fir_Resampler.h
-include/gme/Gme_File.h
-include/gme/M3u_Playlist.h
-include/gme/Multi_Buffer.h
-include/gme/Music_Emu.h
-include/gme/blargg_common.h
-include/gme/blargg_config.h
-include/gme/blargg_source.h
include/gme/gme.h
-include/gme/gme_types.h
lib/libgme.so
lib/libgme.so.0
-lib/libgme.so.0.5.3
+lib/libgme.so.0.6.0
+libdata/pkgconfig/libgme.pc