aboutsummaryrefslogtreecommitdiff
path: root/audio/libid3tag
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-09-18 08:16:29 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-09-18 08:16:29 +0000
commit9a1afddbdd21ae83001035e20ad6cc2fbdaeb953 (patch)
treea356f4c158e6aae84c498723b0cbfc69f9dfc988 /audio/libid3tag
parentd89a73c73086045a836c000686b9379681bf2845 (diff)
downloadports-9a1afddbdd21ae83001035e20ad6cc2fbdaeb953.tar.gz
ports-9a1afddbdd21ae83001035e20ad6cc2fbdaeb953.zip
Convert to USES=libtool and add INSTALL_TARGET=install-strip
Notes
Notes: svn path=/head/; revision=368428
Diffstat (limited to 'audio/libid3tag')
-rw-r--r--audio/libid3tag/Makefile7
-rw-r--r--audio/libid3tag/files/patch-configure99
-rw-r--r--audio/libid3tag/files/patch-ltmain.sh43
-rw-r--r--audio/libid3tag/pkg-plist1
4 files changed, 4 insertions, 146 deletions
diff --git a/audio/libid3tag/Makefile b/audio/libid3tag/Makefile
index 47e351fbffb9..2f25ab1c0b2d 100644
--- a/audio/libid3tag/Makefile
+++ b/audio/libid3tag/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libid3tag
PORTVERSION= 0.15.1b
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= SF/mad/${PORTNAME}/${PORTVERSION} \
ftp://ftp.mars.org/pub/mpeg/
@@ -14,11 +15,9 @@ LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USES= libtool pkgconfig
USE_LDCONFIG= yes
-USES= pkgconfig
-
-post-patch:
- @${REINPLACE_CMD} -e 's|echo aout|echo elf|g' ${WRKSRC}/configure
post-build:
cd ${WRKSRC} && CONFIG_FILES=id3tag.pc CONFIG_HEADERS= ${SH} ./config.status
diff --git a/audio/libid3tag/files/patch-configure b/audio/libid3tag/files/patch-configure
deleted file mode 100644
index cbdb69b18b4a..000000000000
--- a/audio/libid3tag/files/patch-configure
+++ /dev/null
@@ -1,99 +0,0 @@
---- configure.orig 2013-01-06 09:12:38.564020000 +0100
-+++ configure 2013-01-06 09:21:16.604744000 +0100
-@@ -3485,13 +3485,13 @@
- lt_cv_deplibs_check_method=pass_all
- ;;
-
--freebsd* | kfreebsd*-gnu)
-+freebsd* | kfreebsd*-gnu | DragonFly* )
- if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
- case $host_cpu in
- i*86 )
- # Not sure whether the presence of OpenBSD here was a mistake.
- # Let's accept both of them until this is cleared up.
-- lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD)/i[3-9]86 (compact )?demand paged shared library'
-+ lt_cv_deplibs_check_method='file_magic (FreeBSD|DragonFly|OpenBSD)/i[3-9]86 (compact )?demand paged shared library'
- lt_cv_file_magic_cmd=/usr/bin/file
- lt_cv_file_magic_test_file=`echo /usr/lib/libc.so.*`
- ;;
-@@ -7144,7 +7144,7 @@
- ;;
-
- # FreeBSD 3 and greater uses gcc -shared to do shared libraries.
-- freebsd* | kfreebsd*-gnu)
-+ freebsd* | dragonfly* | kfreebsd*-gnu)
- archive_cmds='$CC -shared -o $lib $libobjs $deplibs $compiler_flags'
- hardcode_libdir_flag_spec='-R$libdir'
- hardcode_direct=yes
-@@ -7722,7 +7722,7 @@
- dynamic_linker='GNU ld.so'
- ;;
-
--freebsd*)
-+freebsd*|dragonfly*)
- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
- version_type=freebsd-$objformat
- case $version_type in
-@@ -10093,7 +10093,7 @@
- freebsd-elf*)
- archive_cmds_need_lc_CXX=no
- ;;
-- freebsd* | kfreebsd*-gnu)
-+ freebsd* | dragonfly* | kfreebsd*-gnu)
- # FreeBSD 3 and later use GNU C++ and GNU ld with standard ELF
- # conventions
- ld_shlibs_CXX=yes
-@@ -10800,7 +10800,7 @@
- ;;
- esac
- ;;
-- freebsd* | kfreebsd*-gnu)
-+ freebsd* | dragonfly* | kfreebsd*-gnu)
- # FreeBSD uses GNU C++
- ;;
- hpux9* | hpux10* | hpux11*)
-@@ -11411,7 +11411,7 @@
- dynamic_linker='GNU ld.so'
- ;;
-
--freebsd*)
-+freebsd*|dragonfly*)
- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
- version_type=freebsd-$objformat
- case $version_type in
-@@ -13973,7 +13973,7 @@
- ;;
-
- # FreeBSD 3 and greater uses gcc -shared to do shared libraries.
-- freebsd* | kfreebsd*-gnu)
-+ freebsd* | dragonfly* | kfreebsd*-gnu)
- archive_cmds_F77='$CC -shared -o $lib $libobjs $deplibs $compiler_flags'
- hardcode_libdir_flag_spec_F77='-R$libdir'
- hardcode_direct_F77=yes
-@@ -14551,7 +14551,7 @@
- dynamic_linker='GNU ld.so'
- ;;
-
--freebsd*)
-+freebsd*|dragonfly*)
- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
- version_type=freebsd-$objformat
- case $version_type in
-@@ -16318,7 +16318,7 @@
- ;;
-
- # FreeBSD 3 and greater uses gcc -shared to do shared libraries.
-- freebsd* | kfreebsd*-gnu)
-+ freebsd* | dragonfly* | kfreebsd*-gnu)
- archive_cmds_GCJ='$CC -shared -o $lib $libobjs $deplibs $compiler_flags'
- hardcode_libdir_flag_spec_GCJ='-R$libdir'
- hardcode_direct_GCJ=yes
-@@ -16896,7 +16896,7 @@
- dynamic_linker='GNU ld.so'
- ;;
-
--freebsd*)
-+freebsd*|dragonfly*)
- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
- version_type=freebsd-$objformat
- case $version_type in
diff --git a/audio/libid3tag/files/patch-ltmain.sh b/audio/libid3tag/files/patch-ltmain.sh
deleted file mode 100644
index 9acb8e593759..000000000000
--- a/audio/libid3tag/files/patch-ltmain.sh
+++ /dev/null
@@ -1,43 +0,0 @@
---- ltmain.sh.orig 2004-02-16 20:52:36.000000000 -0500
-+++ ltmain.sh
-@@ -1335,7 +1335,7 @@ EOF
- # These systems don't actually have a C library (as such)
- test "X$arg" = "X-lc" && continue
- ;;
-- *-*-openbsd* | *-*-freebsd*)
-+ *-*-openbsd* | *-*-freebsd* | *-*-dragonfly* )
- # Do not include libc due to us having libc/libc_r.
- test "X$arg" = "X-lc" && continue
- ;;
-@@ -1346,7 +1346,7 @@ EOF
- esac
- elif test "X$arg" = "X-lc_r"; then
- case $host in
-- *-*-openbsd* | *-*-freebsd*)
-+ *-*-openbsd* | *-*-freebsd* | *-*-dragonfly* )
- # Do not include libc_r directly, use -pthread flag.
- continue
- ;;
-@@ -2980,8 +2980,8 @@ EOF
- ;;
-
- freebsd-elf)
-- major=".$current"
-- versuffix=".$current";
-+ major=.`expr $current - $age`
-+ versuffix="$major";
- ;;
-
- irix | nonstopux)
-@@ -5527,11 +5527,6 @@ relink_command=\"$relink_command\""
- IFS="$save_ifs"
- fi
-
-- # Install the pseudo-library for information purposes.
-- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
-- instname="$dir/$name"i
-- $show "$install_prog $instname $destdir/$name"
-- $run eval "$install_prog $instname $destdir/$name" || exit $?
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/audio/libid3tag/pkg-plist b/audio/libid3tag/pkg-plist
index c69be47c0b31..f87705bdce18 100644
--- a/audio/libid3tag/pkg-plist
+++ b/audio/libid3tag/pkg-plist
@@ -2,4 +2,5 @@ include/id3tag.h
lib/libid3tag.a
lib/libid3tag.so
lib/libid3tag.so.0
+lib/libid3tag.so.0.3.0
libdata/pkgconfig/id3tag.pc