aboutsummaryrefslogtreecommitdiff
path: root/audio/liblo
diff options
context:
space:
mode:
authorDaniel Eischen <deischen@FreeBSD.org>2013-07-12 17:44:49 +0000
committerDaniel Eischen <deischen@FreeBSD.org>2013-07-12 17:44:49 +0000
commit69d3db36a173aff7fba2b435b125a57b03a3b618 (patch)
treee2b64ea6c55e66319032836170c1c8bd708a0a97 /audio/liblo
parent825362d4cdd5a3ab5bbee0b0d33d8797fe12bd34 (diff)
downloadports-69d3db36a173aff7fba2b435b125a57b03a3b618.tar.gz
ports-69d3db36a173aff7fba2b435b125a57b03a3b618.zip
From the (new) maintainer:
- Update to 0.27 - Take maintainership - Shorten header - Add license (LGPL21) - Add dependency for devel/doxygen - Add manual pages - Add docs - Add examples - Add DOCS DOXYGEN EXAMPLES Options - Trim files/patch-src-lo_types_internal.h - Remove not needed patch files/patch-src-server.c - Trim pkg-descr - Trim pkg-plist Note that the previous maintainer was ports@. PR: 179916 Submitted by: nemysis at gmx dot ch (new maintainer)
Notes
Notes: svn path=/head/; revision=322859
Diffstat (limited to 'audio/liblo')
-rw-r--r--audio/liblo/Makefile48
-rw-r--r--audio/liblo/distinfo4
-rw-r--r--audio/liblo/files/patch-src-lo_types_internal.h16
-rw-r--r--audio/liblo/files/patch-src-server.c43
-rw-r--r--audio/liblo/pkg-descr8
-rw-r--r--audio/liblo/pkg-plist13
6 files changed, 67 insertions, 65 deletions
diff --git a/audio/liblo/Makefile b/audio/liblo/Makefile
index 605acff2b694..67a514119cdc 100644
--- a/audio/liblo/Makefile
+++ b/audio/liblo/Makefile
@@ -1,21 +1,53 @@
-# New ports collection makefile for: liblo
-# Date created: 2006-12-04
-# Whom: trasz <trasz@pin.if.uz.zgora.pl>
-#
+# Created by: trasz <trasz@pin.if.uz.zgora.pl>
# $FreeBSD$
-#
PORTNAME= liblo
-PORTVERSION= 0.26
+PORTVERSION= 0.27
CATEGORIES= audio
MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= nemysis@gmx.ch
COMMENT= Lightweight Open Sound Control implementation
+LICENSE= LGPL21
+
+BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
+
+USES= pathfix
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
-USES= pathfix
+
+MAN3= liblo.3 liblolowlevel.3 lo.h.3 lo_arg.3 lo_lowlevel.h.3 \
+ lo_osc_types.h.3 lo_timetag.3 lo_types.h.3 pp.3
+
+PORTDOCS= *
+
+DOCSRCDIR1= ${WRKSRC}
+DOC_FILES1= AUTHORS ChangeLog NEWS README TODO
+
+PORTEXAMPLES= example_client example_server \
+ example_tcp_echo_server nonblocking_server_example
+
+OPTIONS_DEFINE= DOCS DOXYGEN EXAMPLES
+
+.include <bsd.port.options.mk>
+
+post-install:
+ cd ${WRKSRC}/doc/man/man3 && ${INSTALL_MAN} ${MAN3} ${MAN3PREFIX}/man/man3
+
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${DOCSDIR}
+.endif
+
+.if ${PORT_OPTIONS:MDOXYGEN} && ${PORT_OPTIONS:MDOCS}
+ @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} html ${DOCSDIR})
+.endif
+
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${PORTEXAMPLES:S|^|${WRKSRC}/examples/|} ${EXAMPLESDIR}
+.endif
.include <bsd.port.mk>
diff --git a/audio/liblo/distinfo b/audio/liblo/distinfo
index de7d5eecab87..a88f469e4f93 100644
--- a/audio/liblo/distinfo
+++ b/audio/liblo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (liblo-0.26.tar.gz) = a636fb09f8178ad0d5303e94fec37b182d3062a0e3daee85eed2a39ab6232258
-SIZE (liblo-0.26.tar.gz) = 519750
+SHA256 (liblo-0.27.tar.gz) = 67b48e1e63fddea60bb4a0f0c25fba32ea42d2a55877752aa342c478b59374b6
+SIZE (liblo-0.27.tar.gz) = 533684
diff --git a/audio/liblo/files/patch-src-lo_types_internal.h b/audio/liblo/files/patch-src-lo_types_internal.h
index e223c5c9b424..8ad55955f6f6 100644
--- a/audio/liblo/files/patch-src-lo_types_internal.h
+++ b/audio/liblo/files/patch-src-lo_types_internal.h
@@ -1,10 +1,18 @@
---- src/lo_types_internal.h.orig Mon Dec 4 23:29:22 2006
-+++ src/lo_types_internal.h Mon Dec 4 23:29:32 2006
-@@ -9,6 +9,7 @@
+--- src/lo_types_internal.h.orig 2013-05-22 18:34:31.000000000 +0200
++++ src/lo_types_internal.h 2013-06-24 01:54:53.000000000 +0200
+@@ -20,6 +20,7 @@
+ #else
+ #define closesocket close
+ #include <netdb.h>
++#include <netinet/in.h>
+ #include <arpa/inet.h>
#endif
+@@ -33,6 +34,7 @@
+
+ #ifdef ENABLE_THREADS
#include <pthread.h>
+#include <sys/socket.h>
+ #endif
#include "lo/lo_osc_types.h"
-
diff --git a/audio/liblo/files/patch-src-server.c b/audio/liblo/files/patch-src-server.c
deleted file mode 100644
index dab8fc1bb319..000000000000
--- a/audio/liblo/files/patch-src-server.c
+++ /dev/null
@@ -1,43 +0,0 @@
---- src/server.c.orig 2009-03-06 08:09:26.000000000 +0100
-+++ src/server.c 2009-03-28 10:19:58.000000000 +0100
-@@ -958,38 +958,11 @@ static void dispatch_method(lo_server s,
-
- //inet_ntop(s->addr.ss_family, &s->addr.padding, hostname, sizeof(hostname));
- if (s->protocol == LO_UDP && s->addr_len>0) {
-- err = getnameinfo((struct sockaddr *)&s->addr, sizeof(s->addr),
-+ err = getnameinfo((struct sockaddr *)&s->addr, s->addr.ss_len,
- hostname, sizeof(hostname), portname, sizeof(portname),
- NI_NUMERICHOST | NI_NUMERICSERV);
- if (err) {
-- switch (err) {
-- case EAI_AGAIN:
-- lo_throw(s, err, "Try again", path);
-- break;
-- case EAI_BADFLAGS:
-- lo_throw(s, err, "Bad flags", path);
-- break;
-- case EAI_FAIL:
-- lo_throw(s, err, "Failed", path);
-- break;
-- case EAI_FAMILY:
-- lo_throw(s, err, "Cannot resolve address family", path);
-- break;
-- case EAI_MEMORY:
-- lo_throw(s, err, "Out of memory", path);
-- break;
-- case EAI_NONAME:
-- lo_throw(s, err, "Cannot resolve", path);
-- break;
--#ifndef WIN32
-- case EAI_SYSTEM:
-- lo_throw(s, err, strerror(err), path);
-- break;
--#endif
-- default:
-- lo_throw(s, err, "Unknown error", path);
-- break;
-- }
-+ lo_throw(s, err, gai_strerror(err), path);
-
- return;
- }
diff --git a/audio/liblo/pkg-descr b/audio/liblo/pkg-descr
index 4f706b5482d9..022c16425283 100644
--- a/audio/liblo/pkg-descr
+++ b/audio/liblo/pkg-descr
@@ -1,4 +1,8 @@
-liblo is an implementation of the Open Sound Control
-protocol for POSIX systems.
+liblo is a lightweight library that provides an easy to use implementation of
+the Open Sound Control protocol for POSIX systems. For more information about
+the Open Sound Control protocol, please see:
+
+ - [OSC at CNMAT](http://www.cnmat.berkeley.edu/OpenSoundControl/)
+ - [opensoundcontrol.org](http://www.opensoundcontrol.org/)
WWW: http://liblo.sourceforge.net/
diff --git a/audio/liblo/pkg-plist b/audio/liblo/pkg-plist
index 2032815e3d7a..7110911af7aa 100644
--- a/audio/liblo/pkg-plist
+++ b/audio/liblo/pkg-plist
@@ -1,15 +1,16 @@
bin/oscdump
bin/oscsend
-include/lo/lo_errors.h
include/lo/lo.h
+include/lo/lo_endian.h
+include/lo/lo_errors.h
include/lo/lo_lowlevel.h
+include/lo/lo_macros.h
+include/lo/lo_osc_types.h
+include/lo/lo_serverthread.h
include/lo/lo_throw.h
include/lo/lo_types.h
-include/lo/lo_osc_types.h
-include/lo/lo_endian.h
-include/lo/lo_macros.h
-lib/liblo.so.7
-lib/liblo.so
lib/liblo.la
+lib/liblo.so
+lib/liblo.so.8
libdata/pkgconfig/liblo.pc
@dirrm include/lo