aboutsummaryrefslogtreecommitdiff
path: root/audio/liblo
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-08-12 14:33:42 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-08-12 14:33:42 +0000
commit8281aca21862520304719d72ffbd1c736c9f8c17 (patch)
treed0981c3a10b17e529db42b28e3c7b2f387164c45 /audio/liblo
parente5c97b75ccc32082d08b5b212997fab0e2edf800 (diff)
downloadports-8281aca21862520304719d72ffbd1c736c9f8c17.tar.gz
ports-8281aca21862520304719d72ffbd1c736c9f8c17.zip
- Unbreak the build on PowerPC and consumers' builds on i386
- Make DOXYGEN builddep optional (and off by default) - Sort USES values alphabetically - Simplify Makefile a bit (get rid of DOCSRCDIR1 and DOC_FILES1) - Remove traces of markdown in pkg-descr (unsupported in ports) Approved by: maintainer
Notes
Notes: svn path=/head/; revision=364706
Diffstat (limited to 'audio/liblo')
-rw-r--r--audio/liblo/Makefile36
-rw-r--r--audio/liblo/pkg-descr4
-rw-r--r--audio/liblo/pkg-plist20
3 files changed, 33 insertions, 27 deletions
diff --git a/audio/liblo/Makefile b/audio/liblo/Makefile
index 479f6ae027bd..a647e8219456 100644
--- a/audio/liblo/Makefile
+++ b/audio/liblo/Makefile
@@ -1,9 +1,9 @@
-# Created by: trasz <trasz@pin.if.uz.zgora.pl>
+# Created by: Edward Tomasz Napierala <trasz@pin.if.uz.zgora.pl>
# $FreeBSD$
PORTNAME= liblo
PORTVERSION= 0.28
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= SF
@@ -12,9 +12,7 @@ COMMENT= Lightweight Open Sound Control implementation
LICENSE= LGPL21
-BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
-
-USES= gmake pathfix libtool:oldver
+USES= gmake libtool:oldver pathfix
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
@@ -22,25 +20,33 @@ SHLIB_VER= 9
PLIST_SUB+= SHLIB_VER="${SHLIB_VER}"
PORTDOCS= *
-
-DOCSRCDIR1= ${WRKSRC}
-DOC_FILES1= AUTHORS ChangeLog NEWS README TODO
-
PORTEXAMPLES= example_client example_server \
example_tcp_echo_server nonblocking_server_example
-OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONS_DEFINE= DOXYGEN DOCS EXAMPLES
+OPTIONS_SUB= yes
+
+DOXYGEN_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
+
+.include <bsd.port.options.mk>
+
+post-patch:
+.if ${ARCH} == i386 || ${ARCH} == powerpc
+ @${REINPLACE_CMD} -e 's,deadbeef,, ; s,f00baa23,,' \
+ ${WRKSRC}/lo/lo_macros.h
+.endif
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/liblo.so.${SHLIB_VER}
-
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in AUTHORS ChangeLog NEWS README TODO
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
+.endfor
+.if ${PORT_OPTIONS:MDOXYGEN}
(cd ${WRKSRC}/doc/man/man3 && ${INSTALL_MAN} l*.3 p*.3 \
${STAGEDIR}${MAN3PREFIX}/man/man3/)
-
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} html ${STAGEDIR}${DOCSDIR})
-
+.endif
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_SCRIPT} ${PORTEXAMPLES:S|^|${WRKSRC}/examples/|} \
${STAGEDIR}${EXAMPLESDIR}
diff --git a/audio/liblo/pkg-descr b/audio/liblo/pkg-descr
index 022c16425283..8b20259ab206 100644
--- a/audio/liblo/pkg-descr
+++ b/audio/liblo/pkg-descr
@@ -2,7 +2,7 @@ liblo is a lightweight library that provides an easy to use implementation of
the Open Sound Control protocol for POSIX systems. For more information about
the Open Sound Control protocol, please see:
- - [OSC at CNMAT](http://www.cnmat.berkeley.edu/OpenSoundControl/)
- - [opensoundcontrol.org](http://www.opensoundcontrol.org/)
+ - http://www.cnmat.berkeley.edu/OpenSoundControl/
+ - http://www.opensoundcontrol.org/
WWW: http://liblo.sourceforge.net/
diff --git a/audio/liblo/pkg-plist b/audio/liblo/pkg-plist
index 56d1311e6308..4788608564c0 100644
--- a/audio/liblo/pkg-plist
+++ b/audio/liblo/pkg-plist
@@ -14,14 +14,14 @@ lib/liblo.la
lib/liblo.so
lib/liblo.so.%%SHLIB_VER%%
libdata/pkgconfig/liblo.pc
-man/man3/liblo.3.gz
-man/man3/liblolowlevel.3.gz
-man/man3/lo.h.3.gz
-man/man3/lo_arg.3.gz
-man/man3/lo_lowlevel.h.3.gz
-man/man3/lo_osc_types.h.3.gz
-man/man3/lo_serverthread.h.3.gz
-man/man3/lo_timetag.3.gz
-man/man3/lo_types.h.3.gz
-man/man3/pp.3.gz
+%%DOXYGEN%%man/man3/liblo.3.gz
+%%DOXYGEN%%man/man3/liblolowlevel.3.gz
+%%DOXYGEN%%man/man3/lo.h.3.gz
+%%DOXYGEN%%man/man3/lo_arg.3.gz
+%%DOXYGEN%%man/man3/lo_lowlevel.h.3.gz
+%%DOXYGEN%%man/man3/lo_osc_types.h.3.gz
+%%DOXYGEN%%man/man3/lo_serverthread.h.3.gz
+%%DOXYGEN%%man/man3/lo_timetag.3.gz
+%%DOXYGEN%%man/man3/lo_types.h.3.gz
+%%DOXYGEN%%man/man3/pp.3.gz
@dirrm include/lo